Bug 271890 - KDE Wallet Service crashed
Summary: KDE Wallet Service crashed
Status: RESOLVED DUPLICATE of bug 271889
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kshareddatacache (show other bugs)
Version: 0.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 271892 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-28 03:20 UTC by rflazaro
Modified: 2011-04-29 00:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rflazaro 2011-04-28 03:20:14 UTC
Application: kwalletd (0.2)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.39-rc4-12-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was running BleachBit to clean out unnecessary files on my machine

-- Backtrace:
Application: KDE Wallet Service (kdeinit4), signal: Bus error
[KCrash Handler]
#6  0x00007fd5eb5accdd in lock (this=0x7fff98ae3120, _d=0x782f40) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1098
#7  cautiousLock (this=0x7fff98ae3120, _d=0x782f40) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1121
#8  KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff98ae3120, _d=0x782f40) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1146
#9  0x00007fd5eb502d60 in KSharedDataCache::find (this=0x71ab40, key=..., destination=0x7fff98ae3200) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1462
#10 0x00007fd5ebe241dc in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x78aa40, key=..., data=..., path=...) at /usr/src/debug/kdelibs-4.6.0/kdeui/icons/kiconloader.cpp:868
#11 0x00007fd5ebe2bd6e in KIconLoader::loadIcon (this=0x790d10, _name=<value optimized out>, group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.0/kdeui/icons/kiconloader.cpp:1231
#12 0x00007fd5ebe2ce00 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/icons/kiconengine.cpp:93
#13 0x00007fd5ea2c5c45 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#14 0x00007fd5ea2b963a in QWidgetPrivate::setWindowIcon_sys (this=0x7802f0, forceReset=false) at kernel/qwidget_x11.cpp:1456
#15 0x00007fd5ea26ceea in QWidget::setWindowIcon (this=<value optimized out>, icon=...) at kernel/qwidget.cpp:5997
#16 0x00007fd5ebe6acae in KPasswordDialog::KPasswordDialog (this=0x7601a0, parent=<value optimized out>, flags=..., otherButtons=...) at /usr/src/debug/kdelibs-4.6.0/kdeui/dialogs/kpassworddialog.cpp:71
#17 0x00007fd5d9e1a26f in ?? () from /usr/lib64/libkdeinit4_kwalletd.so
#18 0x00007fd5d9e1c724 in ?? () from /usr/lib64/libkdeinit4_kwalletd.so
#19 0x00007fd5d9e1d876 in ?? () from /usr/lib64/libkdeinit4_kwalletd.so
#20 0x00007fd5d9e1e3dd in ?? () from /usr/lib64/libkdeinit4_kwalletd.so
#21 0x00007fd5eb083a6a in QObject::event (this=0x7fff98ae5070, e=<value optimized out>) at kernel/qobject.cpp:1211
#22 0x00007fd5ea21ed14 in QApplicationPrivate::notify_helper (this=0x712ad0, receiver=0x7fff98ae5070, e=0x7a46b0) at kernel/qapplication.cpp:4445
#23 0x00007fd5ea22722a in QApplication::notify (this=<value optimized out>, receiver=0x7fff98ae5070, e=0x7a46b0) at kernel/qapplication.cpp:4324
#24 0x00007fd5ebd139e6 in KApplication::notify (this=0x7fff98ae5120, receiver=0x7fff98ae5070, event=0x7a46b0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#25 0x00007fd5eb06fbfc in QCoreApplication::notifyInternal (this=0x7fff98ae5120, receiver=0x7fff98ae5070, event=0x7a46b0) at kernel/qcoreapplication.cpp:732
#26 0x00007fd5eb0733f5 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1373
#28 0x00007fd5eb09a783 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007fd5e691abd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#31 0x00007fd5e691b3b0 in ?? () from /lib64/libglib-2.0.so.0
#32 0x00007fd5e691b650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#33 0x00007fd5eb09a91f in QEventDispatcherGlib::processEvents (this=0x7128f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#34 0x00007fd5ea2c3d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007fd5eb06f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007fd5eb06f265 in QEventLoop::exec (this=0x7fff98ae4fc0, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007fd5eb0736ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x00007fd5d9e142b2 in kdemain () from /usr/lib64/libkdeinit4_kwalletd.so
#39 0x00000000004075e9 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2011-04-28 09:52:44 UTC
*** Bug 271892 has been marked as a duplicate of this bug. ***
Comment 2 Frank Reininghaus 2011-04-28 12:20:01 UTC
Looks like it's related to bug 271889.
Comment 3 Michael Pyne 2011-04-29 00:10:22 UTC

*** This bug has been marked as a duplicate of bug 271889 ***