Bug 271840 - KPlato crashed while loading template
Summary: KPlato crashed while loading template
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: kplato
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Dag Andersen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-27 13:55 UTC by Sebastian Stolp
Modified: 2013-03-04 06:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Stolp 2011-04-27 13:55:38 UTC
Application: kplato (0.10.1)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

I tryed to load the "8 hours / day, 40 hours / week" template to work with it. After clicking the "Use this template" - Button KPlato crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: KPlato (kdeinit4), signal: Floating point exception
[Current thread is 1 (Thread 0xb5963710 (LWP 9069))]

Thread 3 (Thread 0xac601b70 (LWP 9070)):
#0  0xb5bcbb34 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0xb5bcc8e2 in ?? () from /lib/libglib-2.0.so.0
#2  0xb5bccfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0xb6f5efc7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0xb6f2fa6d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb6f2fc99 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6e30d49 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0xb6f0f7fd in ?? () from /usr/lib/libQtCore.so.4
#8  0xb6e33993 in ?? () from /usr/lib/libQtCore.so.4
#9  0xb2e54de7 in ?? () from /usr/X11R6/lib/libGL.so.1
#10 0xb6170d5e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xa9cf3b70 (LWP 9071)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6dbb105 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0xb3725ed7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb383c1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0xb3725f1f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb383c1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0xb2e54de7 in ?? () from /usr/X11R6/lib/libGL.so.1
#5  0xb6170d5e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb5963710 (LWP 9069)):
[KCrash Handler]
#7  enter (table=0x8899c90, size=0, hash=722438103, name=0xb622b47f "_ZNSt7collateIwE2idE", sym=0xb62217fc, map=0xb6dcc550) at dl-lookup.c:318
#8  0xb78a07c1 in do_lookup_x (new_hash=4260546277, old_hash=0xbfa11d18, ref=0xa8d19fe4, result=0xbfa11d0c, scope=0x8899a4c, i=<value optimized out>, flags=1, skip=0x0, undef_map=0x88998f0) at dl-lookup.c:400
#9  0xb78a0b99 in _dl_lookup_symbol_x (undef_name=0xa8d2334e "_ZZN11QMetaTypeIdIPcE14qt_metatype_idEvE11metatype_id", undef_map=0x88998f0, ref=0xbfa11db8, symbol_scope=0x8899aa8, version=0x0, type_class=0, flags=1, skip_map=0x0) at dl-lookup.c:736
#10 0xb78a24ab in elf_machine_rel (scope=0x8899aa8, reloc_mode=0, consider_profiling=0) at ../sysdeps/i386/dl-machine.h:344
#11 elf_dynamic_do_rel (scope=0x8899aa8, reloc_mode=0, consider_profiling=0) at do-rel.h:120
#12 _dl_relocate_object (scope=0x8899aa8, reloc_mode=0, consider_profiling=0) at dl-reloc.c:268
#13 0xb78a98e3 in dl_open_worker (a=0xbfa11f30) at dl-open.c:338
#14 0xb78a55ff in _dl_catch_error (objname=0xbfa11f58, errstring=0xbfa11f54, mallocedp=0xbfa11f5f, operate=0xb78a9670 <dl_open_worker>, args=0xbfa11f30) at dl-error.c:178
#15 0xb78a93a6 in _dl_open (file=0x8899808 "/usr/lib/qt4/plugins/script/libqtscript_core.so.1.0.0", mode=-2147483647, caller_dlopen=0xb6f20924, nsid=-2, argc=4, argv=0xbfa152c4, env=0x80e2c40) at dl-open.c:554
#16 0xb5ce9bdd in dlopen_doit (a=0xbfa12100) at dlopen.c:67
#17 0xb78a55ff in _dl_catch_error (objname=0x80725a4, errstring=0x80725a8, mallocedp=0x80725a0, operate=0xb5ce9b40 <dlopen_doit>, args=0xbfa12100) at dl-error.c:178
#18 0xb5cea342 in _dlerror_run (operate=0xb5ce9b40 <dlopen_doit>, args=<value optimized out>) at dlerror.c:164
#19 0xb5ce9ca7 in __dlopen (file=0x8899808 "/usr/lib/qt4/plugins/script/libqtscript_core.so.1.0.0", mode=1) at dlopen.c:88
#20 0xb6f20924 in ?? () from /usr/lib/libQtCore.so.4
#21 0xb6f1b484 in ?? () from /usr/lib/libQtCore.so.4
#22 0xb6f1b568 in ?? () from /usr/lib/libQtCore.so.4
#23 0xb6f15213 in QPluginLoader::load() () from /usr/lib/libQtCore.so.4
#24 0xb6f15242 in QPluginLoader::instance() () from /usr/lib/libQtCore.so.4
#25 0xb377d6f3 in QScriptEngine::importExtension (this=0x88958a0, extension=...) at api/qscriptengine.cpp:3591
#26 0xabd8e7d4 in Kross::EcmaScript::Private::init (this=0x88951e8) at /usr/src/debug/kdelibs-4.6.2/kross/qts/script.cpp:54
#27 0xabd8bc67 in Kross::EcmaScript::execute (this=0x8837e60) at /usr/src/debug/kdelibs-4.6.2/kross/qts/script.cpp:179
#28 0xad1f9255 in Kross::Action::slotTriggered (this=0x8893278) at /usr/src/debug/kdelibs-4.6.2/kross/core/action.cpp:528
#29 0xad1fa1ed in Kross::Action::qt_metacall (this=0x8893278, _c=QMetaObject::InvokeMetaMethod, _id=32, _a=0xbfa128d8) at /usr/src/debug/kdelibs-4.6.2/build/kross/core/action.moc:186
#30 0xb6f3707d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#31 0xb6f464cc in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#32 0xb643158d in QAction::triggered (this=0x8893278, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#33 0xb643182b in QAction::activate (this=0x8893278, event=QAction::Trigger) at kernel/qaction.cpp:1257
#34 0xad4d5a30 in trigger (this=0x88940d8) at /usr/include/QtGui/qaction.h:218
#35 KRScriptHandler::trigger (this=0x88940d8) at /usr/src/debug/koffice-2.3.1/libs/koreport/renderer/scripting/krscripthandler.cpp:102
#36 0xad4ca82f in KoReportPreRenderer::generate (this=0x8842d58) at /usr/src/debug/koffice-2.3.1/libs/koreport/renderer/KoReportPreRenderer.cpp:538
#37 0xadc4dba0 in KPlato::ReportView::refresh (this=0x882f9d8) at /usr/src/debug/koffice-2.3.1/kplato/libs/ui/reports/reportview.cpp:415
#38 0xadc4dfa8 in KPlato::ReportView::loadXML (this=0x882f9d8, doc=...) at /usr/src/debug/koffice-2.3.1/kplato/libs/ui/reports/reportview.cpp:462
#39 0xae00a244 in KPlato::View::createViews (this=0x8348608) at /usr/src/debug/koffice-2.3.1/kplato/kptview.cpp:487
#40 0xae00dd66 in KPlato::View::View (this=0x8348608, part=0x8210cf8, parent=0x82634a0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/koffice-2.3.1/kplato/kptview.cpp:192
#41 0xadfef4f3 in KPlato::Part::createViewInstance (this=0x8210cf8, parent=0x82634a0) at /usr/src/debug/koffice-2.3.1/kplato/kptpart.cpp:172
#42 0xb0de71d2 in KoDocument::createView (this=0x8210cf8, parent=0x82634a0) at /usr/src/debug/koffice-2.3.1/libs/main/KoDocument.cpp:428
#43 0xb0e1af60 in KoMainWindow::setRootDocument (this=0x823cca0, doc=0x8210cf8) at /usr/src/debug/koffice-2.3.1/libs/main/KoMainWindow.cpp:464
#44 0xb0decd1d in KoDocument::deleteOpenPane (this=0x8210cf8) at /usr/src/debug/koffice-2.3.1/libs/main/KoDocument.cpp:2490
#45 0xb0ded423 in KoDocument::openTemplate (this=0x8210cf8, url=...) at /usr/src/debug/koffice-2.3.1/libs/main/KoDocument.cpp:2430
#46 0xadfec3ce in KPlato::Part::openTemplate (this=0x8210cf8, url=...) at /usr/src/debug/koffice-2.3.1/kplato/kptpart.cpp:754
#47 0xadff79c6 in KPlato::Part::qt_metacall (this=0x8210cf8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa134f8) at /usr/src/debug/koffice-2.3.1/build/kplato/kptpart.moc:103
#48 0xb6f3707d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#49 0xb6f464cc in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#50 0xb0e59c45 in KoOpenPane::openTemplate (this=0x8287a68, _t1=...) at /usr/src/debug/koffice-2.3.1/build/libs/main/KoOpenPane.moc:111
#51 0xb0e5b6f3 in KoOpenPane::qt_metacall (this=0x8287a68, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa13618) at /usr/src/debug/koffice-2.3.1/build/libs/main/KoOpenPane.moc:87
#52 0xb6f3707d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#53 0xb6f464cc in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#54 0xb0e58115 in KoDetailsPane::openUrl (this=0x839a810, _t1=...) at /usr/src/debug/koffice-2.3.1/build/libs/main/KoDetailsPane.moc:105
#55 0xb0e6494b in KoTemplatesPane::openFile (this=0x839a810, index=...) at /usr/src/debug/koffice-2.3.1/libs/main/KoTemplatesPane.cpp:138
#56 0xb0e57e4b in KoDetailsPane::openFile (this=0x839a810) at /usr/src/debug/koffice-2.3.1/libs/main/KoDetailsPane.cpp:120
#57 0xb0e6469b in KoTemplatesPane::openFile (this=0x839a810) at /usr/src/debug/koffice-2.3.1/libs/main/KoTemplatesPane.cpp:127
#58 0xb0e58237 in KoDetailsPane::qt_metacall (this=0x839a810, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa13868) at /usr/src/debug/koffice-2.3.1/build/libs/main/KoDetailsPane.moc:91
#59 0xb0e650c2 in KoTemplatesPane::qt_metacall (this=0x839a810, _c=QMetaObject::InvokeMetaMethod, _id=31, _a=0xbfa13868) at /usr/src/debug/koffice-2.3.1/build/libs/main/KoTemplatesPane.moc:79
#60 0xb6f3707d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#61 0xb6f464cc in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#62 0xb6b5d45d in QAbstractButton::clicked (this=0x8138e28, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#63 0xb68567cd in QAbstractButtonPrivate::emitClicked (this=0x83bc2d0) at widgets/qabstractbutton.cpp:546
#64 0xb68580ab in QAbstractButtonPrivate::click (this=0x83bc2d0) at widgets/qabstractbutton.cpp:539
#65 0xb6858366 in QAbstractButton::mouseReleaseEvent (this=0x8138e28, e=0xbfa13f84) at widgets/qabstractbutton.cpp:1121
#66 0xb6493af0 in QWidget::event (this=0x8138e28, event=0xbfa13f84) at kernel/qwidget.cpp:8259
#67 0xb6857380 in QAbstractButton::event (this=0x8138e28, e=0xbfa13f84) at widgets/qabstractbutton.cpp:1080
#68 0xb68f9918 in QPushButton::event (this=0x8138e28, e=0xbfa13f84) at widgets/qpushbutton.cpp:683
#69 0xb6438684 in QApplicationPrivate::notify_helper (this=0x81047c8, receiver=0x8138e28, e=0xbfa13f84) at kernel/qapplication.cpp:4462
#70 0xb6441f80 in QApplication::notify (this=0xbfa13c9c, receiver=0x8138e28, e=0xbfa13f84) at kernel/qapplication.cpp:4023
#71 0xb758c5b1 in KApplication::notify (this=0xbfa147c0, receiver=0x8138e28, event=0xbfa13f84) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#72 0xb6f3078e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#73 0xb643972c in sendSpontaneousEvent (receiver=0x8138e28, event=0xbfa13f84, alienWidget=0x8138e28, nativeWidget=0x823cca0, buttonDown=0xb6dadc00, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#74 QApplicationPrivate::sendMouseEvent (receiver=0x8138e28, event=0xbfa13f84, alienWidget=0x8138e28, nativeWidget=0x823cca0, buttonDown=0xb6dadc00, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#75 0xb64c5bb0 in QETWidget::translateMouseEvent (this=0x823cca0, event=0xbfa1449c) at kernel/qapplication_x11.cpp:4461
#76 0xb64c4cbe in QApplication::x11ProcessEvent (this=0xbfa147c0, event=0xbfa1449c) at kernel/qapplication_x11.cpp:3465
#77 0xb64ef5e0 in x11EventSourceDispatch (s=0x8107010, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#78 0xb5bcc509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#79 0xb5bccd10 in ?? () from /lib/libglib-2.0.so.0
#80 0xb5bccfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#81 0xb6f5ef7b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#82 0xb64ef1da in QGuiEventDispatcherGlib::processEvents (this=0x80e91f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0xb6f2fa6d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#84 0xb6f2fc99 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#85 0xb6f34740 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#86 0xb64363d4 in QApplication::exec () at kernel/qapplication.cpp:3736
#87 0xb5580545 in kdemain (argc=1, argv=0x80e10a8) at /usr/src/debug/koffice-2.3.1/kplato/main.cpp:41
#88 0x0804e514 in launch (argc=1, _name=0x80dc99c "kplato", args=<value optimized out>, cwd=0x0, envc=1, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80525c3 "0") at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:734
#89 0x0804f02f in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:1226
#90 0x0804f6dc in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:1419
#91 0x08050559 in main (argc=143235312, argv=0x0, envp=0x0) at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 264350.

Possible duplicates by query: bug 269995, bug 264350, bug 263337, bug 261129, bug 255221.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-04 06:20:48 UTC

*** This bug has been marked as a duplicate of bug 251719 ***