Bug 255221 - KTorrent crash
Summary: KTorrent crash
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-25 15:53 UTC by mail.zausa.giulio
Modified: 2010-10-25 19:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mail.zausa.giulio 2010-10-25 15:53:31 UTC
Application: ktorrent (4.0.4)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.4-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
Starting KTorrent in LXDE with one torrent loaded.

- Unusual behavior I noticed:
Plasma don't start.

- Custom settings of the application:
NVIDIA 260 driver installed

The crash can be reproduced every time.

-- Backtrace:
Application: KTorrent (ktorrent), signal: Floating point exception
[KCrash Handler]
#7  0xb77f410a in enter.8103 () from /lib/ld-linux.so.2
#8  0xb77f4771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb77f4b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb77f645b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb77fd82e in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb77f950f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb77fd2e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb510cbdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb77f950f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb510d342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb510cca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb69c23e5 in QLibraryPrivate::load_sys (this=0x82efa60) at plugin/qlibrary_unix.cpp:205
#19 0xb69bc864 in QLibraryPrivate::load (this=0x82efa60) at plugin/qlibrary.cpp:484
#20 0xadd10abe in loadLibrary (libname=0xadd1dd1a "krosspython", functionname=0xadd1dd09 "krossinterpreter") at /usr/src/debug/kdelibs-4.5.2/kross/core/manager.cpp:89
#21 0xadd14c3f in Kross::Manager::Manager (this=0x82e4b90) at /usr/src/debug/kdelibs-4.5.2/kross/core/manager.cpp:132
#22 0xadd164cf in _self () at /usr/src/debug/kdelibs-4.5.2/kross/core/manager.cpp:71
#23 Kross::Manager::self () at /usr/src/debug/kdelibs-4.5.2/kross/core/manager.cpp:75
#24 0xadd59f2d in ?? () from /usr/lib/kde4/ktscriptingplugin.so
#25 0xb7639b43 in kt::PluginManager::load(KPluginInfo const&, int) () from /usr/lib/libktcore.so.11
#26 0xb763a119 in kt::PluginManager::loadPlugins() () from /usr/lib/libktcore.so.11
#27 0xb763a467 in kt::PluginManager::loadPluginList() () from /usr/lib/libktcore.so.11
#28 0x08079106 in ?? ()
#29 0x0807a795 in ?? ()
#30 0xb70b1603 in KUniqueApplicationAdaptor::newInstance (this=0x81f3878, asn_id=..., args=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kuniqueapplication.cpp:440
#31 0xb70b16bc in KUniqueApplicationAdaptor::qt_metacall (this=0x81f3878, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa0c6fc)
    at /usr/src/debug/kdelibs-4.5.2/build/kdeui/kuniqueapplication_p.moc:81
#32 0xb5578e27 in QDBusConnectionPrivate::deliverCall (this=0x8137e70, object=0x81f3878, msg=..., metaTypes=..., slotIdx=-1580852999) at qdbusintegrator.cpp:919
#33 0xb5579ca7 in QDBusConnectionPrivate::activateCall (this=0x8137e70, object=0x81f3878, flags=337, msg=...) at qdbusintegrator.cpp:822
#34 0xb557a438 in QDBusConnectionPrivate::activateObject (this=0x8137e70, node=..., msg=..., pathStartPos=135498328) at qdbusintegrator.cpp:1399
#35 0xb557a938 in QDBusActivateObjectEvent::placeMetaCall (this=0x813e720) at qdbusintegrator.cpp:1493
#36 0xb69e769f in QObject::event (this=0xbfa0d110, e=0x813e720) at kernel/qobject.cpp:1211
#37 0xb69d271a in QCoreApplication::event (this=0xbfa0d110, e=0x813e720) at kernel/qcoreapplication.cpp:1561
#38 0xb5ed48dd in QApplication::event (this=0xbfa0d110, e=0x813e720) at kernel/qapplication.cpp:2439
#39 0xb5ed21a4 in QApplicationPrivate::notify_helper (this=0x8141e30, receiver=0xbfa0d110, e=0x813e720) at kernel/qapplication.cpp:4396
#40 0xb5edadd7 in QApplication::notify (this=0xbfa0d110, receiver=0xbfa0d110, e=0x813e720) at kernel/qapplication.cpp:3798
#41 0x0807a8a7 in ?? ()
#42 0xb69d212e in QCoreApplication::notifyInternal (this=0xbfa0d110, receiver=0xbfa0d110, event=0x813e720) at kernel/qcoreapplication.cpp:732
#43 0xb69d5e6c in sendEvent (receiver=0x0, event_type=0, data=0x8119f68) at kernel/qcoreapplication.h:215
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8119f68) at kernel/qcoreapplication.cpp:1373
#45 0xb69d5fbc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#46 0xb6a006d4 in sendPostedEvents (s=0x8144d90) at kernel/qcoreapplication.h:220
#47 postEventSourceDispatch (s=0x8144d90) at kernel/qeventdispatcher_glib.cpp:277
#48 0xb5054b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#49 0xb5055350 in ?? () from /usr/lib/libglib-2.0.so.0
#50 0xb505560e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#51 0xb6a0085b in QEventDispatcherGlib::processEvents (this=0x811d980, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#52 0xb5f8719a in QGuiEventDispatcherGlib::processEvents (this=0x811d980, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0xb69d140d in QEventLoop::processEvents (this=0xbfa0d084, flags=...) at kernel/qeventloop.cpp:149
#54 0xb69d1639 in QEventLoop::exec (this=0xbfa0d084, flags=...) at kernel/qeventloop.cpp:201
#55 0xb69d6090 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#56 0xb5ecfed4 in QApplication::exec () at kernel/qapplication.cpp:3672
#57 0x080699a1 in _start ()

Reported using DrKonqi
Comment 1 Joris Guisson 2010-10-25 17:56:13 UTC
This is a kross problem
Comment 2 Christoph Feck 2010-10-25 19:08:41 UTC

*** This bug has been marked as a duplicate of bug 251719 ***