Bug 269995 - kNotify4 crashes when date or time is tried to adjust
Summary: kNotify4 crashes when date or time is tried to adjust
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knotify (show other bugs)
Version: 4.0
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-03 13:30 UTC by milde.markus
Modified: 2011-04-03 16:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description milde.markus 2011-04-03 13:30:39 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
After a standard installation of opensuse 11.3 everything except the multimedia part worked fine. After having installed VLC-Player also this part worked fine. So I decided to deinstalled xine, kaffeine and the other multimedia related stuff, because I believed that there is no more requirements in the system working with VLC-player now. The applications where I got a warning or an error from YAST when I tried to deinstall, I left installed on my system.

Already the next day I used my LINUX system I got the message - and all other users on this system too -in a big window with "Es tut uns sehr leid; das Programm KDE-Kontrollmodul wurde unerwartet beendet. Sie können..."

For the reason that all my needed Applications worked fine I did not care, clicked on "close" and continued working. Some search on many forums with huge variations of search items did not help me at all - I give up.

Now the daylight saving time has come and the system clock is set to a wrong value by the automatic setting and I tried to correct it in two ways:
1. right mouse button click on the clock in the system tray -> same window  "Es tut uns sehr leid..." occurs
2.  KDE-Menu -> Systemeinstellungen -> Datum&Zeit; same window like in #1.

Please help me in getting back the required application that the crash can be avoided.

Info: I do not use PLASMA. I read all the infos related to the bug entries mentioned below and I did not have the time yet to install another nVidia driver. I did not have any idea that this could be related to my issues.

Thanks a lot in advance.

 -- Backtrace:
Application: KNotify (knotify4), signal: Floating point exception
[KCrash Handler]
#6  0xb77d010a in enter.8102 () from /lib/ld-linux.so.2
#7  0xb77d0771 in do_lookup_x () from /lib/ld-linux.so.2
#8  0xb77d0b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#9  0xb77d245b in _dl_relocate_object () from /lib/ld-linux.so.2
#10 0xb77d9823 in dl_open_worker () from /lib/ld-linux.so.2
#11 0xb77d550f in _dl_catch_error () from /lib/ld-linux.so.2
#12 0xb77d92e6 in _dl_open () from /lib/ld-linux.so.2
#13 0xb5cc5bdd in dlopen_doit () from /lib/libdl.so.2
#14 0xb77d550f in _dl_catch_error () from /lib/ld-linux.so.2
#15 0xb5cc6342 in _dlerror_run () from /lib/libdl.so.2
#16 0xb5cc5ca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#17 0xb3330269 in ?? () from /usr/lib/libvlccore.so.4
#18 0xb3329648 in ?? () from /usr/lib/libvlccore.so.4
#19 0xb33299d1 in ?? () from /usr/lib/libvlccore.so.4
#20 0xb33298c6 in ?? () from /usr/lib/libvlccore.so.4
#21 0xb3329eeb in ?? () from /usr/lib/libvlccore.so.4
#22 0xb32a2b2a in libvlc_InternalInit () from /usr/lib/libvlccore.so.4
#23 0xb3394eee in libvlc_new () from /usr/lib/libvlc.so.5
#24 0xb33e9235 in Phonon::VLC::vlcInit(int) () from /usr/lib/kde4/plugins/phonon_backend/phonon_vlc.so
#25 0xb33d84b2 in Phonon::VLC::Backend::Backend(QObject*, QList<QVariant> const&) () from /usr/lib/kde4/plugins/phonon_backend/phonon_vlc.so
#26 0xb33d8a73 in qt_plugin_instance () from /usr/lib/kde4/plugins/phonon_backend/phonon_vlc.so
#27 0xb6f6f274 in QPluginLoader::instance() () from /usr/lib/libQtCore.so.4
#28 0xb37a609c in Phonon::KdePlatformPlugin::createBackend (this=0x8197420, newService=...) at /usr/src/debug/kdebase-runtime-4.4.4/phonon/platform_kde/kdeplatformplugin.cpp:155
#29 0xb37a6f30 in Phonon::KdePlatformPlugin::createBackend (this=0x8197420) at /usr/src/debug/kdebase-runtime-4.4.4/phonon/platform_kde/kdeplatformplugin.cpp:204
#30 0xb73a8fe7 in Phonon::FactoryPrivate::createBackend (this=0x81a39d8) at /usr/src/debug/phonon-4.4.2/phonon/factory.cpp:119
#31 0xb73a97c3 in Phonon::Factory::backend (createWhenNull=true) at /usr/src/debug/phonon-4.4.2/phonon/factory.cpp:438
#32 0xb73aa418 in Phonon::Factory::createAudioOutput (parent=0x818ae10) at /usr/src/debug/phonon-4.4.2/phonon/factory.cpp:343
#33 0xb73a2bdb in Phonon::AudioOutputPrivate::createBackendObject (this=0x81a3b98) at /usr/src/debug/phonon-4.4.2/phonon/audiooutput.cpp:133
#34 0xb739fa26 in Phonon::AudioOutputPrivate::init (this=0x81a3b98, c=Phonon::NotificationCategory) at /usr/src/debug/phonon-4.4.2/phonon/audiooutput.cpp:106
#35 0x0805358c in Player (this=0x8157ab4) at /usr/src/debug/kdebase-runtime-4.4.4/knotify/notifybysound.cpp:59
#36 PlayerPool::getPlayer (this=0x8157ab4) at /usr/src/debug/kdebase-runtime-4.4.4/knotify/notifybysound.cpp:99
#37 0x08053b73 in NotifyBySound::notify (this=0x8178868, eventId=3, config=0x81890c8) at /usr/src/debug/kdebase-runtime-4.4.4/knotify/notifybysound.cpp:243
#38 0x0804f124 in KNotify::emitEvent (this=0xbfc227bc, e=0x81890c0) at /usr/src/debug/kdebase-runtime-4.4.4/knotify/knotify.cpp:179
#39 0x0804f63c in KNotify::event (this=0xbfc227bc, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0)
    at /usr/src/debug/kdebase-runtime-4.4.4/knotify/knotify.cpp:128
#40 0x0804f976 in KNotifyAdaptor::event (this=0x8170890, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0)
    at /usr/src/debug/kdebase-runtime-4.4.4/knotify/knotify.cpp:236
#41 0x0805017a in KNotifyAdaptor::qt_metacall (this=0x8170890, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfc21e0c) at /usr/src/debug/kdebase-runtime-4.4.4/build/knotify/knotify.moc:227
#42 0xb70c5a37 in QDBusConnectionPrivate::deliverCall (this=0x8080588, object=0x8170890, msg=..., metaTypes=..., slotIdx=-1580852999) at qdbusintegrator.cpp:904
#43 0xb70c7ca8 in QDBusConnectionPrivate::activateCall (this=0x8080588, object=0x8170890, flags=273, msg=...) at qdbusintegrator.cpp:816
#44 0xb70c8378 in QDBusConnectionPrivate::activateObject (this=0x8080588, node=..., msg=..., pathStartPos=135773288) at qdbusintegrator.cpp:1383
#45 0xb70c8878 in QDBusActivateObjectEvent::placeMetaCall (this=0x818a868) at qdbusintegrator.cpp:1477
#46 0xb6f9c93f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#47 0xb64dec64 in QApplicationPrivate::notify_helper (this=0x8089390, receiver=0xbfc227bc, e=0x818a868) at kernel/qapplication.cpp:4302
#48 0xb64e6bf7 in QApplication::notify (this=0xbfc227d0, receiver=0xbfc227bc, e=0x818a868) at kernel/qapplication.cpp:3706
#49 0xb74fb9d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#50 0xb6f89e0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#51 0xb6f8d9b4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#52 0xb6f8db9c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#53 0xb6fb583d in ?? () from /usr/lib/libQtCore.so.4
#54 0xb5c0db49 in g_main_dispatch (context=0x808b490) at gmain.c:1960
#55 IA__g_main_context_dispatch (context=0x808b490) at gmain.c:2513
#56 0xb5c0e350 in g_main_context_iterate (context=0x808b490, block=1, dispatch=1, self=0x8090ef8) at gmain.c:2591
#57 0xb5c0e60e in IA__g_main_context_iteration (context=0x808b490, may_block=1) at gmain.c:2654
#58 0xb6fb5d4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#59 0xb658f19a in QGuiEventDispatcherGlib::processEvents (this=0x806c438, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#60 0xb6f8911d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#61 0xb6f89319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#62 0xb6f8dc70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#63 0xb64dc164 in QApplication::exec () at kernel/qapplication.cpp:3581
#64 0x0804e53f in main (argc=136929160, argv=0x0) at /usr/src/debug/kdebase-runtime-4.4.4/knotify/main.cpp:73

Possible duplicates by query: bug 264350, bug 261129.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-04-03 16:35:45 UTC

*** This bug has been marked as a duplicate of bug 251719 ***