Bug 263337 - Kword crashes on startup
Summary: Kword crashes on startup
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: kword
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-16 17:42 UTC by ametedinov
Modified: 2011-01-16 20:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ametedinov 2011-01-16 17:42:43 UTC
Application: kword (2.1.2)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
When I tri opening a .doc document with Kword, the application crashes and closes on startup. 

If I open Kword from the gnome menu, the application opens normally. Then, it I go to file >> open and
select ANY .doc file and open it FROM KWORD, the program still crashes, not letting me even take a look at the .doc document

The crash can be reproduced every time.

 -- Backtrace:
Application: KWord (kword), signal: Floating point exception
[KCrash Handler]
#6  0xb78aa10a in enter.8102 () from /lib/ld-linux.so.2
#7  0xb78aa771 in do_lookup_x () from /lib/ld-linux.so.2
#8  0xb78aab49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#9  0xb78ac45b in _dl_relocate_object () from /lib/ld-linux.so.2
#10 0xb78b3823 in dl_open_worker () from /lib/ld-linux.so.2
#11 0xb78af50f in _dl_catch_error () from /lib/ld-linux.so.2
#12 0xb78b32e6 in _dl_open () from /lib/ld-linux.so.2
#13 0xb5514bdd in dlopen_doit () from /lib/libdl.so.2
#14 0xb78af50f in _dl_catch_error () from /lib/ld-linux.so.2
#15 0xb5515342 in _dlerror_run () from /lib/libdl.so.2
#16 0xb5514ca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#17 0xb6817469 in ?? () from /usr/lib/libQtCore.so.4
#18 0xb68119c4 in ?? () from /usr/lib/libQtCore.so.4
#19 0xaee702ee in loadLibrary (libname=0xaee7d978 "krosskjs", functionname=0xaee7d8e9 "krossinterpreter") at /usr/src/debug/kdelibs-4.4.4/kross/core/manager.cpp:89
#20 0xaee75391 in Kross::Manager::Manager (this=0x8e1fa80) at /usr/src/debug/kdelibs-4.4.4/kross/core/manager.cpp:173
#21 0xaee7643f in _self () at /usr/src/debug/kdelibs-4.4.4/kross/core/manager.cpp:71
#22 Kross::Manager::self () at /usr/src/debug/kdelibs-4.4.4/kross/core/manager.cpp:75
#23 0xaee98baa in KoScriptingPart::KoScriptingPart (this=0x8a42a90, __vtt_parm=0xaeeda5b4, module=0x8e2f658, __in_chrg=<value optimized out>)
    at /usr/src/debug/koffice-2.1.2/libs/kokross/KoScriptingPart.cpp:93
#24 0xaeecf186 in KWScriptingPart::KWScriptingPart (this=0x8a42a90, parent=0x89f7fb8, args=..., __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /usr/src/debug/koffice-2.1.2/kword/plugins/scripting/KWScriptingPart.cpp:31
#25 0xaeecf86c in create (this=0x8fdcb40, parent=0x89f7fb8, className=0xb65cc836 "KParts::Plugin", args=...) at /usr/include/kgenericfactory.tcc:173
#26 create (this=0x8fdcb40, parent=0x89f7fb8, className=0xb65cc836 "KParts::Plugin", args=...) at /usr/include/kgenericfactory.tcc:136
#27 KGenericFactory<KWScriptingPart, QObject>::createObject (this=0x8fdcb40, parent=0x89f7fb8, className=0xb65cc836 "KParts::Plugin", args=...) at /usr/include/kgenericfactory.h:164
#28 0xb6a6ad7f in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib/libkdecore.so.5
#29 0xb65b8e91 in create<KParts::Plugin> (parent=0x89f7fb8, libname=...) at /usr/src/debug/kdelibs-4.4.4/kdecore/util/kpluginfactory.h:503
#30 createInstance<KParts::Plugin> (parent=0x89f7fb8, libname=...) at /usr/src/debug/kdelibs-4.4.4/kdecore/util/klibloader.h:219
#31 createInstance<KParts::Plugin> (parent=0x89f7fb8, libname=...) at /usr/src/debug/kdelibs-4.4.4/kdecore/util/klibloader.h:250
#32 KParts::Plugin::loadPlugin (parent=0x89f7fb8, libname=...) at /usr/src/debug/kdelibs-4.4.4/kparts/plugin.cpp:190
#33 0xb65c1063 in KParts::Plugin::loadPlugins (parent=0x89f7fb8, parentGUIClient=0x89f8064, componentData=..., enableNewPluginsByDefault=true, interfaceVersionRequired=0)
    at /usr/src/debug/kdelibs-4.4.4/kparts/plugin.cpp:323
#34 0xb65c18ad in KParts::PartBase::loadPlugins (this=0x89f7fcc, parent=0x89f7fb8, parentGUIClient=0x89f8064, instance=...) at /usr/src/debug/kdelibs-4.4.4/kparts/part.cpp:160
#35 0xb65c1efc in KParts::PartBase::setComponentData (this=0x89f7fcc, componentData=..., bLoadPlugins=true) at /usr/src/debug/kdelibs-4.4.4/kparts/part.cpp:151
#36 0xb65ad55f in KParts::PartBase::setComponentData (this=0x89f7fcc, componentData=...) at /usr/src/debug/kdelibs-4.4.4/kparts/part.cpp:138
#37 0xb0ccde95 in KWView::KWView (this=0x89f7fb8, viewMode=..., document=0x82569c0, parent=0x8297c90, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /usr/src/debug/koffice-2.1.2/kword/part/KWView.cpp:108
#38 0xb0cc255b in KWDocument::createViewInstance (this=0x82569c0, parent=0x8297c90) at /usr/src/debug/koffice-2.1.2/kword/part/KWDocument.cpp:215
#39 0xb766fb72 in KoDocument::createView (this=0x82569c0, parent=0x8297c90) at /usr/src/debug/koffice-2.1.2/libs/main/KoDocument.cpp:345
#40 0xb76a6728 in KoMainWindow::setRootDocument (this=0x8263128, doc=0x82569c0) at /usr/src/debug/koffice-2.1.2/libs/main/KoMainWindow.cpp:455
#41 0xb769fa4f in KoMainWindow::slotLoadCompleted (this=0x8263128) at /usr/src/debug/koffice-2.1.2/libs/main/KoMainWindow.cpp:705
#42 0xb769fe75 in KoMainWindow::qt_metacall (this=0x8263128, _c=QMetaObject::InvokeMetaMethod, _id=31, _a=0xbfdb361c) at /usr/src/debug/koffice-2.1.2/build/libs/main/KoMainWindow.moc:166
#43 0xb682cefd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#44 0xb683bfe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#45 0xb65b1605 in KParts::ReadOnlyPart::completed (this=0x82569c0) at /usr/src/debug/kdelibs-4.4.4/build/kparts/part.moc:219
#46 0xb65bfa40 in KParts::ReadOnlyPart::openUrl (this=0x82569c0, url=...) at /usr/src/debug/kdelibs-4.4.4/kparts/part.cpp:560
#47 0xb767b151 in KoDocument::openUrl (this=0x82569c0, _url=...) at /usr/src/debug/koffice-2.1.2/libs/main/KoDocument.cpp:1136
#48 0xb769a104 in KoMainWindow::openDocumentInternal (this=0x8263128, url=..., newdoc=<value optimized out>) at /usr/src/debug/koffice-2.1.2/libs/main/KoMainWindow.cpp:670
#49 0xb76983fc in KoMainWindow::openDocument (this=0x8263128, newdoc=0x82569c0, url=...) at /usr/src/debug/koffice-2.1.2/libs/main/KoMainWindow.cpp:653
#50 0xb76675f3 in KoApplication::start (this=0xbfdb3b30) at /usr/src/debug/koffice-2.1.2/libs/main/KoApplication.cpp:216
#51 0xb787efc4 in kdemain (argc=2, argv=0xbfdb3c34) at /usr/src/debug/koffice-2.1.2/kword/part/main.cpp:36
#52 0x0804860b in main (argc=2, argv=0xbfdb3c34) at /usr/src/debug/koffice-2.1.2/build/kword/part/kword_dummy.cpp:3

Possible duplicates by query: bug 261129.

Reported using DrKonqi
Comment 1 Pino Toscano 2011-01-16 20:07:37 UTC

*** This bug has been marked as a duplicate of bug 251719 ***