Bug 268276 - KDE crashes after update from Suse 11.3 to Suse 11.4
Summary: KDE crashes after update from Suse 11.3 to Suse 11.4
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-12 07:34 UTC by Timon Zielonka
Modified: 2011-03-19 13:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timon Zielonka 2011-03-12 07:34:21 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
Start the PC the first time after upgrade from Suse 11.3 to Suse 11.4

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Floating point exception
[Current thread is 1 (Thread 0xb5943710 (LWP 3723))]

Thread 3 (Thread 0xae3abb70 (LWP 3724)):
#0  0xb5c6122b in clock_gettime (clock_id=1, tp=0xae3aaf70) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb6e59ae5 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6f2c726 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6f2af6b in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6f2b00d in ?? () from /usr/lib/libQtCore.so.4
#5  0xb5baba70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#6  0xb5bac8e2 in ?? () from /lib/libglib-2.0.so.0
#7  0xb5bacfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#8  0xb6f2b7b7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb6efc2bd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6efc4e9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6dfd7b9 in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0xb6edc23d in ?? () from /usr/lib/libQtCore.so.4
#13 0xb6e003aa in ?? () from /usr/lib/libQtCore.so.4
#14 0xb2e50de7 in ?? () from /usr/X11R6/lib/libGL.so.1
#15 0xb6141d5e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xa70dcb70 (LWP 3728)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6d89105 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0xb3707e17 in ?? () from /usr/lib/libQtScript.so.4
#3  0xb3707e5f in ?? () from /usr/lib/libQtScript.so.4
#4  0xb2e50de7 in ?? () from /usr/X11R6/lib/libGL.so.1
#5  0xb6141d5e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb5943710 (LWP 3723)):
[KCrash Handler]
#7  enter (table=0x8327360, size=0, hash=722438103, name=0xb61fc47f "_ZNSt7collateIwE2idE", sym=0xb61f27fc, map=0xb6d9a550) at dl-lookup.c:318
#8  0xb78697c1 in do_lookup_x (new_hash=3911375438, old_hash=0xbffa4088, ref=0xa611b094, result=0xbffa407c, scope=0x83de1e4, i=<value optimized out>, flags=1, skip=0x0, undef_map=0x83de088) at dl-lookup.c:400
#9  0xb7869b99 in _dl_lookup_symbol_x (undef_name=0xa6120dd0 "_ZZN11QMetaTypeIdIP9QMimeDataE14qt_metatype_idEvE11metatype_id", undef_map=0x83de088, ref=0xbffa4128, symbol_scope=0x83de240, version=0x0, type_class=0, flags=1, skip_map=0x0) at dl-lookup.c:736
#10 0xb786b4ab in elf_machine_rel (scope=0x83de240, reloc_mode=0, consider_profiling=0) at ../sysdeps/i386/dl-machine.h:344
#11 elf_dynamic_do_rel (scope=0x83de240, reloc_mode=0, consider_profiling=0) at do-rel.h:120
#12 _dl_relocate_object (scope=0x83de240, reloc_mode=0, consider_profiling=0) at dl-reloc.c:268
#13 0xb78728e3 in dl_open_worker (a=0xbffa42a0) at dl-open.c:338
#14 0xb786e5ff in _dl_catch_error (objname=0xbffa42c8, errstring=0xbffa42c4, mallocedp=0xbffa42cf, operate=0xb7872670 <dl_open_worker>, args=0xbffa42a0) at dl-error.c:178
#15 0xb78723a6 in _dl_open (file=0x843ef70 "/usr/lib/qt4/plugins/script/libqtscript_core.so.1.0.0", mode=-2147483647, caller_dlopen=0xb6eed194, nsid=-2, argc=4, argv=0xbffa6194, env=0x8739bc8) at dl-open.c:554
#16 0xb5cc9bdd in dlopen_doit (a=0xbffa4470) at dlopen.c:67
#17 0xb786e5ff in _dl_catch_error (objname=0x807217c, errstring=0x8072180, mallocedp=0x8072178, operate=0xb5cc9b40 <dlopen_doit>, args=0xbffa4470) at dl-error.c:178
#18 0xb5cca342 in _dlerror_run (operate=0xb5cc9b40 <dlopen_doit>, args=<value optimized out>) at dlerror.c:164
#19 0xb5cc9ca7 in __dlopen (file=0x843ef70 "/usr/lib/qt4/plugins/script/libqtscript_core.so.1.0.0", mode=1) at dlopen.c:88
#20 0xb6eed194 in ?? () from /usr/lib/libQtCore.so.4
#21 0xb6ee7cf4 in ?? () from /usr/lib/libQtCore.so.4
#22 0xb6ee7dd8 in ?? () from /usr/lib/libQtCore.so.4
#23 0xb6ee1c53 in QPluginLoader::load() () from /usr/lib/libQtCore.so.4
#24 0xb6ee1c82 in QPluginLoader::instance() () from /usr/lib/libQtCore.so.4
#25 0xb375e433 in QScriptEngine::importExtension(QString const&) () from /usr/lib/libQtScript.so.4
#26 0xa74f97d4 in Kross::EcmaScript::Private::init (this=0x89277e8) at /usr/src/debug/kdelibs-4.6.0/kross/qts/script.cpp:54
#27 0xa74f6c67 in Kross::EcmaScript::execute (this=0x864e078) at /usr/src/debug/kdelibs-4.6.0/kross/qts/script.cpp:179
#28 0xa74ce255 in Kross::Action::slotTriggered (this=0x8503028) at /usr/src/debug/kdelibs-4.6.0/kross/core/action.cpp:528
#29 0xa74cf1ed in Kross::Action::qt_metacall (this=0x8503028, _c=QMetaObject::InvokeMetaMethod, _id=32, _a=0xbffa4c48) at /usr/src/debug/kdelibs-4.6.0/build/kross/core/action.moc:186
#30 0xb6f038cd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#31 0xb6f13a2c in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#32 0xb64022bd in QAction::triggered(bool) () from /usr/lib/libQtGui.so.4
#33 0xb640255b in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQtGui.so.4
#34 0xa7f8d0bf in trigger (this=0x88b89cc) at /usr/include/QtGui/qaction.h:218
#35 ComicProviderWrapper::init (this=0x88b89cc) at /usr/src/debug/kdeplasma-addons-4.6.0/dataengines/comic/comicproviderwrapper.cpp:316
#36 0xa7f8e24f in ComicProviderWrapper::qt_metacall (this=0x88b89cc, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0x88b8af8) at /usr/src/debug/kdeplasma-addons-4.6.0/build/dataengines/comic/comicproviderwrapper.moc:512
#37 0xb6f038cd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#38 0xb6f0e3a5 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#39 0xb6f125af in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#40 0xb6409414 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#41 0xb64120c7 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#42 0xb75571f1 in KApplication::notify (this=0x80fa1b0, receiver=0x88b89cc, event=0x88b79c0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#43 0xb6efcfde in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#44 0xb6f00d6c in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#45 0xb6f00ebc in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#46 0xb6f2b5e4 in ?? () from /usr/lib/libQtCore.so.4
#47 0xb5bac509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#48 0xb5bacd10 in ?? () from /lib/libglib-2.0.so.0
#49 0xb5bacfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#50 0xb6f2b76b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#51 0xb64bf55a in ?? () from /usr/lib/libQtGui.so.4
#52 0xb6efc2bd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#53 0xb6efc4e9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#54 0xb6f00f90 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#55 0xb6407104 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#56 0xb0eb38aa in kdemain (argc=1, argv=0x80da318) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#57 0x0804e531 in launch (argc=1, _name=0x80deef4 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80525e3 "0") at /usr/src/debug/kdelibs-4.6.0/kinit/kinit.cpp:730
#58 0x0804f04f in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kinit/kinit.cpp:1222
#59 0x0804f6fc in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kinit/kinit.cpp:1415
#60 0x08050579 in main (argc=138272904, argv=0x0, envp=0x0) at /usr/src/debug/kdelibs-4.6.0/kinit/kinit.cpp:1903

Possible duplicates by query: bug 264350, bug 262664, bug 261129, bug 261066, bug 257409.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-03-13 22:55:22 UTC
Thanks for the backtrace.

This seems to be bug 251719. Are you using NVIDIA binary drivers?
Comment 2 Timon Zielonka 2011-03-14 08:58:08 UTC
Yes. I was using the Nvidia binary drivers.

Gruss

Timon

Christoph Feck <christoph@maxiom.de> wrote:

https://bugs.kde.org/show_bug.cgi?id=268276 Christoph Feck <christoph@maxiom.de> changed: What |Removed |Added_____________________________________________
CC| |christoph@maxiom.de --- Comment #1 from Christoph Feck <christoph maxiom de> 2011-03-13 22:55:22 --- Thanks for the backtrace. This seems to be bug 251719. Are you using NVIDIA binary drivers? -- Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You reported the bug.
Comment 3 Christoph Feck 2011-03-19 13:46:19 UTC

*** This bug has been marked as a duplicate of bug 251719 ***