Bug 267742 - Digikam crashes during startup
Summary: Digikam crashes during startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Setup-Templates (show other bugs)
Version: 1.5.0
Platform: OpenSUSE Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-05 22:16 UTC by Sean Quinlan
Modified: 2019-08-11 14:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments
digikam4.db - created before crash (43.00 KB, application/octet-stream)
2011-03-05 22:20 UTC, Sean Quinlan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Quinlan 2011-03-05 22:16:22 UTC
Application: digikam (1.5.0)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
I recently installed SuSE 11.3 on a new machine, copying files from my old 11.2 system. My ~/Pictures folder is a symlink to /usr/local/share/Pictures. I copied the pictures from my old system, where I used digikam, to the new computer and started digikam. The app started and showed all of the directories, but would not display any pictures. I next moved the contents to another location, deleting the old db and thumbnails file, intending to instead import the pictures. However digikam no longer starts, going directly to the crash report.

I do note that in the Pictures directory I see a new digikam4.db file. Restarting with this file in place causes a fast crash. If I delete the file there is a pause from startup to crash, and a new copy of the file is created.

The crash can be reproduced every time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f538af757c0 (LWP 23997))]

Thread 2 (Thread 0x7f5376e54710 (LWP 23998)):
#0  0x00007f5382ec139c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f53856c72bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000006b5a0d in Digikam::ScanController::run (this=0xb87b40) at /usr/src/debug/digikam-1.5.0/digikam/scancontroller.cpp:515
#3  0x00007f53856c6bf5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f5382ebca4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f53849d282d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f538af757c0 (LWP 23997)):
[KCrash Handler]
#5  0x00007f53857bf8ee in QMetaObject::changeGuard(QObject**, QObject*) () from /usr/lib64/libQtCore.so.4
#6  0x00000000006ed6cd in Digikam::SubjectEdit::SubjectEdit (this=0xf9ca20, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/libs/template/subjectedit.cpp:80
#7  0x00000000006e9d8d in Digikam::TemplatePanel::TemplatePanel (this=0xee4120, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/libs/template/templatepanel.cpp:435
#8  0x00000000004b3799 in Digikam::SetupTemplate::SetupTemplate (this=0xded8d0, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/utilities/setup/setuptemplate.cpp:103
#9  0x00000000004ad308 in Digikam::Setup::Setup (this=0xbeaab0, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/utilities/setup/setup.cpp:195
#10 0x00000000004af410 in Digikam::Setup::execSinglePage (parent=0x0, page=Digikam::Setup::CollectionsPage) at /usr/src/debug/digikam-1.5.0/utilities/setup/setup.cpp:363
#11 0x000000000061b0dd in Digikam::AlbumManager::setDatabase (this=0xb91120, params=..., priority=<value optimized out>, suggestedAlbumRoot=...)
    at /usr/src/debug/digikam-1.5.0/digikam/albummanager.cpp:899
#12 0x0000000000722cd0 in main (argc=11117936, argv=0x7fff81528fe8) at /usr/src/debug/digikam-1.5.0/digikam/main.cpp:169

Possible duplicates by query: bug 260864, bug 251403, bug 246666, bug 245920, bug 245472.

Reported using DrKonqi
Comment 1 Sean Quinlan 2011-03-05 22:20:59 UTC
Created attachment 57706 [details]
digikam4.db - created before crash
Comment 2 caulier.gilles 2011-03-06 11:26:23 UTC

*** This bug has been marked as a duplicate of bug 260864 ***
Comment 3 caulier.gilles 2019-08-11 14:26:18 UTC
Fixed with bug #260864