Bug 245920 - digikam crash when open in suse 11.3
Summary: digikam crash when open in suse 11.3
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Setup-Templates (show other bugs)
Version: 1.3.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-27 17:16 UTC by Fernando
Modified: 2019-08-11 14:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fernando 2010-07-27 17:16:19 UTC
Application: digikam (1.3.0)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
always crash when open, digikam updated from 11.2 on SUSU 11.3

The crash can be reproduced every time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fec687377c0 (LWP 25512))]

Thread 2 (Thread 0x7fec4d6cf710 (LWP 25513)):
#0  0x00007fec6069239c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fec62e982bb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000006aa43d in Digikam::ScanController::run (this=0xe73b10) at /usr/src/debug/digikam-1.3.0/digikam/scancontroller.cpp:516
#3  0x00007fec62e97bf5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fec6068da4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007fec621a382d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fec687377c0 (LWP 25512)):
[KCrash Handler]
#5  0x00007fec62f908ea in QMetaObject::changeGuard(QObject**, QObject*) () from /usr/lib64/libQtCore.so.4
#6  0x00000000006e2e8d in Digikam::SubjectEdit::SubjectEdit (this=0x1078c50, parent=<value optimized out>) at /usr/src/debug/digikam-1.3.0/libs/template/subjectedit.cpp:80
#7  0x00000000006df5c8 in Digikam::TemplatePanel::TemplatePanel (this=0xe23950, parent=<value optimized out>) at /usr/src/debug/digikam-1.3.0/libs/template/templatepanel.cpp:419
#8  0x00000000004b1bd1 in Digikam::SetupTemplate::SetupTemplate (this=0xf39570, parent=<value optimized out>) at /usr/src/debug/digikam-1.3.0/utilities/setup/setuptemplate.cpp:104
#9  0x00000000004ab728 in Digikam::Setup::Setup (this=0xe0f4a0, parent=<value optimized out>) at /usr/src/debug/digikam-1.3.0/utilities/setup/setup.cpp:195
#10 0x00000000004ad830 in Digikam::Setup::execSinglePage (parent=0x0, page=Digikam::Setup::CollectionsPage) at /usr/src/debug/digikam-1.3.0/utilities/setup/setup.cpp:363
#11 0x00000000006108ad in Digikam::AlbumManager::setDatabase (this=0xd41d90, params=..., priority=<value optimized out>, suggestedAlbumRoot=...)
    at /usr/src/debug/digikam-1.3.0/digikam/albummanager.cpp:899
#12 0x00000000007136c0 in main (argc=11032000, argv=0x7fffd51dda08) at /usr/src/debug/digikam-1.3.0/digikam/main.cpp:169

Possible duplicates by query: bug 245472.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-07-28 09:53:54 UTC

*** This bug has been marked as a duplicate of bug 245472 ***
Comment 2 caulier.gilles 2019-08-11 14:23:32 UTC
Fixed with bug #245472