Bug 260864 - Digikam fails to start
Summary: Digikam fails to start
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Setup-Templates (show other bugs)
Version: 1.5.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-21 11:37 UTC by pmanousis
Modified: 2019-08-11 14:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pmanousis 2010-12-21 11:37:32 UTC
Application: digikam (1.5.0)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Digikam was working fine.  I updated of some of my libs (now I have the latest of opensuse 11.3) and since then every time I try to run digikam, it crashes with a segmentation fault.

The crash can be reproduced every time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f27d57db7c0 (LWP 15899))]

Thread 2 (Thread 0x7f27c191a710 (LWP 15907)):
#0  0x00007f27cd6dc39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f27cfee510b in wait (this=<value optimized out>, mutex=0xb44e40, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xb44e40, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000006b5a0d in Digikam::ScanController::run (this=0xb46560) at /usr/src/debug/digikam-1.5.0/digikam/scancontroller.cpp:515
#4  0x00007f27cfee4a1e in QThreadPrivate::start (arg=0xb46560) at thread/qthread_unix.cpp:285
#5  0x00007f27cd6d7a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f27cf1ec82d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f27d57db7c0 (LWP 15899)):
[KCrash Handler]
#4  QMetaObject::changeGuard (ptr=0x7f27d0ce63a8, o=0x12c8630) at kernel/qobject.cpp:470
#5  0x00000000006ed6cd in Digikam::SubjectEdit::SubjectEdit (this=0x10fc710, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/libs/template/subjectedit.cpp:80
#6  0x00000000006e9d8d in Digikam::TemplatePanel::TemplatePanel (this=0xe5ad70, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/libs/template/templatepanel.cpp:435
#7  0x00000000004b3799 in Digikam::SetupTemplate::SetupTemplate (this=0xdb4f50, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/utilities/setup/setuptemplate.cpp:103
#8  0x00000000004ad308 in Digikam::Setup::Setup (this=0xe21e00, parent=<value optimized out>) at /usr/src/debug/digikam-1.5.0/utilities/setup/setup.cpp:195
#9  0x00000000004af410 in Digikam::Setup::execSinglePage (parent=0x0, page=Digikam::Setup::CollectionsPage) at /usr/src/debug/digikam-1.5.0/utilities/setup/setup.cpp:363
#10 0x000000000061b0dd in Digikam::AlbumManager::setDatabase (this=0xb01cd0, params=..., priority=<value optimized out>, suggestedAlbumRoot=...)
    at /usr/src/debug/digikam-1.5.0/digikam/albummanager.cpp:899
#11 0x0000000000722cd0 in main (argc=11102960, argv=0x7fffc5dff1f8) at /usr/src/debug/digikam-1.5.0/digikam/main.cpp:169

This bug may be a duplicate of or related to bug 243107.

Possible duplicates by query: bug 251403, bug 246666, bug 245920, bug 245472.

Reported using DrKonqi
Comment 1 Martin Klapetek 2010-12-21 12:53:31 UTC
There might be some libs/files mismatch in your instalation after your libs upgrade. Please try to reinstall digiKam or try to update to today released digiKam 1.7.0 and report back. Thanks!
Comment 2 pmanousis 2010-12-21 14:01:47 UTC
I reinstalled digiKam as you told me but the error remains.  Also I tried to compile digiKam 1.7 from sourceforge (http://sourceforge.net/projects/digikam/files/digikam/) but it seems that I can not:

I ran this: "cmake -Wno-dev -DCMAKE_INSTALL_PREFIX=/usr/bin .", and got this:
"Re-run cmake no build system arguments
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:98 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /home/pit/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
Call Stack (most recent call first):
  CMakeLists.txt:129 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!"

My cmake is: "cmake version 2.8.1" and the modules I have are: "FindBTCore.cmake  FindCLucene.cmake  FindSLP.cmake".  I can not find the wanted module: "FindKDE4Internal.cmake" in yast (openSuse). :(
Comment 3 Martin Klapetek 2010-12-21 14:15:33 UTC
Please try to follow this guide when compiling digiKam (sorry for not posting this earlier :)
- http://www.digikam.org/drupal/download?q=download/tarball

You should run in no problems at all when compiling by this guide. Also, don't forget to first uninstall your current digiKam package before compiling your own version!
Comment 4 Dario Andres 2010-12-21 16:13:08 UTC
[Comment from a bug triager]
This seems to be related to bug 246666 and bug 243107 (Read https://bugs.kde.org/show_bug.cgi?id=243107#c12)
Regards
Comment 5 pmanousis 2010-12-22 19:57:47 UTC
Solved by the solution given in bug 243107!  Thank you guys.

*** This bug has been marked as a duplicate of bug 243107 ***
Comment 6 caulier.gilles 2011-03-06 11:26:24 UTC
*** Bug 267742 has been marked as a duplicate of this bug. ***
Comment 7 caulier.gilles 2019-08-11 14:25:50 UTC
Fixed with bug #243107