Bug 245472 - digiKam crashed after clicking on the "Configure digiKam" option in the Settings menu
Summary: digiKam crashed after clicking on the "Configure digiKam" option in the Setti...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Setup-Templates (show other bugs)
Version: 1.3.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-22 20:52 UTC by Philip Woite
Modified: 2019-08-11 14:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Woite 2010-07-22 20:52:10 UTC
Application: digikam (1.3.0)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 4"
Qt Version: 4.6.3
Operating System: Linux 2.6.35-rc5-13-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
Every time that I try to configure digiKam, it crashes.

digiKam crashes directly upon clicking the "Configure digiKam" option in the Settings menu.

The crash can be reproduced every time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2131740 (LWP 6250))]

Thread 12 (Thread 0xb08d1b70 (LWP 6251)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb4653125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4b5824c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb4df6710 in wait (this=0x8554270, mutex=0x855426c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x8554270, mutex=0x855426c, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x082fae7a in Digikam::ScanController::run (this=0x8555c78) at /usr/src/debug/digikam-1.3.0/digikam/scancontroller.cpp:516
#6  0xb4df604f in QThreadPrivate::start (arg=0x8555c78) at thread/qthread_unix.cpp:248
#7  0xb464eb25 in start_thread () from /lib/libpthread.so.0
#8  0xb4b4a46e in clone () from /lib/libc.so.6

Thread 11 (Thread 0xb00d0b70 (LWP 6255)):
#0  0xb2d2022b in clock_gettime () from /lib/librt.so.1
#1  0xb4f1875c in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0xb4f1cb16 in updateCurrentTime (this=0x86c5654, tm=...) at kernel/qeventdispatcher_unix.cpp:340
#3  QTimerInfoList::timerWait (this=0x86c5654, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0xb4f1b56b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb00d012c) at kernel/qeventdispatcher_glib.cpp:136
#5  0xb4f1b60d in timerSourcePrepare (source=0x86c5620, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#6  0xb2eec0c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb2eecf22 in ?? () from /usr/lib/libglib-2.0.so.0
#8  0xb2eed60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb4f1bd97 in QEventDispatcherGlib::processEvents (this=0x85ce310, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0xb4eef11d in QEventLoop::processEvents (this=0xb00d02c0, flags=...) at kernel/qeventloop.cpp:149
#11 0xb4eef319 in QEventLoop::exec (this=0xb00d02c0, flags=...) at kernel/qeventloop.cpp:201
#12 0xb4df3403 in QThread::exec (this=0x8571080) at thread/qthread.cpp:487
#13 0xb66d67bb in Digikam::ImageFilterModelWorker::Thread::run (this=0x8571080) at /usr/src/debug/digikam-1.3.0/libs/models/imagefiltermodelthreads.h:66
#14 0xb4df604f in QThreadPrivate::start (arg=0x8571080) at thread/qthread_unix.cpp:248
#15 0xb464eb25 in start_thread () from /lib/libpthread.so.0
#16 0xb4b4a46e in clone () from /lib/libc.so.6

Thread 10 (Thread 0xaf8c2b70 (LWP 6256)):
#0  0xb464d350 in __i686.get_pc_thunk.bx () from /lib/libpthread.so.0
#1  0xb4652469 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#2  0xb4b584a4 in pthread_mutex_unlock () from /lib/libc.so.6
#3  0xb2eec0b3 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#4  0xb2eecf22 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0xb2eed60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#6  0xb4f1bd97 in QEventDispatcherGlib::processEvents (this=0x8572490, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#7  0xb4eef11d in QEventLoop::processEvents (this=0xaf8c22c0, flags=...) at kernel/qeventloop.cpp:149
#8  0xb4eef319 in QEventLoop::exec (this=0xaf8c22c0, flags=...) at kernel/qeventloop.cpp:201
#9  0xb4df3403 in QThread::exec (this=0x8733300) at thread/qthread.cpp:487
#10 0xb66d67bb in Digikam::ImageFilterModelWorker::Thread::run (this=0x8733300) at /usr/src/debug/digikam-1.3.0/libs/models/imagefiltermodelthreads.h:66
#11 0xb4df604f in QThreadPrivate::start (arg=0x8733300) at thread/qthread_unix.cpp:248
#12 0xb464eb25 in start_thread () from /lib/libpthread.so.0
#13 0xb4b4a46e in clone () from /lib/libc.so.6

Thread 9 (Thread 0xae1d2b70 (LWP 6257)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb4653125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4b5824c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb4df6710 in wait (this=0x8706aa0, mutex=0x8706a9c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x8706aa0, mutex=0x8706a9c, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb69d354b in Digikam::ParkingThread::run (this=0x8706a90) at /usr/src/debug/digikam-1.3.0/libs/threads/threadmanager.cpp:101
#6  0xb4df604f in QThreadPrivate::start (arg=0x8706a90) at thread/qthread_unix.cpp:248
#7  0xb464eb25 in start_thread () from /lib/libpthread.so.0
#8  0xb4b4a46e in clone () from /lib/libc.so.6

Thread 8 (Thread 0xad9d1b70 (LWP 6258)):
#0  0xb46544aa in pthread_once () from /lib/libpthread.so.0
#1  0xb4df6146 in QThreadData::current () at thread/qthread_unix.cpp:134
#2  0xb4f1b877 in postEventSourcePrepare (s=0x86d9eb8, timeout=0x0) at kernel/qeventdispatcher_glib.cpp:253
#3  0xb4f1b8f7 in postEventSourceCheck (source=0x86d9eb8) at kernel/qeventdispatcher_glib.cpp:269
#4  0xb2eec7d0 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#5  0xb2eed108 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0xb2eed60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#7  0xb4f1bd97 in QEventDispatcherGlib::processEvents (this=0x889dbc0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#8  0xb4eef11d in QEventLoop::processEvents (this=0xad9d12e0, flags=...) at kernel/qeventloop.cpp:149
#9  0xb4eef319 in QEventLoop::exec (this=0xad9d12e0, flags=...) at kernel/qeventloop.cpp:201
#10 0xb4df3403 in QThread::exec (this=0x869c298) at thread/qthread.cpp:487
#11 0xb4df604f in QThreadPrivate::start (arg=0x869c298) at thread/qthread_unix.cpp:248
#12 0xb464eb25 in start_thread () from /lib/libpthread.so.0
#13 0xb4b4a46e in clone () from /lib/libc.so.6

Thread 7 (Thread 0xad1d0b70 (LWP 6259)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb4b3f75e in poll () from /lib/libc.so.6
#2  0xb2efd1db in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb2eed286 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb2eed60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb4f1bd97 in QEventDispatcherGlib::processEvents (this=0x857f860, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0xb4eef11d in QEventLoop::processEvents (this=0xad1d02e0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4eef319 in QEventLoop::exec (this=0xad1d02e0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb4df3403 in QThread::exec (this=0x87283e8) at thread/qthread.cpp:487
#9  0xb4df604f in QThreadPrivate::start (arg=0x87283e8) at thread/qthread_unix.cpp:248
#10 0xb464eb25 in start_thread () from /lib/libpthread.so.0
#11 0xb4b4a46e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xa9fe6b70 (LWP 6261)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb4653452 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4b582a4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xab2b91d7 in ?? () from /usr/lib/libxine.so.1
#4  0xb464eb25 in start_thread () from /lib/libpthread.so.0
#5  0xb4b4a46e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xa93aab70 (LWP 6262)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb4653452 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4b582a4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xab2c7d25 in ?? () from /usr/lib/libxine.so.1
#4  0xb464eb25 in start_thread () from /lib/libpthread.so.0
#5  0xb4b4a46e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa8ba9b70 (LWP 6263)):
#0  0xb4650fba in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb4b58464 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb2eec0ef in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#3  0xb2eecf22 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb2eed60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb4f1bd97 in QEventDispatcherGlib::processEvents (this=0x85ebef0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0xb4eef11d in QEventLoop::processEvents (this=0xa8ba9290, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4eef319 in QEventLoop::exec (this=0xa8ba9290, flags=...) at kernel/qeventloop.cpp:201
#8  0xb4df3403 in QThread::exec (this=0x85b1958) at thread/qthread.cpp:487
#9  0xab312dc8 in ?? () from /usr/lib/kde4/plugins/phonon_backend/phonon_xine.so
#10 0xb4df604f in QThreadPrivate::start (arg=0x85b1958) at thread/qthread_unix.cpp:248
#11 0xb464eb25 in start_thread () from /lib/libpthread.so.0
#12 0xb4b4a46e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa83a8b70 (LWP 6266)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb4b3f75e in poll () from /lib/libc.so.6
#2  0xa97d2fbc in ?? () from /usr/lib/xine/plugins/1.28/xineplug_ao_out_alsa.so
#3  0xb464eb25 in start_thread () from /lib/libpthread.so.0
#4  0xb4b4a46e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa7ba7b70 (LWP 6267)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb4653125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb4b5824c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xab2cc250 in ?? () from /usr/lib/libxine.so.1
#4  0xb464eb25 in start_thread () from /lib/libpthread.so.0
#5  0xb4b4a46e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb2131740 (LWP 6250)):
[KCrash Handler]
#6  QMetaObject::changeGuard (ptr=0xb53e95e4, o=0xb5082f8) at kernel/qobject.cpp:488
#7  0xb5805ff4 in operator= (this=0xb4d2ee0, v=0xb5082f8) at ../../src/corelib/kernel/qpointer.h:68
#8  setValidator (this=0xb4d2ee0, v=0xb5082f8) at ../../src/gui/widgets/qlinecontrol_p.h:641
#9  QLineEdit::setValidator (this=0xb4d2ee0, v=0xb5082f8) at widgets/qlineedit.cpp:589
#10 0x08336535 in Digikam::SubjectEdit::SubjectEdit (this=0xb4b1ec8, parent=0x26) at /usr/src/debug/digikam-1.3.0/libs/template/subjectedit.cpp:80
#11 0x08332a4d in Digikam::TemplatePanel::TemplatePanel (this=0xb43aab0, parent=0x26) at /usr/src/debug/digikam-1.3.0/libs/template/templatepanel.cpp:419
#12 0x080e4b63 in Digikam::SetupTemplate::SetupTemplate (this=0xb3eed88, parent=0x26) at /usr/src/debug/digikam-1.3.0/utilities/setup/setuptemplate.cpp:104
#13 0x080de206 in Digikam::Setup::Setup (this=0xb23a380, parent=0x26) at /usr/src/debug/digikam-1.3.0/utilities/setup/setup.cpp:195
#14 0x080e0443 in Digikam::Setup::exec (parent=0x863ae48, page=Digikam::Setup::LastPageUsed) at /usr/src/debug/digikam-1.3.0/utilities/setup/setup.cpp:349
#15 0x08297277 in Digikam::DigikamApp::setup (this=0x863ae48) at /usr/src/debug/digikam-1.3.0/digikam/digikamapp.cpp:2138
#16 0x082b225d in Digikam::DigikamApp::qt_metacall (this=0x863ae48, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbf870b78) at /usr/src/debug/digikam-1.3.0/build/digikam/digikamapp.moc:223
#17 0xb4ef5efd in QMetaObject::metacall (object=0x863ae48, cl=QMetaObject::InvokeMetaMethod, idx=74, argv=0xbf870b78) at kernel/qmetaobject.cpp:237
#18 0xb4f04fe8 in QMetaObject::activate (sender=0x9dd4a90, m=0x8479658, local_signal_index=1, argv=0xbf870b78) at kernel/qobject.cpp:3295
#19 0xb539ca0d in QAction::triggered (this=0x9dd4a90, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#20 0xb539ccab in QAction::activate (this=0x9dd4a90, event=QAction::Trigger) at kernel/qaction.cpp:1255
#21 0xb5836fb5 in QMenuPrivate::activateCausedStack (this=0x99be780, causedStack=..., action=0x9dd4a90, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1002
#22 0xb583dc87 in QMenuPrivate::activateAction (this=0x99be780, action=0x9dd4a90, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1094
#23 0xb583f058 in QMenu::mouseReleaseEvent (this=0x9701918, e=0xbf8713e4) at widgets/qmenu.cpp:2312
#24 0xb5de0f1c in KMenu::mouseReleaseEvent (this=0x9701918, e=0xbf8713e4) at /usr/src/debug/kdelibs-4.4.4/kdeui/widgets/kmenu.cpp:471
#25 0xb53fcf00 in QWidget::event (this=0x9701918, event=0xbf8713e4) at kernel/qwidget.cpp:8044
#26 0xb583f0dc in QMenu::event (this=0x9701918, e=0xbf8713e4) at widgets/qmenu.cpp:2421
#27 0xb53a3c64 in QApplicationPrivate::notify_helper (this=0x84aeff0, receiver=0x9701918, e=0xbf8713e4) at kernel/qapplication.cpp:4302
#28 0xb53ac750 in QApplication::notify (this=0xbf8710fc, receiver=0x9701918, e=0xbf8713e4) at kernel/qapplication.cpp:3867
#29 0xb5e169d1 in KApplication::notify (this=0xbf871ce4, receiver=0x9701918, event=0xbf8713e4) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#30 0xb4eefe0e in QCoreApplication::notifyInternal (this=0xbf871ce4, receiver=0x9701918, event=0xbf8713e4) at kernel/qcoreapplication.cpp:726
#31 0xb53a4c4c in sendSpontaneousEvent (receiver=0x9701918, event=0xbf8713e4, alienWidget=0x0, nativeWidget=0x9701918, buttonDown=0xb5cee078, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:218
#32 QApplicationPrivate::sendMouseEvent (receiver=0x9701918, event=0xbf8713e4, alienWidget=0x0, nativeWidget=0x9701918, buttonDown=0xb5cee078, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#33 0xb542c766 in QETWidget::translateMouseEvent (this=0x9701918, event=0xbf8718fc) at kernel/qapplication_x11.cpp:4314
#34 0xb542b73e in QApplication::x11ProcessEvent (this=0xbf871ce4, event=0xbf8718fc) at kernel/qapplication_x11.cpp:3391
#35 0xb5454570 in x11EventSourceDispatch (s=0x84b2200, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#36 0xb2eecb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb2eed350 in ?? () from /usr/lib/libglib-2.0.so.0
#38 0xb2eed60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#39 0xb4f1bd4b in QEventDispatcherGlib::processEvents (this=0x8483a38, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#40 0xb545419a in QGuiEventDispatcherGlib::processEvents (this=0x8483a38, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0xb4eef11d in QEventLoop::processEvents (this=0xbf871bb4, flags=...) at kernel/qeventloop.cpp:149
#42 0xb4eef319 in QEventLoop::exec (this=0xbf871bb4, flags=...) at kernel/qeventloop.cpp:201
#43 0xb4ef3c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#44 0xb53a1164 in QApplication::exec () at kernel/qapplication.cpp:3581
#45 0x08369873 in main (argc=0, argv=0xb3cce80) at /usr/src/debug/digikam-1.3.0/digikam/main.cpp:195

This bug may be a duplicate of or related to bug 243107.

Possible duplicates by query: bug 243107.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-07-22 21:53:18 UTC

*** This bug has been marked as a duplicate of bug 243107 ***
Comment 2 caulier.gilles 2010-07-28 09:53:54 UTC
*** Bug 245920 has been marked as a duplicate of this bug. ***
Comment 3 caulier.gilles 2019-08-11 14:22:51 UTC
Fixed with bug #243107