Bug 246666 - Digikam crashes at launch
Summary: Digikam crashes at launch
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Setup-Templates (show other bugs)
Version: 1.3.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-04 02:48 UTC by mike_fowler
Modified: 2019-08-11 14:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike_fowler 2010-08-04 02:48:52 UTC
Application: digikam (1.3.0)
KDE Platform Version: 4.4.95 (KDE 4.4.95 (KDE 4.5 >= 20100723))
Qt Version: 4.6.3
Operating System: Linux 2.6.31.12-0.2-default i686
Distribution: "openSUSE 11.2 (i586)"

-- Information about the crash:
- What I was doing when the application crashed: Attempting to launch Digikam, happens regardless of other running apps or lack thereof.

- Unusual behavior I noticed: Other than crashing Digikam, no unusual symptoms observed.

- Custom settings of the application: Haven't been able to launch to configure.

System is a relatively fresh and clean install; Digikam failed from the get-go, so removed and re-installed Digikam and related packages with no change.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb21c1740 (LWP 5258))]

Thread 2 (Thread 0xafe73b70 (LWP 5259)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb42ecd95 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb484727c in pthread_cond_wait () from /lib/libc.so.6
#3  0xb55878d0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x08341b2a in Digikam::ScanController::run (this=0x8603bd0) at /usr/src/debug/digikam-1.3.0/digikam/scancontroller.cpp:516
#5  0xb55867cf in ?? () from /usr/lib/libQtCore.so.4
#6  0xb42e86e5 in start_thread () from /lib/libpthread.so.0
#7  0xb42e8600 in ?? () from /lib/libpthread.so.0

Thread 1 (Thread 0xb21c1740 (LWP 5258)):
[KCrash Handler]
#7  0xb569f753 in QMetaObject::changeGuard(QObject**, QObject*) () from /usr/lib/libQtCore.so.4
#8  0xb4fb75f4 in operator= (p=<value optimized out>, this=<value optimized out>) at ../../src/corelib/kernel/qpointer.h:68
#9  setValidator (p=<value optimized out>, this=<value optimized out>) at ../../src/gui/widgets/qlinecontrol_p.h:641
#10 QLineEdit::setValidator (p=<value optimized out>, this=<value optimized out>) at widgets/qlineedit.cpp:589
#11 0x0838eccb in Digikam::SubjectEdit::SubjectEdit (this=0x88085a0, parent=0x0) at /usr/src/debug/digikam-1.3.0/libs/template/subjectedit.cpp:80
#12 0x0838d763 in Digikam::TemplatePanel::TemplatePanel (this=0x865be00, parent=0x0) at /usr/src/debug/digikam-1.3.0/libs/template/templatepanel.cpp:419
#13 0x080f80a8 in Digikam::SetupTemplate::SetupTemplate (this=0x8640f20, parent=0x0) at /usr/src/debug/digikam-1.3.0/utilities/setup/setuptemplate.cpp:104
#14 0x080ecec6 in Digikam::Setup::Setup (this=0x872ca18, parent=0x0) at /usr/src/debug/digikam-1.3.0/utilities/setup/setup.cpp:195
#15 0x080eec93 in Digikam::Setup::execSinglePage (parent=0x0, page=CollectionsPage) at /usr/src/debug/digikam-1.3.0/utilities/setup/setup.cpp:363
#16 0x080eed47 in Digikam::Setup::execSinglePage (page=CollectionsPage) at /usr/src/debug/digikam-1.3.0/utilities/setup/setup.cpp:358
#17 0x08295e48 in Digikam::AlbumManager::setDatabase (this=0x85fef58, params=..., priority=false, suggestedAlbumRoot=...) at /usr/src/debug/digikam-1.3.0/digikam/albummanager.cpp:899
#18 0x083cfc17 in main (argc=5, argv=0xbfc9be04) at /usr/src/debug/digikam-1.3.0/digikam/main.cpp:169

Possible duplicates by query: bug 245472, bug 243107.

Reported using DrKonqi
Comment 1 Johannes Wienke 2010-08-04 10:17:23 UTC
Probably a binary incompatibility. Please try to complete reinstall digikam.

*** This bug has been marked as a duplicate of bug 243107 ***
Comment 2 mike_fowler 2010-08-04 17:46:02 UTC
Did that: "System is a relatively fresh and clean install; Digikam failed from the get-go, so removed and re-installed Digikam and related packages with no change."
Comment 3 mike_fowler 2010-08-04 17:55:00 UTC
Also, 246666 is not a duplicate, thanks.  This bug (243107) refers to a crash when
opening preferences.  246666 refers to a crash when launching Digikam...not
sure how that makes it a duplicate.
Comment 4 Johannes Wienke 2010-08-04 21:26:37 UTC
The backtraces look very similar in the end. But if reinstalling doesn't help we need to further investigate.
Comment 5 caulier.gilles 2010-08-17 13:49:10 UTC
It's a duplicate. The problem is in Qt4 library :

#9  setValidator (p=<value optimized out>, this=<value optimized out>) at
../../src/gui/widgets/qlinecontrol_p.h:641
#10 QLineEdit::setValidator (p=<value optimized out>, this=<value optimized
out>) at widgets/qlineedit.cpp:589
#11 0x0838eccb in Digikam::SubjectEdit::SubjectEdit (this=0x88085a0,
parent=0x0) at /usr/src/debug/digikam-1.3.0/libs/template/subjectedit.cpp:80
#12 0x0838d763 in Digikam::TemplatePanel::TemplatePanel (this=0x865be00,
parent=0x0) at /usr/src/debug/digikam-1.3.0/libs/template/templatepanel.cpp:419
#13 0x080f80a8 in Digikam::SetupTemplate::SetupTemplate (this=0x8640f20,
parent=0x0) at

I remember a lots of memory corruption with QLineEdit using Valgrind with and older release. Now after and update all disappear

Gilles Caulier

*** This bug has been marked as a duplicate of bug 243107 ***
Comment 6 caulier.gilles 2010-09-16 08:41:19 UTC
*** Bug 251403 has been marked as a duplicate of this bug. ***
Comment 7 mike_fowler 2010-10-15 04:48:13 UTC
YAY!!!!  zypper dup fixed it!  Thanks to radlpix@goldmail.de, I tried this after reading about it at bug 243107.
Comment 8 caulier.gilles 2019-08-11 14:23:59 UTC
Fixed with bug #243107