Bug 263487 - error al reinicar network
Summary: error al reinicar network
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-17 23:52 UTC by yeison hernandez
Modified: 2011-02-11 16:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yeison hernandez 2011-01-17 23:52:27 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
al ejecutar como super usuario /etc/init.d/network restart.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0xb705be5d in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0xb702499b in ?? () from /usr/lib/libknmservice.so.4
#8  0xb7024cd2 in ?? () from /usr/lib/libknmservice.so.4
#9  0xb7025795 in ?? () from /usr/lib/libknmservice.so.4
#10 0xb70255f3 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb70141d4 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb7014253 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0xb7018126 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0xb70158e9 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#15 0xb7014ccd in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#16 0xb700fb65 in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#17 0xb6df2efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#18 0xb6e01fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#19 0xb6f99195 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x813b450, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#20 0xb6f997cc in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x813b450, uni=...) at /usr/src/debug/kdebase-workspace-4.4.4/libs/solid/control/networkmanager.cpp:197
#21 0xb6f9984e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x813b450, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf8b3518)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#22 0xb6df2efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#23 0xb6e01fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#24 0xb3a3d135 in NMNetworkManager::networkInterfaceAdded (this=0x8152798, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#25 0xb3a4272a in NMNetworkManager::deviceAdded (this=0x8152798, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#26 0xb3a4cf73 in NMNetworkManager::qt_metacall (this=0x8152798, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf8b3698)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#27 0xb6df2efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#28 0xb6e01fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#29 0xb3a3e745 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x8129b90, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#30 0xb3a47b7f in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x8129b90, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8b38cc)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#31 0xb6f27a37 in QDBusConnectionPrivate::deliverCall (this=0x81370f0, object=0x8129b90, msg=..., metaTypes=..., slotIdx=-1081397480) at qdbusintegrator.cpp:904
#32 0xb6f35536 in QDBusCallDeliveryEvent::placeMetaCall (this=0x82050b8, object=0x8129b90) at qdbusintegrator_p.h:101
#33 0xb6dff93f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#34 0xb6341c64 in QApplicationPrivate::notify_helper (this=0x8095c48, receiver=0x8129b90, e=0x82050b8) at kernel/qapplication.cpp:4302
#35 0xb6349bf7 in QApplication::notify (this=0xbf8b4130, receiver=0x8129b90, e=0x82050b8) at kernel/qapplication.cpp:3706
#36 0xb72b69d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#37 0xb6dece0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#38 0xb6df09b4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#39 0xb6df0b9c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#40 0xb6e1883d in ?? () from /usr/lib/libQtCore.so.4
#41 0xb5ae0b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#42 0xb5ae1350 in ?? () from /usr/lib/libglib-2.0.so.0
#43 0xb5ae160e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#44 0xb6e18d4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0xb63f219a in QGuiEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0xb6dec11d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0xb6dec319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0xb6df0c70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#49 0xb633f164 in QApplication::exec () at kernel/qapplication.cpp:3581
#50 0x08053e59 in _start ()

Possible duplicates by query: bug 261893, bug 260324, bug 258956, bug 258907, bug 258762.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2011-02-11 16:02:13 UTC
Thanks for the bug report. This looks like bug 210878. There have been commits
recently which might fix the problem.

*** This bug has been marked as a duplicate of bug 210878 ***