Bug 258956 - KNetworkManager Crashed while updating
Summary: KNetworkManager Crashed while updating
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-06 00:39 UTC by marko.gabriel.cz
Modified: 2010-12-07 01:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marko.gabriel.cz 2010-12-06 00:39:25 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-trunk-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

-- Information about the crash:
NetworkManager suddenly crashed during update via apt-get.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0xb6f737ce in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0xb6f3ed60 in ?? () from /usr/lib/libknmservice.so.4
#8  0xb6f3ee6c in ?? () from /usr/lib/libknmservice.so.4
#9  0xb6f3f0fd in ?? () from /usr/lib/libknmservice.so.4
#10 0xb6f3f3f2 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb6f2dd03 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb6f2e098 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0xb6f32540 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0xb6f2fbe0 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#15 0xb6f2eaa3 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#16 0xb6f2922b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#17 0xb619f7aa in QMetaObject::metacall (object=0x9078578, cl=3219931672, idx=151481008, argv=0x907debc) at kernel/qmetaobject.cpp:237
#18 0xb61ae1bb in QMetaObject::activate (sender=0x9008ff8, m=0xb6e59440, local_signal_index=1, argv=0xbfec4798) at kernel/qobject.cpp:3295
#19 0xb6e3a463 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x9008ff8, _t1=...) at ./networkmanager.moc:107
#20 0xb6e3aed6 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x9008ff8, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#21 0xb6e3af57 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x9008ff8, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfec4908) at ./networkmanager_p.moc:81
#22 0xb619f7aa in QMetaObject::metacall (object=0x9008ff8, cl=3219931672, idx=10, argv=0xbfec4908) at kernel/qmetaobject.cpp:237
#23 0xb61ae1bb in QMetaObject::activate (sender=0x8fd7770, m=0xb3a964d0, local_signal_index=1, argv=0xbfec4908) at kernel/qobject.cpp:3295
#24 0xb3a7f613 in NMNetworkManager::networkInterfaceAdded (this=0x8fd7770, _t1=...) at ./manager.moc:134
#25 0xb3a7fefa in NMNetworkManager::deviceAdded (this=0x8fd7770, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#26 0xb3a8421d in NMNetworkManager::qt_metacall (this=0x8fd7770, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfec4aa8) at ./manager.moc:111
#27 0xb619f7aa in QMetaObject::metacall (object=0x8fd7770, cl=3219931672, idx=20, argv=0xbfec4aa8) at kernel/qmetaobject.cpp:237
#28 0xb61ae1bb in QMetaObject::activate (sender=0x8faff88, m=0xb3a974e0, local_signal_index=0, argv=0xbfec4aa8) at kernel/qobject.cpp:3295
#29 0xb3a8e563 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x8faff88, _t1=...) at ./nm-manager-clientinterface.moc:155
#30 0xb3a8e925 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x8faff88, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfec4c58) at ./nm-manager-clientinterface.moc:102
#31 0xb62d4ac1 in QDBusConnectionPrivate::deliverCall (this=0x8fda530, object=0x8faff88, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#32 0xb62df877 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#33 0xb61aadfe in QObject::event (this=0x8faff88, e=0x9084f50) at kernel/qobject.cpp:1248
#34 0xb64825cc in QApplicationPrivate::notify_helper (this=0x8f65b58, receiver=0x8faff88, e=0x9084f50) at kernel/qapplication.cpp:4302
#35 0xb648915e in QApplication::notify (this=0xbfec55a0, receiver=0x8faff88, e=0x9084f50) at kernel/qapplication.cpp:3706
#36 0xb7294c5a in KApplication::notify (this=0xbfec55a0, receiver=0x8faff88, event=0x9084f50) at ../../kdeui/kernel/kapplication.cpp:302
#37 0xb619a4cb in QCoreApplication::notifyInternal (this=0xbfec55a0, receiver=0x8faff88, event=0x9084f50) at kernel/qcoreapplication.cpp:726
#38 0xb619df2c in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8f48860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8f48860) at kernel/qcoreapplication.cpp:1367
#40 0xb619e0ad in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#41 0xb61c657f in QCoreApplication::sendPostedEvents (s=0x8f6eab8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=0x8f6eab8) at kernel/qeventdispatcher_glib.cpp:276
#43 0xb5a50305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0xb5a53fe8 in ?? () from /lib/libglib-2.0.so.0
#45 0xb5a541c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0xb61c6075 in QEventDispatcherGlib::processEvents (this=0x8f48360, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#47 0xb6540ed5 in QGuiEventDispatcherGlib::processEvents (this=0x8f48360, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0xb6198ae9 in QEventLoop::processEvents (this=0xbfec5504, flags=) at kernel/qeventloop.cpp:149
#49 0xb6198f3a in QEventLoop::exec (this=0xbfec5504, flags=...) at kernel/qeventloop.cpp:201
#50 0xb619e16f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#51 0xb6482667 in QApplication::exec () at kernel/qapplication.cpp:3581
#52 0x08053ec5 in _start ()

Possible duplicates by query: bug 258907, bug 258762, bug 258168, bug 256552, bug 256244.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-07 01:22:12 UTC
[Comment from a bug triager]
This issue is being tracked at bug 210878. Merging. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***