Bug 260324 - Crash when restarting network-manager
Summary: Crash when restarting network-manager
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-16 22:09 UTC by Jacob Deker
Modified: 2010-12-17 17:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Deker 2010-12-16 22:09:36 UTC
Application: kded4 ($Id: kded.cpp 1031637 2009-10-05 16:58:19Z lunakl $)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-5-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

-- Information about the crash:
Everytime the network-manager package is upgraded from the squeeze/testing repository, the upgrade process restarts the network-manager. Upon service restart, the crash occurs.

The crash can be reproduced every time.

 -- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00000000 in ?? ()
#7  0xb1ac3eae in qobject_cast<Knm::InterfaceConnection const*> (first=0xb1b0cf10, second=0x8b97a08) at /usr/include/qt4/QtCore/qobject.h:468
#8  activatableLessThan (first=0xb1b0cf10, second=0x8b97a08) at ../../../libs/service/sortedactivatablelist.cpp:183
#9  0xb1ac4142 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:356
#10 0xb1ac43f2 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8b984c0, activatable=0x8bb9b28)
    at /usr/include/qt4/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleAdd (this=0x8b984c0, activatable=0x8bb9b28) at ../../../libs/service/sortedactivatablelist.cpp:96
#12 0xb1ab2d03 in ActivatableList::notifyOnAddActivatable (this=0x8b83850, activatable=0x8bb9b28) at ../../../libs/service/activatablelist.cpp:99
#13 0xb1ab3098 in ActivatableList::addActivatable (this=0x8b83850, activatable=0x8bb9b28) at ../../../libs/service/activatablelist.cpp:83
#14 0xb1ab7540 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x8bba908, addedConnection=0x8b9cfb0) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0xb1ab65a4 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=0x8bba908, ssid=...) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:176
#16 0xb1ab6f41 in WirelessNetworkInterfaceActivatableProvider (this=0x8bba908, connectionList=0x8b81150, activatableList=0x8b83850, interface=0x8ca1240, parent=0x8b30640, 
    __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:76
#17 0xb1ab3b0c in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x8b30640, uni=...) at ../../../libs/service/networkinterfacemonitor.cpp:71
#18 0xb1aae22b in NetworkInterfaceMonitor::qt_metacall (this=0x8b30640, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfd24c78) at moc_networkinterfacemonitor.cpp:75
#19 0xb6cd27aa in QMetaObject::metacall (object=0x8b30640, cl=146387457, idx=4, argv=0xbfd24c78) at kernel/qmetaobject.cpp:237
#20 0xb6ce11bb in QMetaObject::activate (sender=0x8b10850, m=0xb1f14440, local_signal_index=1, argv=0xbfd24c78) at kernel/qobject.cpp:3295
#21 0xb1ef5463 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#22 0xb1ef5ed6 in ?? () from /usr/lib/libsolidcontrol.so.4
#23 0xb1ef5f57 in ?? () from /usr/lib/libsolidcontrol.so.4
#24 0xb6cd27aa in QMetaObject::metacall (object=0x8b10850, cl=146387457, idx=0, argv=0x8b10850) at kernel/qmetaobject.cpp:237
#25 0xb6ce11bb in QMetaObject::activate (sender=0x8afbf88, m=0xb1e2e4d0, local_signal_index=1, argv=0xbfd24de8) at kernel/qobject.cpp:3295
#26 0xb1e17613 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0xb1e17efa in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#28 0xb1e1c21d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#29 0xb6cd27aa in QMetaObject::metacall (object=0x8afbf88, cl=146387457, idx=146593096, argv=0x8afbf88) at kernel/qmetaobject.cpp:237
#30 0xb6ce11bb in QMetaObject::activate (sender=0x8b1de10, m=0xb1e2f4e0, local_signal_index=0, argv=0xbfd24f88) at kernel/qobject.cpp:3295
#31 0xb1e26563 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#32 0xb1e26925 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#33 0xb5d00ac1 in QDBusConnectionPrivate::deliverCall (this=0x8b18510, object=0x8b1de10, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#34 0xb5d0b877 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#35 0xb6cdddfe in QObject::event (this=0x8b1de10, e=0x8b9e040) at kernel/qobject.cpp:1248
#36 0xb62165cc in QApplicationPrivate::notify_helper (this=0x8a54850, receiver=0x8b1de10, e=0x8b9e040) at kernel/qapplication.cpp:4302
#37 0xb621d15e in QApplication::notify (this=0xbfd25a90, receiver=0x8b1de10, e=0x8b9e040) at kernel/qapplication.cpp:3706
#38 0xb6fc3bfa in KApplication::notify (this=0xbfd25a90, receiver=0x8b1de10, event=0x8b9e040) at ../../kdeui/kernel/kapplication.cpp:302
#39 0xb6ccd4cb in QCoreApplication::notifyInternal (this=0xbfd25a90, receiver=0x8b1de10, event=0x8b9e040) at kernel/qcoreapplication.cpp:726
#40 0xb6cd0f2c in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8a01858) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8a01858) at kernel/qcoreapplication.cpp:1367
#42 0xb6cd10ad in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#43 0xb6cf957f in QCoreApplication::sendPostedEvents (s=0x8a56910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=0x8a56910) at kernel/qeventdispatcher_glib.cpp:276
#45 0xb59a3305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#46 0xb59a6fe8 in ?? () from /lib/libglib-2.0.so.0
#47 0xb59a71c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#48 0xb6cf9075 in QEventDispatcherGlib::processEvents (this=0x8a02330, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#49 0xb62d4ed5 in QGuiEventDispatcherGlib::processEvents (this=0x8a02330, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0xb6ccbae9 in QEventLoop::processEvents (this=0xbfd259e4, flags=) at kernel/qeventloop.cpp:149
#51 0xb6ccbf3a in QEventLoop::exec (this=0xbfd259e4, flags=...) at kernel/qeventloop.cpp:201
#52 0xb6cd116f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#53 0xb6216667 in QApplication::exec () at kernel/qapplication.cpp:3581
#54 0xb51d9d4e in kdemain (argc=1, argv=0x8a40200) at ../../kded/kded.cpp:932
#55 0x0804e37b in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80515bb "0") at ../../kinit/kinit.cpp:729
#56 0x08050090 in main (argc=4, argv=0xbfd262c4, envp=0xbfd262d8) at ../../kinit/kinit.cpp:1800

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-17 17:22:27 UTC
[Comment from a bug triager]
This issue is being tracked at bug 210878. Merging. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***