Bug 261893 - It's impossible to manul restart network-manager deamon from konsole
Summary: It's impossible to manul restart network-manager deamon from konsole
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-02 20:18 UTC by Mateusz Pastewski
Modified: 2011-01-23 18:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Pastewski 2011-01-02 20:18:15 UTC
Application: kded4 ($Id: kded.cpp 1031637 2009-10-05 16:58:19Z lunakl $)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-5-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

-- Information about the crash:
Everytime when I try to restart network-manager deamon (with appropriate permissions) from console (/etc/init.d/network-manager restart command), crashe happens. I don't run any other app, don't have unusual configuration (just one wireless network added).

The crash can be reproduced every time.

 -- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb17857ce in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0xb1750d31 in ?? () from /usr/lib/libknmservice.so.4
#8  0xb1750e6c in ?? () from /usr/lib/libknmservice.so.4
#9  0xb17511d8 in ?? () from /usr/lib/libknmservice.so.4
#10 0xb17513f2 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb173fd03 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb1740098 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0xb1744540 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0xb1741be0 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#15 0xb1740aa3 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#16 0xb173b22b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#17 0xb6c4a7aa in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#18 0xb6c591bb in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#19 0xb1bbe463 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#20 0xb1bbeed6 in ?? () from /usr/lib/libsolidcontrol.so.4
#21 0xb1bbef57 in ?? () from /usr/lib/libsolidcontrol.so.4
#22 0xb6c4a7aa in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#23 0xb6c591bb in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#24 0xb1a36613 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#25 0xb1a36efa in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0xb1a3b21d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0xb6c4a7aa in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#28 0xb6c591bb in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#29 0xb1a45563 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#30 0xb1a45925 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#31 0xb5c78ac1 in ?? () from /usr/lib/libQtDBus.so.4
#32 0xb5c83877 in ?? () from /usr/lib/libQtDBus.so.4
#33 0xb6c55dfe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#34 0xb618e5cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#35 0xb619515e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#36 0xb6f3bbfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#37 0xb6c454cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#38 0xb6c48f2c in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#39 0xb6c490ad in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#40 0xb6c7157f in ?? () from /usr/lib/libQtCore.so.4
#41 0xb591b305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0xb591efe8 in ?? () from /lib/libglib-2.0.so.0
#43 0xb591f1c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0xb6c71075 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0xb624ced5 in ?? () from /usr/lib/libQtGui.so.4
#46 0xb6c43ae9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0xb6c43f3a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0xb6c4916f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#49 0xb618e667 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#50 0xb5151d4e in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
#51 0x0804e37b in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-01-15 21:56:11 UTC
Last November I commited a patch to Plasma NM to solve this problem. You are probably using a older version. Try using a more recently compiled package.
Comment 2 Dario Andres 2011-01-23 18:18:42 UTC
[Comment from a bug triager]
This issue is being tracked at bug 210878. Merging. Thanks

@Lamarque V. Souza: should your commit fix bug 210878 too ?

*** This bug has been marked as a duplicate of bug 210878 ***
Comment 3 Lamarque V. Souza 2011-01-23 18:39:54 UTC
Probably. The commit empties the ActivatableList when NetworkManager goes down so that no dangling point lasts when it starts again. Probably the crashes in this bug and in 210878 happens because of those dangling pointers.