Bug 252140 - Nepumuk crash on KDE startup
Summary: Nepumuk crash on KDE startup
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-23 14:51 UTC by Marcello Ceschia
Modified: 2011-01-17 17:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcello Ceschia 2010-09-23 14:51:04 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.69 (4.6 >= 20100920) "release 5"
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.2-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- what I was doing when the application crashed
just starting the KDE

The crash can be reproduced every time.

-- Backtrace:
Application: Nepomuk-Dienst (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f68c49be760 (LWP 2152))]

Thread 3 (Thread 0x7f68b42a6710 (LWP 2366)):
#0  0x00007f68c415939c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f68c43e3fab in wait (this=<value optimized out>, mutex=0x76f900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x76f900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f68b493f5b9 in Nepomuk::IndexFeeder::run (this=0x76f8e0) at /usr/src/debug/kdebase-runtime-4.5.69svn1177452/nepomuk/services/strigi/nepomukindexfeeder.cpp:186
#4  0x00007f68c43e38be in QThreadPrivate::start (arg=0x76f8e0) at thread/qthread_unix.cpp:266
#5  0x00007f68c4154a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f68c1f0f82d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f68aea52710 (LWP 2698)):
[KCrash Handler]
#6  QMutex::lock (this=0x8) at thread/qmutex.cpp:151
#7  0x00007f68be9e1022 in QMutexLocker (this=0x93eda0) at /usr/include/QtCore/qmutex.h:102
#8  Soprano::Error::ErrorCache::clearError (this=0x93eda0) at /usr/src/debug/soprano-2.5.63/soprano/error.cpp:238
#9  0x00007f68be9e16b0 in Soprano::Error::ErrorCache::setError (this=0x93eda0, error=...) at /usr/src/debug/soprano-2.5.63/soprano/error.cpp:225
#10 0x00007f68be77676a in Soprano::Client::DBusModel::executeQuery (this=0x93ed90, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>)
    at /usr/src/debug/soprano-2.5.63/client/dbus/dbusmodel.cpp:108
#11 0x00007f68c318a864 in Nepomuk::MainModel::executeQuery (this=0x76d930, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.5.69svn1177452/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x00007f68be9f15d9 in Soprano::FilterModel::executeQuery (this=0x76f020, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>)
    at /usr/src/debug/soprano-2.5.63/soprano/filtermodel.cpp:164
#13 0x00007f68c3180440 in Nepomuk::ResourceManager::generateUniqueUri (this=<value optimized out>, name=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.69svn1177452/nepomuk/core/resourcemanager.cpp:488
#14 0x00007f68b493c14d in Nepomuk::StrigiIndexWriter::startAnalysis (this=0x758430, idx=0x7f68aea519c0)
    at /usr/src/debug/kdebase-runtime-4.5.69svn1177452/nepomuk/services/strigi/nepomukindexwriter.cpp:391
#15 0x00007f68b49418e1 in Nepomuk::Indexer::indexFile (this=<value optimized out>, info=...) at /usr/src/debug/kdebase-runtime-4.5.69svn1177452/nepomuk/services/strigi/nepomukindexer.cpp:127
#16 0x00007f68b493617c in Nepomuk::IndexScheduler::analyzeDir (this=0x76e580, dir=<value optimized out>, flags=...)
    at /usr/src/debug/kdebase-runtime-4.5.69svn1177452/nepomuk/services/strigi/indexscheduler.cpp:369
#17 0x00007f68b49368c5 in Nepomuk::IndexScheduler::run (this=0x76e580) at /usr/src/debug/kdebase-runtime-4.5.69svn1177452/nepomuk/services/strigi/indexscheduler.cpp:271
#18 0x00007f68c43e38be in QThreadPrivate::start (arg=0x76e580) at thread/qthread_unix.cpp:266
#19 0x00007f68c4154a4f in start_thread () from /lib64/libpthread.so.0
#20 0x00007f68c1f0f82d in clone () from /lib64/libc.so.6
#21 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f68c49be760 (LWP 2152)):
#0  0x00007f68c1f066b3 in poll () from /lib64/libc.so.6
#1  0x00007f68c0a64550 in ?? () from /lib64/libdbus-1.so.3
#2  0x00007f68c0a6360d in ?? () from /lib64/libdbus-1.so.3
#3  0x00007f68c0a4de0e in ?? () from /lib64/libdbus-1.so.3
#4  0x00007f68c0a4fdd4 in ?? () from /lib64/libdbus-1.so.3
#5  0x00007f68c0a50456 in dbus_connection_send_with_reply_and_block () from /lib64/libdbus-1.so.3
#6  0x00007f68c0a4aa96 in ?? () from /lib64/libdbus-1.so.3
#7  0x00007f68c0a4c207 in dbus_bus_add_match () from /lib64/libdbus-1.so.3
#8  0x00007f68c3efd73b in q_dbus_bus_add_match (this=0x67ef20, key=..., hook=...) at qdbus_symbols_p.h:90
#9  QDBusConnectionPrivate::connectSignal (this=0x67ef20, key=..., hook=...) at qdbusintegrator.cpp:2053
#10 0x00007f68c3efdf82 in QDBusConnectionPrivate::connectRelay (this=0x67ef20, service=..., path=..., interface=..., receiver=0x953240, signal=<value optimized out>) at qdbusintegrator.cpp:2214
#11 0x00007f68c44e50ff in QObject::connect (sender=0x953240, signal=<value optimized out>, receiver=0x93ed90, method=0x967738 "statementRemoved(Soprano::Statement)", type=Qt::AutoConnection)
    at kernel/qobject.cpp:2584
#12 0x00007f68be774101 in Soprano::Client::DBusModel::DBusModel (this=0x93ed90, serviceName=..., dbusObject=..., backend=<value optimized out>)
    at /usr/src/debug/soprano-2.5.63/client/dbus/dbusmodel.cpp:57
#13 0x00007f68be773476 in Soprano::Client::DBusClient::createModel (this=<value optimized out>, name=<value optimized out>, settings=<value optimized out>)
    at /usr/src/debug/soprano-2.5.63/client/dbus/dbusclient.cpp:77
#14 0x00007f68c31857a2 in init (this=0x76d930) at /usr/src/debug/kdelibs-4.5.69svn1177452/nepomuk/core/nepomukmainmodel.cpp:92
#15 Nepomuk::MainModel::init (this=0x76d930) at /usr/src/debug/kdelibs-4.5.69svn1177452/nepomuk/core/nepomukmainmodel.cpp:176
#16 0x00007f68c317fc87 in Nepomuk::ResourceManager::init (this=0x76d720) at /usr/src/debug/kdelibs-4.5.69svn1177452/nepomuk/core/resourcemanager.cpp:329
#17 0x00007f68c3181c25 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x7265c0, success=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.69svn1177452/nepomuk/core/resourcemanager.cpp:220
#18 0x00007f68c3181d35 in Nepomuk::ResourceManager::qt_metacall (this=0x76d720, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3706d1a0)
    at /usr/src/debug/kdelibs-4.5.69svn1177452/build/nepomuk/resourcemanager.moc:90
#19 0x00007f68c3ef73a8 in QDBusConnectionPrivate::deliverCall (this=0x67ef20, object=0x76d720, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:916
#20 0x00007f68c3f02f4f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#21 0x00007f68c44e27da in QObject::event (this=0x76d720, e=<value optimized out>) at kernel/qobject.cpp:1211
#22 0x00007f68c266ff94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007f68c26783ba in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#24 0x00007f68c3600bc6 in KApplication::notify (this=0x7fff3706de00, receiver=0x76d720, event=0x9553a0) at /usr/src/debug/kdelibs-4.5.69svn1177452/kdeui/kernel/kapplication.cpp:310
#25 0x00007f68c44ce9dc in QCoreApplication::notifyInternal (this=0x7fff3706de00, receiver=0x76d720, event=0x9553a0) at kernel/qcoreapplication.cpp:732
#26 0x00007f68c44d2185 in sendEvent (receiver=0x0, event_type=0, data=0x60ef10) at kernel/qcoreapplication.h:215
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60ef10) at kernel/qcoreapplication.cpp:1373
#28 0x00007f68c44f9463 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007f68c1373a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f68c1374270 in ?? () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f68c1374510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f68c44f95ff in QEventDispatcherGlib::processEvents (this=0x60e5f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x00007f68c2713d5e in ?? () from /usr/lib64/libQtGui.so.4
#35 0x00007f68c44cde12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f68c44ce025 in QEventLoop::exec (this=0x7fff3706dbd0, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f68c44d243b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x0000000000403ea2 in main (argc=2, argv=0x7fff3706e258) at /usr/src/debug/kdebase-runtime-4.5.69svn1177452/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 251418.

Possible duplicates by query: bug 251418, bug 246110, bug 234994.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-18 19:04:03 UTC
[Comment from a bug triager]
This bug may be related to bug 245266. Thanks
Comment 2 Sebastian Trueg 2011-01-17 17:07:15 UTC

*** This bug has been marked as a duplicate of bug 245266 ***