Bug 261397 - Digikam Crashes on Startup
Summary: Digikam Crashes on Startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Image (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-27 18:07 UTC by John Verel
Modified: 2017-01-06 22:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Verel 2010-12-27 18:07:26 UTC
Application: digikam (1.2.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-27-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Hello.  Startup Digikam from KDE menu (Kubuntu) or Konsole command line.  Crashes.  Every time.

The crash can be reproduced every time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76df760 (LWP 3450))]

Thread 8 (Thread 0xb614eb70 (LWP 3451)):
#0  0x00ada422 in __kernel_vsyscall ()
#1  0x001da015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x04cf6287 in QWaitConditionPrivate::wait (this=0x9f2f028, mutex=0x9f2f024, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x9f2f028, mutex=0x9f2f024, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x08321fb4 in Digikam::ScanController::run (this=0x9f38630) at /build/buildd/digikam-1.2.0/digikam/scancontroller.cpp:516
#5  0x04cf532e in QThreadPrivate::start (arg=0x9f38630) at thread/qthread_unix.cpp:248
#6  0x001d596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x022ada4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xb58b5b70 (LWP 3453)):
#0  0x09311e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x04e206fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x04e25825 in QTimerInfoList::updateCurrentTime (this=0xa15968c) at kernel/qeventdispatcher_unix.cpp:340
#3  0x04e2586a in QTimerInfoList::timerWait (this=0xa15968c, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x04e23818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb58b50bc) at kernel/qeventdispatcher_glib.cpp:136
#5  0x04e238a5 in timerSourcePrepare (source=0x0, timeout=0x9315ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x089caaca in IA__g_main_context_prepare (context=0xa158c80, priority=0xb58b513c) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2280
#7  0x089caee9 in g_main_context_iterate (context=0xa158c80, block=<value optimized out>, dispatch=1, self=0xa158d00) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2571
#8  0x089cb4b8 in IA__g_main_context_iteration (context=0xa158c80, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#9  0x04e2360f in QEventDispatcherGlib::processEvents (this=0xa14ef78, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x04df6059 in QEventLoop::processEvents (this=0xb58b5280, flags=) at kernel/qeventloop.cpp:149
#11 0x04df64aa in QEventLoop::exec (this=0xb58b5280, flags=...) at kernel/qeventloop.cpp:201
#12 0x04cf25a8 in QThread::exec (this=0x9f84b20) at thread/qthread.cpp:487
#13 0x041a4ced in Digikam::ImageFilterModelWorker::Thread::run (this=0x9f84b20) at /build/buildd/digikam-1.2.0/obj-i486-linux-gnu/digikam/../../libs/models/imagefiltermodelthreads.h:66
#14 0x04cf532e in QThreadPrivate::start (arg=0x9f84b20) at thread/qthread_unix.cpp:248
#15 0x001d596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x022ada4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xb4effb70 (LWP 3454)):
#0  IA__g_main_context_prepare (context=0xa15aa20, priority=0xb4eff13c) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2282
#1  0x089caee9 in g_main_context_iterate (context=0xa15aa20, block=<value optimized out>, dispatch=1, self=0xa15a230) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2571
#2  0x089cb4b8 in IA__g_main_context_iteration (context=0xa15aa20, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#3  0x04e2360f in QEventDispatcherGlib::processEvents (this=0xa15a2c0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0x04df6059 in QEventLoop::processEvents (this=0xb4eff280, flags=) at kernel/qeventloop.cpp:149
#5  0x04df64aa in QEventLoop::exec (this=0xb4eff280, flags=...) at kernel/qeventloop.cpp:201
#6  0x04cf25a8 in QThread::exec (this=0xa135640) at thread/qthread.cpp:487
#7  0x041a4ced in Digikam::ImageFilterModelWorker::Thread::run (this=0xa135640) at /build/buildd/digikam-1.2.0/obj-i486-linux-gnu/digikam/../../libs/models/imagefiltermodelthreads.h:66
#8  0x04cf532e in QThreadPrivate::start (arg=0xa135640) at thread/qthread_unix.cpp:248
#9  0x001d596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x022ada4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xb467eb70 (LWP 3455)):
#0  0x00ada422 in __kernel_vsyscall ()
#1  0x001da015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x04cf6287 in QWaitConditionPrivate::wait (this=0xa13d828, mutex=0xa13d824, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0xa13d828, mutex=0xa13d824, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x0691810a in Digikam::LoadSaveThread::run (this=0xa13d818) at /build/buildd/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#5  0x04cf532e in QThreadPrivate::start (arg=0xa13d818) at thread/qthread_unix.cpp:248
#6  0x001d596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x022ada4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xb3e7db70 (LWP 3456)):
#0  IA__g_main_context_check (context=0xa1bb200, max_priority=2147483647, fds=0xa1b5be8, n_fds=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2472
#1  0x089cb0ce in g_main_context_iterate (context=0xa1bb200, block=<value optimized out>, dispatch=1, self=0xa1b77a8) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2588
#2  0x089cb4b8 in IA__g_main_context_iteration (context=0xa1bb200, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#3  0x04e2360f in QEventDispatcherGlib::processEvents (this=0xa1b77f8, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0x04df6059 in QEventLoop::processEvents (this=0xb3e7d2a0, flags=) at kernel/qeventloop.cpp:149
#5  0x04df64aa in QEventLoop::exec (this=0xb3e7d2a0, flags=...) at kernel/qeventloop.cpp:201
#6  0x04cf25a8 in QThread::exec (this=0xa1b47b8) at thread/qthread.cpp:487
#7  0x04cf532e in QThreadPrivate::start (arg=0xa1b47b8) at thread/qthread_unix.cpp:248
#8  0x001d596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#9  0x022ada4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xb367cb70 (LWP 3457)):
#0  0x001d7f5b in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#1  0x089ca7c8 in IA__g_main_context_check (context=0xa1b9d50, max_priority=2147483647, fds=0xa1b5898, n_fds=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2471
#2  0x089cb0ce in g_main_context_iterate (context=0xa1b9d50, block=<value optimized out>, dispatch=1, self=0xa1b5858) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2588
#3  0x089cb4b8 in IA__g_main_context_iteration (context=0xa1b9d50, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#4  0x04e2360f in QEventDispatcherGlib::processEvents (this=0xa1b6b98, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#5  0x04df6059 in QEventLoop::processEvents (this=0xb367c2a0, flags=) at kernel/qeventloop.cpp:149
#6  0x04df64aa in QEventLoop::exec (this=0xb367c2a0, flags=...) at kernel/qeventloop.cpp:201
#7  0x04cf25a8 in QThread::exec (this=0xa1b7550) at thread/qthread.cpp:487
#8  0x04cf532e in QThreadPrivate::start (arg=0xa1b7550) at thread/qthread_unix.cpp:248
#9  0x001d596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x022ada4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xad914b70 (LWP 3461)):
#0  0x00ada422 in __kernel_vsyscall ()
#1  0x0229fb86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x056a5502 in ?? () from /usr/lib/libpulse.so.0
#3  0x05691a59 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x05693a13 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x05693ae4 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x056a52a3 in ?? () from /usr/lib/libpulse.so.0
#7  0x0426fe02 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0x001d596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#9  0x022ada4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb76df760 (LWP 3450)):
[KCrash Handler]
#6  0x03dade5c in ?? () from /usr/lib/libasound.so.2
#7  0x03d6ae9e in snd_pcm_close () from /usr/lib/libasound.so.2
#8  0x03d09662 in gst_alsasink_close (asink=0xa402c58) at gstalsasink.c:804
#9  0x03f90512 in gst_audioringbuffer_close_device (buf=0xa3ff2c0) at gstaudiosink.c:365
#10 0x03f806f0 in gst_ring_buffer_close_device (buf=0xa3ff2c0) at gstringbuffer.c:714
#11 0x03f8ae42 in gst_base_audio_sink_change_state (element=0xa402c58, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1879
#12 0x03fdb435 in gst_element_change_state (element=0xa402c58, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2548
#13 0x03fde928 in gst_element_set_state_func (element=0xa402c58, state=GST_STATE_NULL) at gstelement.c:2504
#14 0x03fda7f0 in gst_element_set_state (element=0xa402c58, state=GST_STATE_NULL) at gstelement.c:2405
#15 0x03cc4e1c in Phonon::Gstreamer::AudioOutput::setOutputDevice (this=0xa40a800, newDevice=...) at ../../gstreamer/audiooutput.cpp:217
#16 0x009b6621 in callSetOutputDevice (this=0xa2c5698) at ../3rdparty/phonon/phonon/audiooutput.cpp:67
#17 Phonon::AudioOutputPrivate::setupBackendObject (this=0xa2c5698) at ../3rdparty/phonon/phonon/audiooutput.cpp:281
#18 0x009b6d22 in Phonon::AudioOutputPrivate::createBackendObject (this=0xa2c5698) at ../3rdparty/phonon/phonon/audiooutput.cpp:124
#19 0x009b3284 in Phonon::AudioOutputPrivate::init (this=0xa2c5698, c=Phonon::VideoCategory) at ../3rdparty/phonon/phonon/audiooutput.cpp:106
#20 0x009b3929 in AudioOutput (this=0xa2c5680, category=Phonon::VideoCategory, parent=0xa2c52d8) at ../3rdparty/phonon/phonon/audiooutput.cpp:76
#21 0x009d7f5d in Phonon::VideoPlayerPrivate::init (this=0xa2c54c8, q=0xa2c52d8, category=Phonon::VideoCategory) at ../3rdparty/phonon/phonon/videoplayer.cpp:59
#22 0x009d82e0 in VideoPlayer (this=0xa2c52d8, category=Phonon::VideoCategory, parent=0xa2c4cc8) at ../3rdparty/phonon/phonon/videoplayer.cpp:75
#23 0x0831104b in MediaPlayerView (this=0xa2c3160, parent=0x9f52230) at /build/buildd/digikam-1.2.0/digikam/mediaplayerview.cpp:124
#24 0x082a5aee in AlbumWidgetStack (this=0x9f52230, parent=0xa0bd9f8) at /build/buildd/digikam-1.2.0/digikam/albumwidgetstack.cpp:105
#25 0x082da3a0 in DigikamView (this=0xa13ce58, parent=0x9f4a098, modelCollection=0x9f43880) at /build/buildd/digikam-1.2.0/digikam/digikamview.cpp:169
#26 0x082c06bd in Digikam::DigikamApp::setupView (this=0x9f4a098) at /build/buildd/digikam-1.2.0/digikam/digikamapp.cpp:478
#27 0x082ceb62 in DigikamApp (this=0x9f4a098, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/digikam-1.2.0/digikam/digikamapp.cpp:230
#28 0x083c292a in main (argc=1, argv=0xbfb4df34) at /build/buildd/digikam-1.2.0/digikam/main.cpp:170

Possible duplicates by query: bug 253416, bug 248238, bug 246495, bug 245249, bug 244298.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-12-27 18:45:45 UTC

*** This bug has been marked as a duplicate of bug 232068 ***
Comment 2 Myriam Schweingruber 2011-04-27 21:18:49 UTC
reassigning to the new bugzilla product for better bug tracing of the various backends. Sorry for the noise.
Comment 3 caulier.gilles 2017-01-06 22:18:20 UTC
digiKam 5.4.0 bundles will use QtAV framework instead Qt5Multimedia to thumb
and play video/audio. The Slideshow tool will also support video as well.

QtAV use ffmpeg codecs. It's multi-platform and will always available in
OSX, Windows and Linux bundles that digiKam team provide.

For Linux packagers, you will need to turn on video support at compilation time
and solve QtAV dependencies...

See screenshots here :

https://www.flickr.com/photos/digikam/30886133553
https://www.flickr.com/photos/digikam/31679362466
https://www.flickr.com/photos/digikam/31572654722
https://www.flickr.com/photos/digikam/31726086736

Bundles have been recompiled are posted to GDrive for testing :

https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWelRJenM