Bug 244298 - Executable: Knotify PID: 27179 signal: 11 segmentation fault
Summary: Executable: Knotify PID: 27179 signal: 11 segmentation fault
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-12 16:11 UTC by provence16
Modified: 2010-07-12 16:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description provence16 2010-07-12 16:11:11 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
KDE always crashes after completed burn & displays the error message: Executable: Knotify PID: 27179 signal: 11 segmentation fault

The crash can be reproduced every time.

 -- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77f6710 (LWP 27179))]

Thread 2 (Thread 0xb20f3b70 (LWP 27295)):
#0  0x00dea422 in __kernel_vsyscall ()
#1  0x4b430b86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x4d4d6502 in ?? () from /usr/lib/libpulse.so.0
#3  0x4d4c2a59 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x4d4c4a13 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x4d4c4ae4 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x4d4d62a3 in ?? () from /usr/lib/libpulse.so.0
#7  0x4d494e02 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0x4b50096e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#9  0x4b43ea4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77f6710 (LWP 27179)):
[KCrash Handler]
#6  0x4c5ade5c in ?? () from /usr/lib/libasound.so.2
#7  0x4c56ae9e in snd_pcm_close () from /usr/lib/libasound.so.2
#8  0x00290662 in gst_alsasink_close (asink=0x8e4c530) at gstalsasink.c:804
#9  0x0027c512 in gst_audioringbuffer_close_device (buf=<value optimized out>) at gstaudiosink.c:365
#10 0x0026c6f0 in gst_ring_buffer_close_device (buf=<value optimized out>) at gstringbuffer.c:714
#11 0x00276e42 in gst_base_audio_sink_change_state (element=<value optimized out>, transition=<value optimized out>) at gstbaseaudiosink.c:1879
#12 0x4c97a435 in gst_element_change_state (element=<value optimized out>, transition=<value optimized out>) at gstelement.c:2548
#13 0x4c97d928 in gst_element_set_state_func (element=<value optimized out>, state=<value optimized out>) at gstelement.c:2504
#14 0x4c9797f0 in gst_element_set_state (element=<value optimized out>, state=) at gstelement.c:2405
#15 0x4c969827 in gst_bin_element_set_state (element=<value optimized out>, transition=<value optimized out>) at gstbin.c:2118
#16 gst_bin_change_state_func (element=<value optimized out>, transition=<value optimized out>) at gstbin.c:2417
#17 0x4c97a435 in gst_element_change_state (element=<value optimized out>, transition=<value optimized out>) at gstelement.c:2548
#18 0x4c97d928 in gst_element_set_state_func (element=<value optimized out>, state=<value optimized out>) at gstelement.c:2504
#19 0x4c9797f0 in gst_element_set_state (element=<value optimized out>, state=) at gstelement.c:2405
#20 0x4c969827 in gst_bin_element_set_state (element=<value optimized out>, transition=<value optimized out>) at gstbin.c:2118
#21 gst_bin_change_state_func (element=<value optimized out>, transition=<value optimized out>) at gstbin.c:2417
#22 0x00f8b11e in gst_switch_sink_change_state (element=0x8e3d188, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstswitchsink.c:255
#23 0x00f87f56 in gst_gconf_audio_sink_change_state (element=0x8e3d188, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstgconfaudiosink.c:298
#24 0x4c97a435 in gst_element_change_state (element=<value optimized out>, transition=<value optimized out>) at gstelement.c:2548
#25 0x4c97d928 in gst_element_set_state_func (element=<value optimized out>, state=<value optimized out>) at gstelement.c:2504
#26 0x4c9797f0 in gst_element_set_state (element=<value optimized out>, state=) at gstelement.c:2405
#27 0x00a16e1c in Phonon::Gstreamer::AudioOutput::setOutputDevice (this=0x8cf5c28, newDevice=...) at ../../gstreamer/audiooutput.cpp:217
#28 0x43962561 in callSetOutputDevice (this=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:67
#29 Phonon::AudioOutputPrivate::setupBackendObject (this=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:281
#30 0x43962c62 in Phonon::AudioOutputPrivate::createBackendObject (this=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:124
#31 0x4395f1c4 in Phonon::AudioOutputPrivate::init (this=<value optimized out>, c=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:106
#32 0x4395f869 in AudioOutput (this=<value optimized out>, category=<value optimized out>, parent=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:76
#33 0x080535b4 in Player (this=0x8ccf7c4) at ../../knotify/notifybysound.cpp:59
#34 PlayerPool::getPlayer (this=0x8ccf7c4) at ../../knotify/notifybysound.cpp:99
#35 0x08053b01 in NotifyBySound::notify (this=0x8cd1b30, eventId=5, config=0x8cab000) at ../../knotify/notifybysound.cpp:243
#36 0x0804f475 in KNotify::emitEvent (this=0xbfabcf04, e=0x8caaff8) at ../../knotify/knotify.cpp:179
#37 0x0804f70b in KNotify::event (this=0xbfabcf04, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0) at ../../knotify/knotify.cpp:128
#38 0x0804fa05 in KNotifyAdaptor::event (this=0x8c9f4b0, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=<value optimized out>)
    at ../../knotify/knotify.cpp:236
#39 0x080505ad in KNotifyAdaptor::qt_metacall (this=0x8c9f4b0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfabc4ec) at ./knotify.moc:227
#40 0x4be86014 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=<value optimized out>, 
    slotIdx=<value optimized out>) at qdbusintegrator.cpp:904
#41 0x4be87325 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=<value optimized out>, flags=<value optimized out>, msg=<value optimized out>) at qdbusintegrator.cpp:816
#42 0x4be87d60 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=<value optimized out>, pathStartPos=<value optimized out>)
    at qdbusintegrator.cpp:1364
#43 0x4be87ffa in QDBusActivateObjectEvent::placeMetaCall (this=) at qdbusintegrator.cpp:1477
#44 0x4bd1771e in QObject::event (this=<value optimized out>, e=<value optimized out>) at kernel/qobject.cpp:1248
#45 0x424da07c in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4300
#46 0x424e0bfe in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:3704
#47 0x43035f6a in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:302
#48 0x4bd06d5b in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:704
#49 0x4bd09793 in QCoreApplication::sendEvent (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#50 QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>) at kernel/qcoreapplication.cpp:1345
#51 0x4bd098fd in QCoreApplication::sendPostedEvents (receiver=) at kernel/qcoreapplication.cpp:1238
#52 0x4bd32dff in QCoreApplication::sendPostedEvents (s=) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#53 postEventSourceDispatch (s=) at kernel/qeventdispatcher_glib.cpp:276
#54 0x4b5735e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#55 0x4b5772d8 in ?? () from /lib/libglib-2.0.so.0
#56 0x4b5774b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#57 0x4bd328f5 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#58 0x42599cd5 in QGuiEventDispatcherGlib::processEvents (this=) at kernel/qguieventdispatcher_glib.cpp:204
#59 0x4bd05379 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#60 0x4bd057ca in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#61 0x4bd099bf in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#62 0x424da117 in QApplication::exec () at kernel/qapplication.cpp:3579
#63 0x0804e52f in main (argc=1, argv=0xbfabd094) at ../../knotify/main.cpp:73

Possible duplicates by query: bug 244191, bug 241334, bug 240428, bug 240181, bug 238918.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-07-12 16:32:44 UTC

*** This bug has been marked as a duplicate of bug 232068 ***