Bug 253416 - Kopete crashed when new message is recieved
Summary: Kopete crashed when new message is recieved
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-06 20:29 UTC by dima.vox
Modified: 2010-10-06 21:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dima.vox 2010-10-06 20:29:54 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Kopete crashed when new message is recieved. No pop-up window is shown when new message is recieved meanwhile pop-up is enabled in settings. There is crash report window instead

The crash can be reproduced every time.

 -- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc288da3760 (LWP 2388))]

Thread 2 (Thread 0x7fc26d6aa710 (LWP 2389)):
#0  0x00007fc286528fb3 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc2725c141f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007fc2725b0d86 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007fc2725b2809 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007fc2725b28c0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007fc2725c121b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007fc2723800e8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007fc284bf89ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007fc28653572d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc288da3760 (LWP 2388)):
[KCrash Handler]
#5  0x00007fc279cc5e49 in ?? () from /usr/lib/libasound.so.2
#6  0x00007fc279c88b15 in snd_pcm_close () from /usr/lib/libasound.so.2
#7  0x00007fc2729e36ff in gst_alsasink_close (asink=<value optimized out>) at gstalsasink.c:804
#8  0x00007fc27386d3c6 in gst_audioringbuffer_close_device (buf=<value optimized out>) at gstaudiosink.c:365
#9  0x00007fc273860ecb in gst_ring_buffer_close_device (buf=0x2366470) at gstringbuffer.c:714
#10 0x00007fc273868ca6 in gst_base_audio_sink_change_state (element=<value optimized out>, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1879
#11 0x00007fc27410c18c in gst_element_change_state (element=0x26d80f0, transition=0) at gstelement.c:2548
#12 0x00007fc27410f1bb in gst_element_set_state_func (element=0x269c800, state=GST_STATE_NULL) at gstelement.c:2504
#13 0x00007fc2740fcc29 in gst_bin_element_set_state (element=0x23e28a0, transition=<value optimized out>) at gstbin.c:2118
#14 gst_bin_change_state_func (element=0x23e28a0, transition=<value optimized out>) at gstbin.c:2417
#15 0x00007fc27410c18c in gst_element_change_state (element=0x26d80f0, transition=0) at gstelement.c:2548
#16 0x00007fc27410f1bb in gst_element_set_state_func (element=0x23e28a0, state=GST_STATE_NULL) at gstelement.c:2504
#17 0x00007fc2740fcc29 in gst_bin_element_set_state (element=0x26a4260, transition=<value optimized out>) at gstbin.c:2118
#18 gst_bin_change_state_func (element=0x26a4260, transition=<value optimized out>) at gstbin.c:2417
#19 0x00007fc273240372 in gst_switch_sink_change_state (element=0x26a4260, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstswitchsink.c:255
#20 0x00007fc27323d7c5 in gst_gconf_audio_sink_change_state (element=0x26a4260, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstgconfaudiosink.c:298
#21 0x00007fc27410c18c in gst_element_change_state (element=0x26d80f0, transition=0) at gstelement.c:2548
#22 0x00007fc27410f1bb in gst_element_set_state_func (element=0x26a4260, state=GST_STATE_NULL) at gstelement.c:2504
#23 0x00007fc2749069aa in Phonon::Gstreamer::AudioOutput::setOutputDevice (this=0x2488c50, newDevice=<value optimized out>) at ../../gstreamer/audiooutput.cpp:217
#24 0x00007fc28833b010 in callSetOutputDevice (this=0x24628e0) at ../3rdparty/phonon/phonon/audiooutput.cpp:67
#25 Phonon::AudioOutputPrivate::setupBackendObject (this=0x24628e0) at ../3rdparty/phonon/phonon/audiooutput.cpp:281
#26 0x00007fc28833b6f0 in Phonon::AudioOutputPrivate::createBackendObject (this=0x24628e0) at ../3rdparty/phonon/phonon/audiooutput.cpp:124
#27 0x00007fc288337eea in Phonon::AudioOutputPrivate::init (this=0x24628e0, c=<value optimized out>) at ../3rdparty/phonon/phonon/audiooutput.cpp:106
#28 0x00007fc28833859d in AudioOutput (this=0x24631d0, category=Phonon::NotificationCategory, parent=0x0) at ../3rdparty/phonon/phonon/audiooutput.cpp:76
#29 0x000000000040d101 in Player (this=0x2419608) at ../../knotify/notifybysound.cpp:59
#30 PlayerPool::getPlayer (this=0x2419608) at ../../knotify/notifybysound.cpp:99
#31 0x000000000040d63e in NotifyBySound::notify (this=0x24478a0, eventId=2, config=0x7fffc3559720) at ../../knotify/notifybysound.cpp:243
#32 0x0000000000408d63 in KNotify::emitEvent (this=0x7fffc355aa20, e=0x2232460) at ../../knotify/knotify.cpp:179
#33 0x0000000000409022 in KNotify::event (this=0x7fffc355aa20, event=<value optimized out>, appname=<value optimized out>, contexts=<value optimized out>, title=<value optimized out>, 
    text=<value optimized out>, image=..., actions=..., timeout=-1, winId=35676136) at ../../knotify/knotify.cpp:128
#34 0x000000000040935f in KNotifyAdaptor::event (this=0x244d4f0, event=..., fromApp=..., contexts=<value optimized out>, title=..., text=<value optimized out>, image=..., actions=..., timeout=-1, 
    winId=35676136) at ../../knotify/knotify.cpp:236
#35 0x000000000040a03b in KNotifyAdaptor::qt_metacall (this=0x244d4f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc3559cb0) at ./knotify.moc:227
#36 0x00007fc287c24486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#37 0x00007fc287c2574b in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x244d4f0, flags=273, msg=...) at qdbusintegrator.cpp:816
#38 0x00007fc287c261cd in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1364
#39 0x00007fc287c26468 in QDBusActivateObjectEvent::placeMetaCall (this=0x2474780) at qdbusintegrator.cpp:1477
#40 0x00007fc2878fad49 in QObject::event (this=0x7fffc355aa20, e=0x2474780) at kernel/qobject.cpp:1248
#41 0x00007fc286ca422c in QApplicationPrivate::notify_helper (this=0x2240730, receiver=0x7fffc355aa20, e=0x2474780) at kernel/qapplication.cpp:4300
#42 0x00007fc286caa6fb in QApplication::notify (this=0x7fffc355aa50, receiver=0x7fffc355aa20, e=0x2474780) at kernel/qapplication.cpp:4183
#43 0x00007fc2887a5526 in KApplication::notify (this=0x7fffc355aa50, receiver=0x7fffc355aa20, event=0x2474780) at ../../kdeui/kernel/kapplication.cpp:302
#44 0x00007fc2878eb06c in QCoreApplication::notifyInternal (this=0x7fffc355aa50, receiver=0x7fffc355aa20, event=0x2474780) at kernel/qcoreapplication.cpp:704
#45 0x00007fc2878ed7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x221bff0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x221bff0) at kernel/qcoreapplication.cpp:1345
#47 0x00007fc2879149d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#49 0x00007fc2835308c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#50 0x00007fc283534748 in ?? () from /lib/libglib-2.0.so.0
#51 0x00007fc2835348fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#52 0x00007fc287914513 in QEventDispatcherGlib::processEvents (this=0x221bb30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#53 0x00007fc286d5446e in QGuiEventDispatcherGlib::processEvents (this=0x26d80f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x00007fc2878e9992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#55 0x00007fc2878e9d6c in QEventLoop::exec (this=0x7fffc355a970, flags=) at kernel/qeventloop.cpp:201
#56 0x00007fc2878edaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#57 0x0000000000407f4f in main (argc=<value optimized out>, argv=<value optimized out>) at ../../knotify/main.cpp:73

Possible duplicates by query: bug 248238, bug 246495, bug 245249, bug 244298, bug 244191.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-06 21:11:16 UTC

*** This bug has been marked as a duplicate of bug 232068 ***