Bug 248238 - Knotify random crash
Summary: Knotify random crash
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-18 13:33 UTC by Adrian Cozma
Modified: 2010-08-18 13:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Cozma 2010-08-18 13:33:32 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.5.00 (KDE 4.5.0)
Qt Version: 4.6.3
Operating System: Linux 2.6.31.12-0.2-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
KNotify random crashes when reporting Phonon configuration problems (which happens every time at login for me, probably while waiting for devices to appear) and KMail incoming e-mails.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f76a57c5750 (LWP 16638))]

Thread 2 (Thread 0x7f768964d910 (LWP 16745)):
#0  0x00007f76a2cb7d03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f76a0f1a8bf in poll_func (ufds=0x9051a0, nfds=2, timeout=-1, userdata=0x7b3d00) at pulse/thread-mainloop.c:75
#2  0x00007f76a0f0ab76 in pa_mainloop_poll (m=0x7b3c00) at pulse/mainloop.c:879
#3  0x00007f76a0f0bf59 in pa_mainloop_iterate (m=0x7b3c00, block=<value optimized out>, retval=0x0) at pulse/mainloop.c:961
#4  0x00007f76a0f0c010 in pa_mainloop_run (m=0x7b3c00, retval=0x0) at pulse/mainloop.c:979
#5  0x00007f76a0f1a7cb in thread (userdata=0x900b40) at pulse/thread-mainloop.c:94
#6  0x00007f769dcaf978 in internal_thread_func (userdata=0x8e2f90) at pulsecore/thread-posix.c:72
#7  0x00007f76a138a65d in start_thread (arg=<value optimized out>) at pthread_create.c:297
#8  0x00007f76a2cc0e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f76a57c5750 (LWP 16638)):
[KCrash Handler]
#6  0x00007f7694fc0019 in snd_pcm_ioplug_close (pcm=<value optimized out>) at pcm_ioplug.c:743
#7  0x00007f7694f82d15 in snd_pcm_close (pcm=0x8feaa0) at pcm.c:706
#8  0x00007f7694f9cf2d in snd_pcm_plug_close (pcm=0x8fecc0) at pcm_plug.c:71
#9  0x00007f7694f82d15 in snd_pcm_close (pcm=0x8fecc0) at pcm.c:706
#10 0x00007f768d861085 in gst_alsasink_close (asink=<value optimized out>) at gstalsasink.c:783
#11 0x00007f7693a2199c in gst_audioringbuffer_close_device (buf=<value optimized out>) at gstaudiosink.c:365
#12 0x00007f7693a15ceb in gst_ring_buffer_close_device (buf=0x8eb450) at gstringbuffer.c:714
#13 0x00007f7693a1d6d6 in gst_base_audio_sink_change_state (element=0x904200, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1888
#14 0x00007f76942cb26c in gst_element_change_state (element=0x900a50, transition=0) at gstelement.c:2546
#15 0x00007f76942ce7ac in gst_element_set_state_func (element=0x904200, state=2674907072) at gstelement.c:2502
#16 0x00007f7694a4a87a in Phonon::MediaSource::type() const () at /usr/include/QtCore/qshareddata.h:137
#17 0x00007f76a4d747d3 in callSetOutputDevice (dev=<value optimized out>, d=<value optimized out>) at /usr/src/debug/phonon-4.4.2/phonon/audiooutput.cpp:70
#18 Phonon::AudioOutputPrivate::setupBackendObject (dev=<value optimized out>, d=<value optimized out>) at /usr/src/debug/phonon-4.4.2/phonon/audiooutput.cpp:314
#19 0x00007f76a4d74cb3 in Phonon::AudioOutputPrivate::createBackendObject (this=0x774520) at /usr/src/debug/phonon-4.4.2/phonon/audiooutput.cpp:139
#20 0x00007f76a4d7241a in Phonon::AudioOutputPrivate::init (this=0x774520, c=<value optimized out>) at /usr/src/debug/phonon-4.4.2/phonon/audiooutput.cpp:106
#21 0x000000000040e6a1 in Player (this=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.5.0/knotify/notifybysound.cpp:59
#22 PlayerPool::getPlayer (this=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.5.0/knotify/notifybysound.cpp:99
#23 0x000000000040ebde in NotifyBySound::notify (this=0x766230, eventId=3, config=0x7fffac7fb550) at /usr/src/debug/kdebase-runtime-4.5.0/knotify/notifybysound.cpp:243
#24 0x000000000040a023 in KNotify::emitEvent (this=0x7fffac7fc7c0, e=0x6fcf90) at /usr/src/debug/kdebase-runtime-4.5.0/knotify/knotify.cpp:181
#25 0x000000000040a2e2 in KNotify::event (this=0x7fffac7fc7c0, event=<value optimized out>, appname=<value optimized out>, contexts=<value optimized out>, title=<value optimized out>, 
    text=<value optimized out>, image=..., actions=..., timeout=-1, winId=0) at /usr/src/debug/kdebase-runtime-4.5.0/knotify/knotify.cpp:130
#26 0x000000000040a61f in KNotifyAdaptor::event (this=0x6c2c80, event=..., fromApp=..., contexts=<value optimized out>, title=..., text=<value optimized out>, image=..., actions=..., timeout=-1, 
    winId=0) at /usr/src/debug/kdebase-runtime-4.5.0/knotify/knotify.cpp:238
#27 0x000000000040b2fb in KNotifyAdaptor::qt_metacall (this=0x6c2c80, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffac7fba50)
    at /usr/src/debug/kdebase-runtime-4.5.0/build/knotify/knotify.moc:227
#28 0x00007f76a439446e in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#29 0x00007f76a439528b in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x6c2c80, flags=273, msg=...) at qdbusintegrator.cpp:816
#30 0x00007f76a4395d0d in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1364
#31 0x00007f76a4395fa8 in QDBusActivateObjectEvent::placeMetaCall (this=0x72a7c0) at qdbusintegrator.cpp:1477
#32 0x00007f76a4069949 in QObject::event (this=0x7fffac7fc7c0, e=0x72a7c0) at kernel/qobject.cpp:1248
#33 0x00007f76a34177fc in QApplicationPrivate::notify_helper (this=0x64fb40, receiver=0x7fffac7fc7c0, e=0x72a7c0) at kernel/qapplication.cpp:4302
#34 0x00007f76a341dddb in QApplication::notify (this=0x7fffac7fc7f0, receiver=0x7fffac7fc7c0, e=0x72a7c0) at kernel/qapplication.cpp:4185
#35 0x00007f76a516f5c6 in KApplication::notify (this=0x7fffac7fc7f0, receiver=0x7fffac7fc7c0, event=0x72a7c0) at /usr/src/debug/kdelibs-4.5.0/kdeui/kernel/kapplication.cpp:310
#36 0x00007f76a4059b1c in QCoreApplication::notifyInternal (this=0x7fffac7fc7f0, receiver=0x7fffac7fc7c0, event=0x72a7c0) at kernel/qcoreapplication.cpp:726
#37 0x00007f76a405d1d4 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1367
#39 0x00007f76a4083653 in sendPostedEvents () at kernel/qcoreapplication.h:220
#40 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:276
#41 0x00007f769f473dee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f769f4777b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f769f4778e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f76a4083193 in QEventDispatcherGlib::processEvents (this=0x64f190, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#45 0x00007f76a34c621e in QGuiEventDispatcherGlib::processEvents (this=0x900a50, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00007f76a4058432 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#47 0x00007f76a405880c in QEventLoop::exec (this=0x7fffac7fc710, flags=) at kernel/qeventloop.cpp:201
#48 0x00007f76a405d4bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#49 0x00000000004091cf in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.5.0/knotify/main.cpp:73
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-18 13:40:12 UTC
closing as dupplicate from coling

*** This bug has been marked as a duplicate of bug 232068 ***