Bug 246495 - crash at startup
Summary: crash at startup
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-02 10:55 UTC by claude_hum
Modified: 2013-09-20 16:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.13 KB, text/plain)
2013-09-20 16:28 UTC, afg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description claude_hum 2010-08-02 10:55:27 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
the crash happens each time on startup and on each different session.

The crash can be reproduced every time.

 -- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f1710 (LWP 2252))]

Thread 2 (Thread 0xb481bb70 (LWP 2257)):
#0  0x00a16422 in __kernel_vsyscall ()
#1  0x00951b86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x073cc502 in ?? () from /usr/lib/libpulse.so.0
#3  0x073b8a59 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x073baa13 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x073baae4 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x073cc2a3 in ?? () from /usr/lib/libpulse.so.0
#7  0x02832e02 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0x00ee496e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#9  0x0095fa4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb76f1710 (LWP 2252)):
[KCrash Handler]
#6  0x023f8e5c in ?? () from /usr/lib/libasound.so.2
#7  0x023b5e9e in snd_pcm_close () from /usr/lib/libasound.so.2
#8  0x053d7662 in gst_alsasink_close (asink=0x97b8008) at gstalsasink.c:804
#9  0x06374512 in gst_audioringbuffer_close_device (buf=0x95a9c88) at gstaudiosink.c:365
#10 0x063646f0 in gst_ring_buffer_close_device (buf=0x95a9c88) at gstringbuffer.c:714
#11 0x0636ee42 in gst_base_audio_sink_change_state (element=0x97b8008, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1879
#12 0x026ea435 in gst_element_change_state (element=0x97b8008, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2548
#13 0x026ed928 in gst_element_set_state_func (element=0x97b8008, state=GST_STATE_NULL) at gstelement.c:2504
#14 0x026e97f0 in gst_element_set_state (element=0x97b8008, state=GST_STATE_NULL) at gstelement.c:2405
#15 0x026d9827 in gst_bin_element_set_state (element=0x95aca58, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2118
#16 gst_bin_change_state_func (element=0x95aca58, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2417
#17 0x026ea435 in gst_element_change_state (element=0x95aca58, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2548
#18 0x026ed928 in gst_element_set_state_func (element=0x95aca58, state=GST_STATE_NULL) at gstelement.c:2504
#19 0x026e97f0 in gst_element_set_state (element=0x95aca58, state=GST_STATE_NULL) at gstelement.c:2405
#20 0x026d9827 in gst_bin_element_set_state (element=0x978f190, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2118
#21 gst_bin_change_state_func (element=0x978f190, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2417
#22 0x0607811e in gst_switch_sink_change_state (element=0x978f190, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstswitchsink.c:255
#23 0x06074f56 in gst_gconf_audio_sink_change_state (element=0x978f190, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstgconfaudiosink.c:298
#24 0x026ea435 in gst_element_change_state (element=0x978f190, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2548
#25 0x026ed928 in gst_element_set_state_func (element=0x978f190, state=GST_STATE_NULL) at gstelement.c:2504
#26 0x026e97f0 in gst_element_set_state (element=0x978f190, state=GST_STATE_NULL) at gstelement.c:2405
#27 0x026d9827 in gst_bin_element_set_state (element=0x95accb0, transition=9) at gstbin.c:2118
#28 gst_bin_change_state_func (element=0x95accb0, transition=9) at gstbin.c:2417
#29 0x026ea435 in gst_element_change_state (element=0x95accb0, transition=9) at gstelement.c:2548
#30 0x026ed928 in gst_element_set_state_func (element=0x95accb0, state=GST_STATE_NULL) at gstelement.c:2504
#31 0x026e97f0 in gst_element_set_state (element=0x95accb0, state=GST_STATE_NULL) at gstelement.c:2405
#32 0x01f3df98 in Phonon::Gstreamer::MediaNode::addOutput (this=0x94bd190, output=0x96716b4, tee=0x956ac30) at ../../gstreamer/medianode.cpp:317
#33 0x01f3ef1b in Phonon::Gstreamer::MediaNode::linkMediaNodeList (this=0x94bd190, list=..., bin=0x97e1650, tee=0x956ac30, fakesink=0x9796740, src=0x97e0210) at ../../gstreamer/medianode.cpp:392
#34 0x01f3f06e in Phonon::Gstreamer::MediaNode::link (this=0x94bd190) at ../../gstreamer/medianode.cpp:404
#35 0x01f3ec8a in Phonon::Gstreamer::MediaNode::buildGraph (this=0x94bd190) at ../../gstreamer/medianode.cpp:102
#36 0x01f3f6c5 in Phonon::Gstreamer::MediaNode::connectNode (this=0x94bd190, obj=0x96716a8) at ../../gstreamer/medianode.cpp:188
#37 0x01f2e3ec in Phonon::Gstreamer::Backend::connectNodes (this=0x96805f0, source=0x94bd180, sink=0x96716a8) at ../../gstreamer/backend.cpp:356
#38 0x00d98ed6 in Phonon::PathPrivate::executeTransaction (this=0x965ce18, disconnections=..., connections=...) at ../3rdparty/phonon/phonon/path.cpp:332
#39 0x00d99ccc in Phonon::Path::reconnect (this=0xbfe609ec, source=0x94ccc08, sink=0x9655bc8) at ../3rdparty/phonon/phonon/path.cpp:197
#40 0x00d9a22b in Phonon::createPath (source=0x94ccc08, sink=0x9655bc8) at ../3rdparty/phonon/phonon/path.cpp:436
#41 0x080535e4 in Player (this=0x962e91c) at ../../knotify/notifybysound.cpp:61
#42 PlayerPool::getPlayer (this=0x962e91c) at ../../knotify/notifybysound.cpp:99
#43 0x08053b01 in NotifyBySound::notify (this=0x9658c38, eventId=1, config=0x95cbd40) at ../../knotify/notifybysound.cpp:243
#44 0x0804f475 in KNotify::emitEvent (this=0xbfe617a4, e=0x95cbd38) at ../../knotify/knotify.cpp:179
#45 0x0804f70b in KNotify::event (this=0xbfe617a4, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=56623258) at ../../knotify/knotify.cpp:128
#46 0x0804fa05 in KNotifyAdaptor::event (this=0x9546d58, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=<value optimized out>)
    at ../../knotify/knotify.cpp:236
#47 0x080505ad in KNotifyAdaptor::qt_metacall (this=0x9546d58, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfe60d8c) at ./knotify.moc:227
#48 0x00743b34 in QDBusConnectionPrivate::deliverCall (this=0x94b8c70, object=0x9546d58, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:904
#49 0x00744ddf in QDBusConnectionPrivate::activateCall (this=0x94b8c70, object=0x9546d58, flags=273, msg=...) at qdbusintegrator.cpp:809
#50 0x00745880 in QDBusConnectionPrivate::activateObject (this=0x94b8c70, node=..., msg=..., pathStartPos=7) at qdbusintegrator.cpp:1364
#51 0x00745b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x964cf58) at qdbusintegrator.cpp:1477
#52 0x00b903fe in QObject::event (this=0xbfe617a4, e=0x964cf58) at kernel/qobject.cpp:1248
#53 0x011094dc in QApplicationPrivate::notify_helper (this=0x94c20c8, receiver=0xbfe617a4, e=0x964cf58) at kernel/qapplication.cpp:4300
#54 0x0111005e in QApplication::notify (this=0xbfe617b8, receiver=0xbfe617a4, e=0x964cf58) at kernel/qapplication.cpp:3704
#55 0x002eff2a in KApplication::notify (this=0xbfe617b8, receiver=0xbfe617a4, event=0x964cf58) at ../../kdeui/kernel/kapplication.cpp:302
#56 0x00b7fa3b in QCoreApplication::notifyInternal (this=0xbfe617b8, receiver=0xbfe617a4, event=0x964cf58) at kernel/qcoreapplication.cpp:704
#57 0x00b82473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x94a4420) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x94a4420) at kernel/qcoreapplication.cpp:1345
#59 0x00b825dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#60 0x00babadf in QCoreApplication::sendPostedEvents (s=0x94c4318) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#61 postEventSourceDispatch (s=0x94c4318) at kernel/qeventdispatcher_glib.cpp:276
#62 0x091615e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#63 0x091652d8 in ?? () from /lib/libglib-2.0.so.0
#64 0x091654b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#65 0x00bab5d5 in QEventDispatcherGlib::processEvents (this=0x94a4118, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#66 0x011c9135 in QGuiEventDispatcherGlib::processEvents (this=0x94a4118, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#67 0x00b7e059 in QEventLoop::processEvents (this=0xbfe61704, flags=) at kernel/qeventloop.cpp:149
#68 0x00b7e4aa in QEventLoop::exec (this=0xbfe61704, flags=...) at kernel/qeventloop.cpp:201
#69 0x00b8269f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#70 0x01109577 in QApplication::exec () at kernel/qapplication.cpp:3579
#71 0x0804e52f in main (argc=1, argv=0xbfe61934) at ../../knotify/main.cpp:73

This bug may be a duplicate of or related to bug 232068.

Possible duplicates by query: bug 245249, bug 244298, bug 244191, bug 241334, bug 240428.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-08-02 15:43:28 UTC

*** This bug has been marked as a duplicate of bug 232068 ***
Comment 2 afg 2013-09-20 16:28:17 UTC
Created attachment 82426 [details]
New crash information added by DrKonqi

amarok (2.5.0) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:

It crashes everytime I try to open Amarok, with or without applications opened. 

However, it is since I have switched to  Ubuntu 13.04 that Amarok doesn't work anymore.

-- Backtrace (Reduced):
#6  Phonon::Gstreamer::MediaNode::linkMediaNodeList (this=0x1153580, list=..., bin=0xc872e0, tee=0x0, fakesink=0x0, src=0x0) at ../../gstreamer/medianode.cpp:352
#7  0x00007f0dd1b565b9 in Phonon::Gstreamer::MediaNode::link (this=0x1153580) at ../../gstreamer/medianode.cpp:382
#8  0x00007f0dd1b559e5 in Phonon::Gstreamer::MediaNode::buildGraph (this=0x1153580) at ../../gstreamer/medianode.cpp:103
#9  0x00007f0dd1b56a63 in Phonon::Gstreamer::MediaNode::connectNode (this=0x1153580, obj=0x115eba0) at ../../gstreamer/medianode.cpp:191
#10 0x00007f0dd1b496cb in Phonon::Gstreamer::Backend::connectNodes (this=0xde4260, source=0x1153560, sink=0x115eba0) at ../../gstreamer/backend.cpp:418