Bug 260996 - Kate crashed using backspace
Summary: Kate crashed using backspace
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-22 20:11 UTC by lyngeled
Modified: 2010-12-22 20:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lyngeled 2010-12-22 20:11:49 UTC
Application: kate (3.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-27-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I selected several lines at end a file, then deleted with backspace, and pressed backspace onca more. Then Kate chrashed.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b3aa0 (LWP 10327))]

Thread 2 (Thread 0xb4ce6b70 (LWP 10328)):
#0  0x087e1a33 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x087e1ee9 in ?? () from /lib/libglib-2.0.so.0
#2  0x087e24b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x005a760f in QEventDispatcherGlib::processEvents (this=0x99a7768, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0x0057a059 in QEventLoop::processEvents (this=0xb4ce6290, flags=) at kernel/qeventloop.cpp:149
#5  0x0057a4aa in QEventLoop::exec (this=0xb4ce6290, flags=...) at kernel/qeventloop.cpp:201
#6  0x004765a8 in QThread::exec (this=0x9beb1b8) at thread/qthread.cpp:487
#7  0x00559c1b in QInotifyFileSystemWatcherEngine::run (this=0x9beb1b8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0047932e in QThreadPrivate::start (arg=0x9beb1b8) at thread/qthread_unix.cpp:248
#9  0x0011596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x04751a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77b3aa0 (LWP 10327)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#7  0x016c594c in KateLayoutCache::viewLine (this=0x9a61a48, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#8  0x016c5f7f in KateLayoutCache::textLayout (this=0x9a61a48, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#9  0x01736e91 in KateViewInternal::makeVisible (this=0x9a606d0, c=..., endCol=-1, force=false, center=false, calledExternally=false) at ../../kate/view/kateviewinternal.cpp:690
#10 0x017375f0 in KateViewInternal::updateCursor (this=0x9a606d0, newCursor=..., force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#11 0x017383eb in KateViewInternal::editEnd (this=0x9a606d0, editTagLineStart=37, editTagLineEnd=37, tagFrom=true) at ../../kate/view/kateviewinternal.cpp:3399
#12 0x01716c69 in KateView::editEnd (this=0x9a5cef8, editTagLineStart=37, editTagLineEnd=37, tagFrom=<value optimized out>) at ../../kate/view/kateview.cpp:1602
#13 0x0167eb04 in KateDocument::editEnd (this=0x9833128) at ../../kate/document/katedocument.cpp:977
#14 0x01685dac in KateDocument::removeText (this=0x9833128, _range=..., block=false) at ../../kate/document/katedocument.cpp:821
#15 0x01687b7d in KateDocument::backspace (this=0x9833128, view=0x9a5cef8, c=...) at ../../kate/document/katedocument.cpp:2906
#16 0x0172c0e1 in KateViewInternal::doBackspace (this=0x9a606d0) at ../../kate/view/kateviewinternal.cpp:854
#17 0x0171966c in KateView::backspace (this=0x9a5cef8) at ../../kate/view/kateview.cpp:2295
#18 0x0171edd4 in KateView::qt_metacall (this=0x9a5cef8, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbf8349a8) at ./kateview.moc:373
#19 0x00580c9a in QMetaObject::metacall (object=0x9a5cef8, cl=QMetaObject::ReadProperty, idx=90, argv=0xbf8349a8) at kernel/qmetaobject.cpp:237
#20 0x0058f3d5 in QMetaObject::activate (sender=0x9add6e8, m=0x2550d58, local_signal_index=1, argv=0xbf8349a8) at kernel/qobject.cpp:3293
#21 0x01c21bd9 in QAction::triggered (this=0x9add6e8, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x01c23dcc in QAction::activate (this=0x9add6e8, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x01c25698 in QAction::event (this=0x97afd18, e=0x0) at kernel/qaction.cpp:1181
#24 0x00e7bd63 in KAction::event (this=0x9add6e8, event=0xbf834ec8) at ../../kdeui/actions/kaction.cpp:129
#25 0x01c284dc in QApplicationPrivate::notify_helper (this=0x95f7030, receiver=0x9add6e8, e=0xbf834ec8) at kernel/qapplication.cpp:4300
#26 0x01c2f05e in QApplication::notify (this=0xbf835df4, receiver=0x9add6e8, e=0xbf834ec8) at kernel/qapplication.cpp:3704
#27 0x00f67f2a in KApplication::notify (this=0xbf835df4, receiver=0x9add6e8, event=0xbf834ec8) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x0057ba3b in QCoreApplication::notifyInternal (this=0xbf835df4, receiver=0x9add6e8, event=0xbf834ec8) at kernel/qcoreapplication.cpp:704
#29 0x01c6a34d in QCoreApplication::sendEvent (this=0x95f70dc, e=0xbf835344) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x95f70dc, e=0xbf835344) at kernel/qshortcutmap.cpp:879
#31 0x01c6c15e in QShortcutMap::tryShortcutEvent (this=0x95f70dc, o=0x9a606d0, e=0xbf835344) at kernel/qshortcutmap.cpp:364
#32 0x01c30e43 in QApplication::notify (this=0xbf835df4, receiver=0x9a606d0, e=0xbf835344) at kernel/qapplication.cpp:3746
#33 0x00f67f2a in KApplication::notify (this=0xbf835df4, receiver=0x9a606d0, event=0xbf835344) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x0057ba3b in QCoreApplication::notifyInternal (this=0xbf835df4, receiver=0x9a606d0, event=0xbf835344) at kernel/qcoreapplication.cpp:704
#35 0x01c292be in QCoreApplication::sendSpontaneousEvent (receiver=0x9a606d0, event=0x97afd18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0x9a606d0, event=0x97afd18) at kernel/qapplication.cpp:5279
#37 0x01ce2d90 in QKeyMapper::sendKeyEvent (keyWidget=0x9a606d0, grab=false, type=QEvent::KeyPress, code=16777219, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#38 0x01ce52f5 in QKeyMapperPrivate::translateKeyEvent (this=0x96132e8, keyWidget=0x9a606d0, event=0xbf835a0c, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x01cb8757 in QApplication::x11ProcessEvent (this=0xbf835df4, event=0xbf835a0c) at kernel/qapplication_x11.cpp:3394
#40 0x01ce860a in x11EventSourceDispatch (s=0x95f8308, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x087de5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x087e22d8 in ?? () from /lib/libglib-2.0.so.0
#43 0x087e24b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x005a75d5 in QEventDispatcherGlib::processEvents (this=0x95f6790, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#45 0x01ce8135 in QGuiEventDispatcherGlib::processEvents (this=0x95f6790, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x0057a059 in QEventLoop::processEvents (this=0xbf835d04, flags=) at kernel/qeventloop.cpp:149
#47 0x0057a4aa in QEventLoop::exec (this=0xbf835d04, flags=...) at kernel/qeventloop.cpp:201
#48 0x0057e69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#49 0x01c28577 in QApplication::exec () at kernel/qapplication.cpp:3579
#50 0x03c6da65 in kdemain () from /usr/lib/libkdeinit4_kate.so
#51 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x95e43d5 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#52 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#53 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#54 0x0804fe4f in main (argc=2, argv=0xbf836d44, envp=0xbf836d50) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 226409.

Possible duplicates by query: bug 257510, bug 256452, bug 255585, bug 254587, bug 254525.

Reported using DrKonqi
Comment 1 Milian Wolff 2010-12-22 20:24:58 UTC
should be fixed in newer version of kde already

*** This bug has been marked as a duplicate of bug 226409 ***