Bug 254525 - Kate crashes when saving
Summary: Kate crashes when saving
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-18 07:28 UTC by goodladybird
Modified: 2010-11-21 15:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description goodladybird 2010-10-18 07:28:33 UTC
Version:           unspecified (using KDE 4.4.2) 
OS:                Linux

Open some documents, and in last opened I was remove some text, save and close document. After this Kate is crashed.

Reproducible: Sometimes

Steps to Reproduce:
Open some bigs php files. In the last opened, select big text block and press backspace.

Actual Results:  
Kate crashes. After this I pressed "Restart application" button. Kate restarted and when I've reproduced the steps Kate crashed again.


Application: Kate (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb786aaa0 (LWP 13368))]

Thread 2 (Thread 0xb4e84b70 (LWP 13370)):
#0  0x0251ae16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x010dd6fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x010e2825 in QTimerInfoList::updateCurrentTime (this=0x93e0a34) at kernel/qeventdispatcher_unix.cpp:340
#3  0x010e286a in QTimerInfoList::timerWait (this=0x93e0a34, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x010e0818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb4e840cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0x010e08a5 in timerSourcePrepare (source=0x0, timeout=0x251eff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x062fdaca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x062fdee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x062fe4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x010e060f in QEventDispatcherGlib::processEvents (this=0x91a27e0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x010b3059 in QEventLoop::processEvents (this=0xb4e84290, flags=) at kernel/qeventloop.cpp:149
#11 0x010b34aa in QEventLoop::exec (this=0xb4e84290, flags=...) at kernel/qeventloop.cpp:201
#12 0x00faf5a8 in QThread::exec (this=0x9088b78) at thread/qthread.cpp:487
#13 0x01092c1b in QInotifyFileSystemWatcherEngine::run (this=0x9088b78) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x00fb232e in QThreadPrivate::start (arg=0x9088b78) at thread/qthread_unix.cpp:248
#15 0x0082196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x034b9a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb786aaa0 (LWP 13368)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#7  0x013ae94c in KateLayoutCache::viewLine (this=0x97f0978, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#8  0x013aef7f in KateLayoutCache::textLayout (this=0x97f0978, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#9  0x0141fe91 in KateViewInternal::makeVisible (this=0x97d88b8, c=..., endCol=-1, force=false, center=false, calledExternally=false) at ../../kate/view/kateviewinternal.cpp:690
#10 0x014205f0 in KateViewInternal::updateCursor (this=0x97d88b8, newCursor=..., force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#11 0x014213eb in KateViewInternal::editEnd (this=0x97d88b8, editTagLineStart=556, editTagLineEnd=556, tagFrom=true) at ../../kate/view/kateviewinternal.cpp:3399
#12 0x013ffc69 in KateView::editEnd (this=0x97a68c0, editTagLineStart=556, editTagLineEnd=556, tagFrom=<value optimized out>) at ../../kate/view/kateview.cpp:1602
#13 0x01367b04 in KateDocument::editEnd (this=0x9756a20) at ../../kate/document/katedocument.cpp:977
#14 0x0136edac in KateDocument::removeText (this=0x9756a20, _range=..., block=false) at ../../kate/document/katedocument.cpp:821
#15 0x01370b7d in KateDocument::backspace (this=0x9756a20, view=0x97a68c0, c=...) at ../../kate/document/katedocument.cpp:2906
#16 0x014150e1 in KateViewInternal::doBackspace (this=0x97d88b8) at ../../kate/view/kateviewinternal.cpp:854
#17 0x0140266c in KateView::backspace (this=0x97a68c0) at ../../kate/view/kateview.cpp:2295
#18 0x01407dd4 in KateView::qt_metacall (this=0x97a68c0, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbff6acb8) at ./kateview.moc:373
#19 0x010b9c9a in QMetaObject::metacall (object=0x97a68c0, cl=QMetaObject::ReadProperty, idx=90, argv=0xbff6acb8) at kernel/qmetaobject.cpp:237
#20 0x010c83d5 in QMetaObject::activate (sender=0x985b438, m=0x7b46d58, local_signal_index=1, argv=0xbff6acb8) at kernel/qobject.cpp:3293
#21 0x07217bd9 in QAction::triggered (this=0x985b438, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x07219dcc in QAction::activate (this=0x985b438, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x0721b698 in QAction::event (this=0x8dfe128, e=0x0) at kernel/qaction.cpp:1181
#24 0x00c84d63 in KAction::event (this=0x985b438, event=0xbff6b1d8) at ../../kdeui/actions/kaction.cpp:129
#25 0x0721e4dc in QApplicationPrivate::notify_helper (this=0x8d40d00, receiver=0x985b438, e=0xbff6b1d8) at kernel/qapplication.cpp:4300
#26 0x0722505e in QApplication::notify (this=0xbff6c104, receiver=0x985b438, e=0xbff6b1d8) at kernel/qapplication.cpp:3704
#27 0x00d70f2a in KApplication::notify (this=0xbff6c104, receiver=0x985b438, event=0xbff6b1d8) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x010b4a3b in QCoreApplication::notifyInternal (this=0xbff6c104, receiver=0x985b438, event=0xbff6b1d8) at kernel/qcoreapplication.cpp:704
#29 0x0726034d in QCoreApplication::sendEvent (this=0x8d40dac, e=0xbff6b654) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x8d40dac, e=0xbff6b654) at kernel/qshortcutmap.cpp:879
#31 0x0726215e in QShortcutMap::tryShortcutEvent (this=0x8d40dac, o=0x97d88b8, e=0xbff6b654) at kernel/qshortcutmap.cpp:364
#32 0x07226e43 in QApplication::notify (this=0xbff6c104, receiver=0x97d88b8, e=0xbff6b654) at kernel/qapplication.cpp:3746
#33 0x00d70f2a in KApplication::notify (this=0xbff6c104, receiver=0x97d88b8, event=0xbff6b654) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x010b4a3b in QCoreApplication::notifyInternal (this=0xbff6c104, receiver=0x97d88b8, event=0xbff6b654) at kernel/qcoreapplication.cpp:704
#35 0x0721f2be in QCoreApplication::sendSpontaneousEvent (receiver=0x97d88b8, event=0x8dfe128) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0x97d88b8, event=0x8dfe128) at kernel/qapplication.cpp:5279
#37 0x072d8d90 in QKeyMapper::sendKeyEvent (keyWidget=0x97d88b8, grab=false, type=QEvent::KeyPress, code=16777219, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#38 0x072db2f5 in QKeyMapperPrivate::translateKeyEvent (this=0x8d80750, keyWidget=0x97d88b8, event=0xbff6bd1c, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x072ae757 in QApplication::x11ProcessEvent (this=0xbff6c104, event=0xbff6bd1c) at kernel/qapplication_x11.cpp:3394
#40 0x072de60a in x11EventSourceDispatch (s=0x8d43190, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x062fa5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x062fe2d8 in ?? () from /lib/libglib-2.0.so.0
#43 0x062fe4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x010e05d5 in QEventDispatcherGlib::processEvents (this=0x8d40760, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#45 0x072de135 in QGuiEventDispatcherGlib::processEvents (this=0x8d40760, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x010b3059 in QEventLoop::processEvents (this=0xbff6c014, flags=) at kernel/qeventloop.cpp:149
#47 0x010b34aa in QEventLoop::exec (this=0xbff6c014, flags=...) at kernel/qeventloop.cpp:201
#48 0x010b769f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#49 0x0721e577 in QApplication::exec () at kernel/qapplication.cpp:3579
#50 0x02243a65 in kdemain () from /usr/lib/libkdeinit4_kate.so
#51 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x8d2f055 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#52 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#53 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#54 0x0804fe4f in main (argc=2, argv=0xbff6d054, envp=0xbff6d060) at ../../kinit/kinit.cpp:1845
Comment 1 goodladybird 2010-10-18 07:30:34 UTC
Kate version 3.4.2
Comment 2 Dario Andres 2010-11-21 15:16:23 UTC
[Comment from a bug triager]
This bug is already fixed since KDE SC 4.4.4 and KDE SC 4.5.0. 
The reports were being tracked at bug 226409. Merging. Thanks

*** This bug has been marked as a duplicate of bug 226409 ***