Bug 255585 - segmentaion fault backspace encoding read only
Summary: segmentaion fault backspace encoding read only
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-29 15:03 UTC by Anton
Modified: 2010-11-21 15:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton 2010-10-29 15:03:20 UTC
Application: kile (2.0.85)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
After i changed the encoding and dsiabled the read only flag i deleated some text at the very end of the document. At a certain point (i might have pressed enter to create some empty lines at the end) kile crashed.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe1047e7760 (LWP 5811))]

Thread 2 (Thread 0x7fe0f1b3e710 (LWP 5812)):
#0  0x00007fe0ff520f93 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe0fc5b24a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fe0fc5b28fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fe1005a5566 in QEventDispatcherGlib::processEvents (this=0x1fd4350, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fe10057a992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fe10057ad6c in QEventLoop::exec (this=0x7fe0f1b3ddb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fe100484d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fe10055b178 in QInotifyFileSystemWatcherEngine::run (this=0x1fd34d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe100487775 in QThreadPrivate::start (arg=0x1fd34d0) at thread/qthread_unix.cpp:248
#9  0x00007fe1001f79ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fe0ff52d70d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe1047e7760 (LWP 5811)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007fe0f75f4e2a in KateLayoutCache::viewLine (this=0x2d81410, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007fe0f75f5421 in KateLayoutCache::textLayout (this=0x2d81410, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#8  0x00007fe0f765a94f in KateViewInternal::makeVisible (this=0x27a29f0, c=<value optimized out>, endCol=<value optimized out>, force=false, center=<value optimized out>, 
    calledExternally=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:690
#9  0x00007fe0f765b009 in KateViewInternal::updateCursor (this=0x27a29f0, newCursor=<value optimized out>, force=<value optimized out>, center=false, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x00007fe0f765bc39 in KateViewInternal::editEnd (this=0x27a29f0, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3399
#11 0x00007fe0f75b3d11 in KateDocument::editEnd (this=0x29303c0) at ../../kate/document/katedocument.cpp:977
#12 0x00007fe0f75baaa6 in KateDocument::removeText (this=0x29303c0, _range=<value optimized out>, block=<value optimized out>) at ../../kate/document/katedocument.cpp:821
#13 0x00007fe0f75bc61a in KateDocument::backspace (this=0x29303c0, view=<value optimized out>, c=<value optimized out>) at ../../kate/document/katedocument.cpp:2906
#14 0x00007fe0f7641a5c in KateView::backspace (this=0x3b9d0e0) at ../../kate/view/kateview.cpp:2295
#15 0x00007fe0f7646bbd in KateView::qt_metacall (this=0x3b9d0e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1cd8f880) at ./kateview.moc:373
#16 0x00007fe10058ee3f in QMetaObject::activate (sender=0x2b84590, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#17 0x00007fe100eea032 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00007fe100eec0ab in QAction::activate (this=0x2b84590, event=<value optimized out>) at kernel/qaction.cpp:1255
#19 0x00007fe100eed9b7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#20 0x00007fe101d80f3d in KAction::event (this=0x0, event=0x7fff1cd8fef0) at ../../kdeui/actions/kaction.cpp:129
#21 0x00007fe100ef022c in QApplicationPrivate::notify_helper (this=0x16127c0, receiver=0x2b84590, e=0x7fff1cd8fef0) at kernel/qapplication.cpp:4300
#22 0x00007fe100ef66fb in QApplication::notify (this=0x7fff1cd914a0, receiver=0x2b84590, e=0x7fff1cd8fef0) at kernel/qapplication.cpp:4183
#23 0x00007fe101e56526 in KApplication::notify (this=0x7fff1cd914a0, receiver=0x2b84590, event=0x7fff1cd8fef0) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007fe10057c06c in QCoreApplication::notifyInternal (this=0x7fff1cd914a0, receiver=0x2b84590, event=0x7fff1cd8fef0) at kernel/qcoreapplication.cpp:704
#25 0x00007fe100f2be86 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff1cd904f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff1cd904f0) at kernel/qshortcutmap.cpp:879
#27 0x00007fe100f2dc97 in QShortcutMap::tryShortcutEvent (this=0x16128e8, o=<value optimized out>, e=0x7fff1cd904f0) at kernel/qshortcutmap.cpp:364
#28 0x00007fe100ef8268 in QApplication::notify (this=0x7fff1cd914a0, receiver=0x27a29f0, e=0x7fff1cd904f0) at kernel/qapplication.cpp:3746
#29 0x00007fe101e56526 in KApplication::notify (this=0x7fff1cd914a0, receiver=0x27a29f0, event=0x7fff1cd904f0) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007fe10057c06c in QCoreApplication::notifyInternal (this=0x7fff1cd914a0, receiver=0x27a29f0, event=0x7fff1cd904f0) at kernel/qcoreapplication.cpp:704
#31 0x00007fe100f9b16a in QKeyMapper::sendKeyEvent (keyWidget=0x27a29f0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777219, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#32 0x00007fe100f9d6f0 in QKeyMapperPrivate::translateKeyEvent (this=0x165a390, keyWidget=0x27a29f0, event=<value optimized out>, grab=32) at kernel/qkeymapper_x11.cpp:1831
#33 0x00007fe100f74904 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff1cd910c0) at kernel/qapplication_x11.cpp:3394
#34 0x00007fe100fa0882 in x11EventSourceDispatch (s=0x1616050, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007fe0fc5ae8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007fe0fc5b2748 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007fe0fc5b28fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007fe1005a5513 in QEventDispatcherGlib::processEvents (this=0x15ed570, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#39 0x00007fe100fa046e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fe10057a992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007fe10057ad6c in QEventLoop::exec (this=0x7fff1cd913f0, flags=) at kernel/qeventloop.cpp:201
#42 0x00007fe10057eaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00000000005f21f2 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-21 15:16:18 UTC
[Comment from a bug triager]
This bug is already fixed since KDE SC 4.4.4 and KDE SC 4.5.0. 
The reports were being tracked at bug 226409. Merging. Thanks

*** This bug has been marked as a duplicate of bug 226409 ***