Bug 254587 - Kate crashed when hitting ^X at end of file
Summary: Kate crashed when hitting ^X at end of file
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-18 21:38 UTC by Aaron Winborn
Modified: 2010-11-21 15:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Winborn 2010-10-18 21:38:20 UTC
Application: kate (3.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I was moving several lines to further up the file, accidentally hit ^X twice after having selected the lines to move, and the program crashed.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7758aa0 (LWP 9964))]

Thread 2 (Thread 0xb4e07b70 (LWP 9967)):
#0  0x00bb6422 in __kernel_vsyscall ()
#1  0x009e1b86 in *__GI___poll (fds=0xa77ff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x01b284eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x01b1b0ac in ?? () from /lib/libglib-2.0.so.0
#4  0x01b1b4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x085c860f in QEventDispatcherGlib::processEvents (this=0x97950b0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x0859b059 in QEventLoop::processEvents (this=0xb4e07290, flags=) at kernel/qeventloop.cpp:149
#7  0x0859b4aa in QEventLoop::exec (this=0xb4e07290, flags=...) at kernel/qeventloop.cpp:201
#8  0x084975a8 in QThread::exec (this=0x99d3138) at thread/qthread.cpp:487
#9  0x0857ac1b in QInotifyFileSystemWatcherEngine::run (this=0x99d3138) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0849a32e in QThreadPrivate::start (arg=0x99d3138) at thread/qthread_unix.cpp:248
#11 0x005f296e in start_thread (arg=0xb4e07b70) at pthread_create.c:300
#12 0x009efa4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7758aa0 (LWP 9964)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x012c694c in KateLayoutCache::viewLine (this=0x985ef10, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x012c6f7f in KateLayoutCache::textLayout (this=0x985ef10, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#8  0x01337e91 in KateViewInternal::makeVisible (this=0x985ecd8, c=..., endCol=-1, force=false, center=false, calledExternally=false) at ../../kate/view/kateviewinternal.cpp:690
#9  0x013385f0 in KateViewInternal::updateCursor (this=0x985ecd8, newCursor=..., force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#10 0x013393eb in KateViewInternal::editEnd (this=0x985ecd8, editTagLineStart=30, editTagLineEnd=30, tagFrom=true) at ../../kate/view/kateviewinternal.cpp:3399
#11 0x01317c69 in KateView::editEnd (this=0x9859190, editTagLineStart=30, editTagLineEnd=30, tagFrom=<value optimized out>) at ../../kate/view/kateview.cpp:1602
#12 0x0127fb04 in KateDocument::editEnd (this=0x962a598) at ../../kate/document/katedocument.cpp:977
#13 0x01286dac in KateDocument::removeText (this=0x962a598, _range=..., block=false) at ../../kate/document/katedocument.cpp:821
#14 0x01288b7d in KateDocument::backspace (this=0x962a598, view=0x9859190, c=...) at ../../kate/document/katedocument.cpp:2906
#15 0x0132d0e1 in KateViewInternal::doBackspace (this=0x985ecd8) at ../../kate/view/kateviewinternal.cpp:854
#16 0x0131a66c in KateView::backspace (this=0x9859190) at ../../kate/view/kateview.cpp:2295
#17 0x0131fdd4 in KateView::qt_metacall (this=0x9859190, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbfe87b48) at ./kateview.moc:373
#18 0x085a1c9a in QMetaObject::metacall (object=0x9859190, cl=QMetaObject::ReadProperty, idx=90, argv=0xbfe87b48) at kernel/qmetaobject.cpp:237
#19 0x085b03d5 in QMetaObject::activate (sender=0x98d38b8, m=0x712fd58, local_signal_index=1, argv=0xbfe87b48) at kernel/qobject.cpp:3293
#20 0x06800bd9 in QAction::triggered (this=0x98d38b8, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#21 0x06802dcc in QAction::activate (this=0x98d38b8, event=QAction::Trigger) at kernel/qaction.cpp:1255
#22 0x06804698 in QAction::event (this=0x956a4e8, e=0x0) at kernel/qaction.cpp:1181
#23 0x00ee4d63 in KAction::event (this=0x98d38b8, event=0xbfe88068) at ../../kdeui/actions/kaction.cpp:129
#24 0x068074dc in QApplicationPrivate::notify_helper (this=0x94cda28, receiver=0x98d38b8, e=0xbfe88068) at kernel/qapplication.cpp:4300
#25 0x0680e05e in QApplication::notify (this=0xbfe88f94, receiver=0x98d38b8, e=0xbfe88068) at kernel/qapplication.cpp:3704
#26 0x00fd0f2a in KApplication::notify (this=0xbfe88f94, receiver=0x98d38b8, event=0xbfe88068) at ../../kdeui/kernel/kapplication.cpp:302
#27 0x0859ca3b in QCoreApplication::notifyInternal (this=0xbfe88f94, receiver=0x98d38b8, event=0xbfe88068) at kernel/qcoreapplication.cpp:704
#28 0x0684934d in QCoreApplication::sendEvent (this=0x94cdad4, e=0xbfe884e4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QShortcutMap::dispatchEvent (this=0x94cdad4, e=0xbfe884e4) at kernel/qshortcutmap.cpp:879
#30 0x0684b15e in QShortcutMap::tryShortcutEvent (this=0x94cdad4, o=0x985ecd8, e=0xbfe884e4) at kernel/qshortcutmap.cpp:364
#31 0x0680fe43 in QApplication::notify (this=0xbfe88f94, receiver=0x985ecd8, e=0xbfe884e4) at kernel/qapplication.cpp:3746
#32 0x00fd0f2a in KApplication::notify (this=0xbfe88f94, receiver=0x985ecd8, event=0xbfe884e4) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x0859ca3b in QCoreApplication::notifyInternal (this=0xbfe88f94, receiver=0x985ecd8, event=0xbfe884e4) at kernel/qcoreapplication.cpp:704
#34 0x068082be in QCoreApplication::sendSpontaneousEvent (receiver=0x985ecd8, event=0x956a4e8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 qt_sendSpontaneousEvent (receiver=0x985ecd8, event=0x956a4e8) at kernel/qapplication.cpp:5279
#36 0x068c1d90 in QKeyMapper::sendKeyEvent (keyWidget=0x985ecd8, grab=false, type=QEvent::KeyPress, code=16777219, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#37 0x068c42f5 in QKeyMapperPrivate::translateKeyEvent (this=0x94f4ae0, keyWidget=0x985ecd8, event=0xbfe88bac, grab=false) at kernel/qkeymapper_x11.cpp:1831
#38 0x06897757 in QApplication::x11ProcessEvent (this=0xbfe88f94, event=0xbfe88bac) at kernel/qapplication_x11.cpp:3394
#39 0x068c760a in x11EventSourceDispatch (s=0x94cf6f0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#40 0x01b175e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#41 0x01b1b2d8 in ?? () from /lib/libglib-2.0.so.0
#42 0x01b1b4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#43 0x085c85d5 in QEventDispatcherGlib::processEvents (this=0x94cd910, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#44 0x068c7135 in QGuiEventDispatcherGlib::processEvents (this=0x94cd910, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x0859b059 in QEventLoop::processEvents (this=0xbfe88ea4, flags=) at kernel/qeventloop.cpp:149
#46 0x0859b4aa in QEventLoop::exec (this=0xbfe88ea4, flags=...) at kernel/qeventloop.cpp:201
#47 0x0859f69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#48 0x06807577 in QApplication::exec () at kernel/qapplication.cpp:3579
#49 0x02fd4a65 in kdemain (argc=2, argv=0x9494150) at ../../../kate/app/katemain.cpp:377
#50 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x9491411 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x9491422 "aaron-desktop;1287429428;267920;2653_TIME959210077") at ../../kinit/kinit.cpp:717
#51 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#52 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#53 0x0804fe4f in main (argc=2, argv=0xbfe89ee4, envp=0xbfe89ef0) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 226409.

Possible duplicates by query: bug 254525, bug 243604, bug 242511, bug 242205, bug 241992.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-21 15:16:20 UTC
[Comment from a bug triager]
This bug is already fixed since KDE SC 4.4.4 and KDE SC 4.5.0. 
The reports were being tracked at bug 226409. Merging. Thanks

*** This bug has been marked as a duplicate of bug 226409 ***