Bug 257510 - Kate crashed when deleting text with backspace
Summary: Kate crashed when deleting text with backspace
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-21 13:58 UTC by incompetent777
Modified: 2010-11-21 15:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description incompetent777 2010-11-21 13:58:09 UTC
Application: kate (3.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Kate crashed when deleting text with backspace. The text was at the end of the document and consisted of 4 spaces. (The editor had been configured to insert spaces instead of tabs and to use 4 space widths per tab.) The spaces did not delete upon pressing the backspace key and then kate crashed. I am using Ubuntu 10.04 Desktop 32 bit. Kate was installed from the apt-get repositories.

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77dc710 (LWP 2731))]

Thread 2 (Thread 0xb5540b70 (LWP 2785)):
#0  0x00208422 in __kernel_vsyscall ()
#1  0x0014a015 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x0037e9dd in __pthread_cond_wait (cond=0x3b9d28c, mutex=0x3b9d274) at forward.c:139
#3  0x03abec97 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3b981a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#4  0x03abece1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x3b981a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#5  0x0014596e in start_thread (arg=0xb5540b70) at pthread_create.c:300
#6  0x00371a4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77dc710 (LWP 2731)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#7  0x02dd694c in KateLayoutCache::viewLine (this=0xa6f1a18, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#8  0x02dd6f7f in KateLayoutCache::textLayout (this=0xa6f1a18, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#9  0x02e47e91 in KateViewInternal::makeVisible (this=0xab19b08, c=..., endCol=-1, force=false, center=false, calledExternally=false) at ../../kate/view/kateviewinternal.cpp:690
#10 0x02e485f0 in KateViewInternal::updateCursor (this=0xab19b08, newCursor=..., force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#11 0x02e493eb in KateViewInternal::editEnd (this=0xab19b08, editTagLineStart=32, editTagLineEnd=32, tagFrom=true) at ../../kate/view/kateviewinternal.cpp:3399
#12 0x02e27c69 in KateView::editEnd (this=0xab1ed80, editTagLineStart=32, editTagLineEnd=32, tagFrom=<value optimized out>) at ../../kate/view/kateview.cpp:1602
#13 0x02d8fb04 in KateDocument::editEnd (this=0xab55728) at ../../kate/document/katedocument.cpp:977
#14 0x02d96dac in KateDocument::removeText (this=0xab55728, _range=..., block=false) at ../../kate/document/katedocument.cpp:821
#15 0x02d98b7d in KateDocument::backspace (this=0xab55728, view=0xab1ed80, c=...) at ../../kate/document/katedocument.cpp:2906
#16 0x02e3d0e1 in KateViewInternal::doBackspace (this=0xab19b08) at ../../kate/view/kateviewinternal.cpp:854
#17 0x02e2a66c in KateView::backspace (this=0xab1ed80) at ../../kate/view/kateview.cpp:2295
#18 0x02e2fdd4 in KateView::qt_metacall (this=0xab1ed80, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbff310e8) at ./kateview.moc:373
#19 0x03f43c9a in QMetaObject::metacall (object=0xab1ed80, cl=QMetaObject::ReadProperty, idx=90, argv=0xbff310e8) at kernel/qmetaobject.cpp:237
#20 0x03f523d5 in QMetaObject::activate (sender=0xabb29e8, m=0x1118d58, local_signal_index=1, argv=0xbff310e8) at kernel/qobject.cpp:3293
#21 0x007e9bd9 in QAction::triggered (this=0xabb29e8, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x007ebdcc in QAction::activate (this=0xabb29e8, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x007ed698 in QAction::event (this=0x9a77a00, e=0x0) at kernel/qaction.cpp:1181
#24 0x08de3d63 in KAction::event (this=0xabb29e8, event=0xbff31608) at ../../kdeui/actions/kaction.cpp:129
#25 0x007f04dc in QApplicationPrivate::notify_helper (this=0x9926250, receiver=0xabb29e8, e=0xbff31608) at kernel/qapplication.cpp:4300
#26 0x007f705e in QApplication::notify (this=0xbff32534, receiver=0xabb29e8, e=0xbff31608) at kernel/qapplication.cpp:3704
#27 0x08ecff2a in KApplication::notify (this=0xbff32534, receiver=0xabb29e8, event=0xbff31608) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x03f3ea3b in QCoreApplication::notifyInternal (this=0xbff32534, receiver=0xabb29e8, event=0xbff31608) at kernel/qcoreapplication.cpp:704
#29 0x0083234d in QCoreApplication::sendEvent (this=0x99262fc, e=0xbff31a84) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x99262fc, e=0xbff31a84) at kernel/qshortcutmap.cpp:879
#31 0x0083415e in QShortcutMap::tryShortcutEvent (this=0x99262fc, o=0xab19b08, e=0xbff31a84) at kernel/qshortcutmap.cpp:364
#32 0x007f8e43 in QApplication::notify (this=0xbff32534, receiver=0xab19b08, e=0xbff31a84) at kernel/qapplication.cpp:3746
#33 0x08ecff2a in KApplication::notify (this=0xbff32534, receiver=0xab19b08, event=0xbff31a84) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x03f3ea3b in QCoreApplication::notifyInternal (this=0xbff32534, receiver=0xab19b08, event=0xbff31a84) at kernel/qcoreapplication.cpp:704
#35 0x007f12be in QCoreApplication::sendSpontaneousEvent (receiver=0xab19b08, event=0x9a77a00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0xab19b08, event=0x9a77a00) at kernel/qapplication.cpp:5279
#37 0x008aad90 in QKeyMapper::sendKeyEvent (keyWidget=0xab19b08, grab=false, type=QEvent::KeyPress, code=16777219, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#38 0x008ad2f5 in QKeyMapperPrivate::translateKeyEvent (this=0x994c280, keyWidget=0xab19b08, event=0xbff3214c, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x00880757 in QApplication::x11ProcessEvent (this=0xbff32534, event=0xbff3214c) at kernel/qapplication_x11.cpp:3394
#40 0x008b060a in x11EventSourceDispatch (s=0x9925280, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x06fbe5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x06fc22d8 in ?? () from /lib/libglib-2.0.so.0
#43 0x06fc24b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x03f6a5d5 in QEventDispatcherGlib::processEvents (this=0x99079c0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#45 0x008b0135 in QGuiEventDispatcherGlib::processEvents (this=0x99079c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x03f3d059 in QEventLoop::processEvents (this=0xbff32444, flags=) at kernel/qeventloop.cpp:149
#47 0x03f3d4aa in QEventLoop::exec (this=0xbff32444, flags=...) at kernel/qeventloop.cpp:201
#48 0x03f4169f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#49 0x007f0577 in QApplication::exec () at kernel/qapplication.cpp:3579
#50 0x00179a65 in kdemain (argc=2, argv=0xbff32bd4) at ../../../kate/app/katemain.cpp:377
#51 0x080485fb in main (argc=2, argv=0xbff32bd4) at kate_dummy.cpp:3

This bug may be a duplicate of or related to bug 256452.

Possible duplicates by query: bug 256452, bug 255585, bug 254587, bug 254525, bug 243604.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-21 15:16:12 UTC
[Comment from a bug triager]
This bug is already fixed since KDE SC 4.4.4 and KDE SC 4.5.0. 
The reports were being tracked at bug 226409. Merging. Thanks

*** This bug has been marked as a duplicate of bug 226409 ***