Bug 258038 - unknown crash - DLing to ext HD
Summary: unknown crash - DLing to ext HD
Status: RESOLVED DUPLICATE of bug 241598
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-27 03:11 UTC by brooke.bearden
Modified: 2010-11-28 10:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brooke.bearden 2010-11-27 03:11:29 UTC
Application: ktorrent (4.0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
kT running DLs normally - had just restarted after submitting additional (seemingly unrelated) bug report. kT is DLing directly to a hardwired external hard drive (this HD is a major hub on a multi-OS media network feeding to a WDTV device - not that this makes a big difference.)

The crash can be reproduced some of the time.

-- Backtrace:
Application: KTorrent (ktorrent), signal: Bus error
[Current thread is 1 (Thread 0xb77f1710 (LWP 14318))]

Thread 6 (Thread 0xb7599b70 (LWP 14319)):
#0  0x00b1a416 in __kernel_vsyscall ()
#1  0x05b27df6 in poll () from /lib/libc.so.6
#2  0x061e9a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x061dc43c in ?? () from /lib/libglib-2.0.so.0
#4  0x061dcba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x01ab86b4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0x0620348f in ?? () from /lib/libglib-2.0.so.0
#7  0x00af3cc9 in start_thread () from /lib/libpthread.so.0
#8  0x05b366be in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb460eb70 (LWP 14321)):
#0  0x00af7898 in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0x061dc870 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x0113259f in QEventDispatcherGlib::processEvents (this=0x83107d0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#3  0x01102609 in QEventLoop::processEvents (this=0xb460e290, flags=) at kernel/qeventloop.cpp:149
#4  0x01102a8a in QEventLoop::exec (this=0xb460e290, flags=...) at kernel/qeventloop.cpp:201
#5  0x00ffeb7e in QThread::exec (this=0x830fcf8) at thread/qthread.cpp:490
#6  0x0020c39e in utp::UTPServerThread::run (this=0x830fcf8) at ../../src/utp/utpserverthread.cpp:44
#7  0x01001df9 in QThreadPrivate::start (arg=0x830fcf8) at thread/qthread_unix.cpp:266
#8  0x00af3cc9 in start_thread () from /lib/libpthread.so.0
#9  0x05b366be in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb3e0db70 (LWP 14322)):
#0  0x00b1a416 in __kernel_vsyscall ()
#1  0x05b2f391 in select () from /lib/libc.so.6
#2  0x001ce8db in dht::RPCServerThread::run (this=0x8318340) at ../../src/dht/rpcserver.cpp:107
#3  0x01001df9 in QThreadPrivate::start (arg=0x8318340) at thread/qthread_unix.cpp:266
#4  0x00af3cc9 in start_thread () from /lib/libpthread.so.0
#5  0x05b366be in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb2691b70 (LWP 14356)):
#0  net::Socket::prepare (this=0xb1311f20, p=0x814a980, mode=net::Poll::INPUT) at ../../src/net/socket.cpp:456
#1  0x001614a0 in net::DownloadThread::waitForSocketReady (this=0x814a978) at ../../src/net/downloadthread.cpp:123
#2  0x001615af in net::DownloadThread::update (this=0x814a978) at ../../src/net/downloadthread.cpp:48
#3  0x00162178 in net::NetworkThread::run (this=0x814a978) at ../../src/net/networkthread.cpp:48
#4  0x01001df9 in QThreadPrivate::start (arg=0x814a978) at thread/qthread_unix.cpp:266
#5  0x00af3cc9 in start_thread () from /lib/libpthread.so.0
#6  0x05b366be in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb4e0fb70 (LWP 14357)):
#0  0x00b1a416 in __kernel_vsyscall ()
#1  0x00af84dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x01000ef2 in QMutexPrivate::wait (this=0x814a910, timeout=-1) at thread/qmutex_unix.cpp:84
#3  0x00ffc5ca in QMutex::lock (this=0x8116894) at thread/qmutex.cpp:167
#4  0x0015f890 in net::SocketMonitor::lock (this=0x8116890) at ../../src/net/socketmonitor.cpp:82
#5  0x00160b15 in net::UploadThread::update (this=0x814ad80) at ../../src/net/uploadthread.cpp:49
#6  0x00162178 in net::NetworkThread::run (this=0x814ad80) at ../../src/net/networkthread.cpp:48
#7  0x01001df9 in QThreadPrivate::start (arg=0x814ad80) at thread/qthread_unix.cpp:266
#8  0x00af3cc9 in start_thread () from /lib/libpthread.so.0
#9  0x05b366be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77f1710 (LWP 14318)):
[KCrash Handler]
#7  0x05adbfd1 in ?? () from /lib/libc.so.6
#8  0x001d57a6 in bt::Chunk::readPiece (this=0x82f3448, off=3981312, len=16384, data=0xa989817d "\317\203\300AN\f$\tE\343\357U'\307\302_\200\374\313\017\200`\a\003\t\020\277\375.\230\fD]^_\341\366\327\217\352\202`\360\020%\203\300@j\\?\036\335S\216\037\004\060\r\241\b\300\061x\224>\bBB\255Q\003 @\006\022\304\221\367\324\272*\353\301C'\275\222\236\b@\213\202\203pH;\323\205\002\275'\f\205~\033I\322\320\\=\220\373\351\240\272\033\323x/\257zJ\234\"\025\341\320p\311P\004]8\036\bN\303n\v\306\324\351\063\242\303:\340\344G\034\367\207\006\367\207\300<\002\324\210\324\030\221\361@\033\240\304\201\360@\256\336\321\256\264\372a\301\360\022\016^^\\\243\303\257\020\252\005\n\277{\336\005\002n\203"...) at //usr/include/bits/string3.h:52
#9  0x00184bea in bt::Packet::Packet (this=0xa9741918, index=7212, begin=3981312, len=16384, ch=0x82f3448) at ../../src/download/packet.cpp:85
#10 0x0017ea5f in bt::PacketWriter::sendChunk (this=0xb119c350, index=7212, begin=3981312, len=16384, ch=0x82f3448) at ../../src/peer/packetwriter.cpp:195
#11 0x0017d2fc in bt::PeerUploader::update (this=0xa9a758b0, cman=..., opt_unchoked=191) at ../../src/peer/peeruploader.cpp:83
#12 0x001a60d8 in bt::Uploader::update (this=0x836cca0, opt_unchoked=191) at ../../src/torrent/uploader.cpp:48
#13 0x001aed71 in bt::TorrentControl::update (this=0xb6c8ea10) at ../../src/torrent/torrentcontrol.cpp:173
#14 0x080690f3 in kt::Core::update (this=0xb6c04b40) at ../../ktorrent/core.cpp:1030
#15 0x080716cd in kt::Core::qt_metacall (this=0xb6c04b40, _c=QMetaObject::InvokeMetaMethod, _id=3981312, _a=0xbfaa2e0c) at ./core.moc:167
#16 0x011098ca in QMetaObject::metacall (object=0xb6c04b40, cl=461, idx=22, argv=0xbfaa2e0c) at kernel/qmetaobject.cpp:237
#17 0x0111c6ad in QMetaObject::activate (sender=0xb6c04b54, m=0x12365a4, local_signal_index=0, argv=0x3cc000) at kernel/qobject.cpp:3280
#18 0x0116e1e7 in QTimer::timeout (this=0xb6c04b54) at .moc/release-shared/moc_qtimer.cpp:134
#19 0x011221ce in QTimer::timerEvent (this=0xb6c04b54, e=0xbfaa3310) at kernel/qtimer.cpp:271
#20 0x01116504 in QObject::event (this=0xb6c04b54, e=0xbfaa2abc) at kernel/qobject.cpp:1183
#21 0x01f9bfdc in QApplicationPrivate::notify_helper (this=0x816e348, receiver=0xb6c04b54, e=0xbfaa3310) at kernel/qapplication.cpp:4396
#22 0x01fa204e in QApplication::notify (this=0xbfaa3660, receiver=0xb6c04b54, e=0xbfaa3310) at kernel/qapplication.cpp:3798
#23 0x080783dc in kt::App::notify (this=0x1cd, receiver=0xbfaa2abc, event=0x3cc000) at ../../ktorrent/app.cpp:97
#24 0x01103b3b in QCoreApplication::notifyInternal (this=0xbfaa3660, receiver=0xb6c04b54, event=0xbfaa3310) at kernel/qcoreapplication.cpp:732
#25 0x01135ad6 in sendEvent (this=0x81741bc) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x81741bc) at kernel/qeventdispatcher_unix.cpp:602
#27 0x01132874 in timerSourceDispatch (source=0x8174188) at kernel/qeventdispatcher_glib.cpp:184
#28 0x061d8855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#29 0x061dc668 in ?? () from /lib/libglib-2.0.so.0
#30 0x061dc848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#31 0x01132565 in QEventDispatcherGlib::processEvents (this=0x81496d8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#32 0x0205dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x81496d8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x01102609 in QEventLoop::processEvents (this=0xbfaa35d4, flags=) at kernel/qeventloop.cpp:149
#34 0x01102a8a in QEventLoop::exec (this=0xbfaa35d4, flags=...) at kernel/qeventloop.cpp:201
#35 0x0110700f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#36 0x01f9ae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#37 0x08066e91 in main (argc=5, argv=0xbfaa3a64) at ../../ktorrent/main.cpp:176

Possible duplicates by query: bug 258034, bug 255577, bug 247984.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-11-28 10:02:27 UTC

*** This bug has been marked as a duplicate of bug 241598 ***