Bug 256244 - Network-Manager lose wifi connection and can't reconnect
Summary: Network-Manager lose wifi connection and can't reconnect
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-06 18:08 UTC by r1v10
Modified: 2010-11-08 23:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description r1v10 2010-11-06 18:08:57 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- Unusual behavior I noticed:
Wifi disconnection and wifi authorized key window open
Never reconnect

- What I was doing when the application crashed:
In a terminal:
sudo -s
service Network-Manager restart
(crash + restart + wifi reconnection ok)

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78e1710 (LWP 1380))]

Thread 2 (Thread 0xb445eb70 (LWP 1383)):
#0  0x0031da91 in postEventSourcePrepare (s=0xb3b00d58, timeout=0xb445e0cc) at kernel/qeventdispatcher_glib.cpp:253
#1  0x06c47e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x06c48279 in ?? () from /lib/libglib-2.0.so.0
#3  0x06c48848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x0031d59f in QEventDispatcherGlib::processEvents (this=0x82466c0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x002ed609 in QEventLoop::processEvents (this=0xb445e2a0, flags=) at kernel/qeventloop.cpp:149
#6  0x002eda8a in QEventLoop::exec (this=0xb445e2a0, flags=...) at kernel/qeventloop.cpp:201
#7  0x001e9b7e in QThread::exec (this=0x8245710) at thread/qthread.cpp:490
#8  0x02113e76 in ?? () from /usr/lib/kde4/kded_bluedevil.so
#9  0x001ecdf9 in QThreadPrivate::start (arg=0x8245710) at thread/qthread_unix.cpp:266
#10 0x00923cc9 in start_thread () from /lib/libpthread.so.0
#11 0x06aa36ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb78e1710 (LWP 1380)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0x002f48f9 in QMetaObject::cast (this=0x2166490, obj=0x82b8478) at kernel/qmetaobject.cpp:266
#9  0x03f9444e in qobject_cast<Knm::InterfaceConnection const*> (first=0x82b8478, second=0x8292078) at /usr/include/qt4/QtCore/qobject.h:468
#10 activatableLessThan (first=0x82b8478, second=0x8292078) at ../../../libs/service/sortedactivatablelist.cpp:183
#11 0x03f946d3 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=) at /usr/include/qt4/QtCore/qalgorithms.h:356
#12 0x03f94982 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8293220, activatable=0x82742c8) at /usr/include/qt4/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x8293220, activatable=0x82742c8) at ../../../libs/service/sortedactivatablelist.cpp:96
#14 0x03f82ac3 in ActivatableList::notifyOnAddActivatable (this=0x82660c0, activatable=0x82742c8) at ../../../libs/service/activatablelist.cpp:99
#15 0x03f83318 in ActivatableList::addActivatable (this=0x82660c0, activatable=0x82742c8) at ../../../libs/service/activatablelist.cpp:83
#16 0x03f875c6 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x8390748, addedConnection=0x829dce8) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#17 0x03f84b40 in NetworkInterfaceActivatableProvider::init (this=0x8390748) at ../../../libs/service/networkinterfaceactivatableprovider.cpp:64
#18 0x03f839b3 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x825c260, uni=...) at ../../../libs/service/networkinterfacemonitor.cpp:87
#19 0x03f7d0eb in NetworkInterfaceMonitor::qt_metacall (this=0x825c260, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf85a6a8) at moc_networkinterfacemonitor.cpp:75
#20 0x002f48ca in QMetaObject::metacall (object=0x825c260, cl=137723137, idx=4, argv=0xbf85a6a8) at kernel/qmetaobject.cpp:237
#21 0x003076ad in QMetaObject::activate (sender=0x82673b0, m=0x527f540, local_signal_index=1, argv=0x8276d90) at kernel/qobject.cpp:3280
#22 0x0525ff03 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x82673b0, _t1=...) at ./networkmanager.moc:107
#23 0x05260986 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x82673b0, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#24 0x05260a07 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x82673b0, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbf85a818) at ./networkmanager_p.moc:81
#25 0x002f48ca in QMetaObject::metacall (object=0x82673b0, cl=137723137, idx=10, argv=0xbf85a818) at kernel/qmetaobject.cpp:237
#26 0x003076ad in QMetaObject::activate (sender=0x825dac0, m=0x20e8950, local_signal_index=1, argv=0x8276d90) at kernel/qobject.cpp:3280
#27 0x020e46c3 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x825dac0, _t1=...) at ./networkmanager.moc:115
#28 0x0229598a in NMNetworkManager::deviceAdded (this=0x825dac0, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#29 0x02299bd5 in NMNetworkManager::qt_metacall (this=0x825dac0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbf85a9b8) at ./manager.moc:95
#30 0x002f48ca in QMetaObject::metacall (object=0x825dac0, cl=137723137, idx=15, argv=0xbf85a9b8) at kernel/qmetaobject.cpp:237
#31 0x003076ad in QMetaObject::activate (sender=0x826a478, m=0x22aea80, local_signal_index=0, argv=0x8276d90) at kernel/qobject.cpp:3280
#32 0x022a4673 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x826a478, _t1=...) at ./nm-manager-clientinterface.moc:155
#33 0x022a4bf5 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x826a478, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf85abfc) at ./nm-manager-clientinterface.moc:102
#34 0x0012f9dc in QDBusConnectionPrivate::deliverCall (this=0x823cba0, object=0x826a478, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#35 0x0013b1f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x827f448, object=0x826a478) at qdbusintegrator_p.h:103
#36 0x003016a2 in QObject::event (this=0x826a478, e=0x2166490) at kernel/qobject.cpp:1219
#37 0x010a3fdc in QApplicationPrivate::notify_helper (this=0x8167f20, receiver=0x826a478, e=0x827f448) at kernel/qapplication.cpp:4396
#38 0x010aa04e in QApplication::notify (this=0xbf85b4d0, receiver=0x826a478, e=0x827f448) at kernel/qapplication.cpp:3798
#39 0x005fe68a in KApplication::notify (this=0xbf85b4d0, receiver=0x826a478, event=0x827f448) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x002eeb3b in QCoreApplication::notifyInternal (this=0xbf85b4d0, receiver=0x826a478, event=0x827f448) at kernel/qcoreapplication.cpp:732
#41 0x002f1d8b in sendEvent (receiver=0x0, event_type=0, data=0x8114f20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8114f20) at kernel/qcoreapplication.cpp:1373
#43 0x002f1f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x0031da74 in sendPostedEvents (s=0x8189330) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x8189330) at kernel/qeventdispatcher_glib.cpp:277
#46 0x06c44855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x06c48668 in ?? () from /lib/libglib-2.0.so.0
#48 0x06c48848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x0031d565 in QEventDispatcherGlib::processEvents (this=0x81161d0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0x01165be5 in QGuiEventDispatcherGlib::processEvents (this=0x81161d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x002ed609 in QEventLoop::processEvents (this=0xbf85b424, flags=) at kernel/qeventloop.cpp:149
#52 0x002eda8a in QEventLoop::exec (this=0xbf85b424, flags=...) at kernel/qeventloop.cpp:201
#53 0x002f200f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x010a2e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0x01c8bcf7 in kdemain (argc=1, argv=0x81581a0) at ../../kded/kded.cpp:894
#56 0x0804e4d1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80517f7 "0") at ../../kinit/kinit.cpp:723
#57 0x0805048d in main (argc=4, argv=0xbf85bc54, envp=0xbf85bc68) at ../../kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:05:19 UTC

*** This bug has been marked as a duplicate of bug 210878 ***