Bug 256552 - KDE 4.5 Network manager plasmoid
Summary: KDE 4.5 Network manager plasmoid
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-10 21:15 UTC by Riccardo
Modified: 2011-03-31 23:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo 2010-11-10 21:15:34 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
After installing KDE 4.5 on my OpenSuse 11.3 kded crashes when restart network service (service network restart).
The network restart is necessary because the new network manager plasmoid didn't recognize network interfaces at boot.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Demone KDE (kdeinit4), signal: Aborted
[KCrash Handler]
#7  0xffffe424 in __kernel_vsyscall ()
#8  0xb60367ff in raise () from /lib/libc.so.6
#9  0xb6038140 in abort () from /lib/libc.so.6
#10 0xb6072fd7 in __libc_message () from /lib/libc.so.6
#11 0xb6078ffb in malloc_printerr () from /lib/libc.so.6
#12 0xb6079d7b in _int_free () from /lib/libc.so.6
#13 0xb607dadd in free () from /lib/libc.so.6
#14 0xb6d9f2eb in qFree (ptr=0x81cc4f8) at global/qmalloc.cpp:60
#15 0xb6df1fc2 in QString::free (d=0x81cc4f8) at tools/qstring.cpp:1151
#16 0xae9369d4 in ~QString (first=0x81cc4e8, second=0x8184b10) at /usr/include/QtCore/qstring.h:882
#17 compareDevices (first=0x81cc4e8, second=0x8184b10) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#18 0xae936cc2 in activatableLessThan (first=0x81cc4e8, second=0x8184b10) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
#19 0xae9377d0 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x81cb8e8, lessThan=0xae936c90 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#20 0xae937033 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8181820, activatable=0x8184b10)
    at /usr/include/QtCore/qalgorithms.h:187
#21 SortedActivatableList::handleAdd (this=0x8181820, activatable=0x8184b10) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#22 0xae925794 in ActivatableList::notifyOnAddActivatable (this=0x817aee8, activatable=0x8184b10) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:120
#23 0xae925813 in ActivatableList::addActivatable (this=0x817aee8, activatable=0x8184b10) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:104
#24 0xae929a26 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x81c8f38, addedConnection=0x8182c58)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#25 0xae9273a9 in NetworkInterfaceActivatableProvider::init (this=0x81c8f38) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#26 0xae9265ed in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x817d2c8, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#27 0xae920d95 in NetworkInterfaceMonitor::qt_metacall (this=0x817d2c8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd60ef8)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#28 0xb6ea996d in QMetaObject::metacall (object=0x817d2c8, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbfd60ef8) at kernel/qmetaobject.cpp:237
#29 0xb6eb9b1c in QMetaObject::activate (sender=0x817e230, m=0xb08c2560, local_signal_index=1, argv=0xbfd60ef8) at kernel/qobject.cpp:3272
#30 0xb08a2075 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x817e230, _t1=...) at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager.moc:107
#31 0xb08a26ac in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x817e230, uni=...) at /usr/src/debug/kdebase-workspace-4.5.3/libs/solid/control/networkmanager.cpp:197
#32 0xb08a272e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x817e230, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd61058)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/networkmanager_p.moc:81
#33 0xb6ea996d in QMetaObject::metacall (object=0x817e230, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbfd61058) at kernel/qmetaobject.cpp:237
#34 0xb6eb9b1c in QMetaObject::activate (sender=0x8176130, m=0xb088a950, local_signal_index=1, argv=0xbfd61058) at kernel/qobject.cpp:3272
#35 0xb0885a85 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x8176130, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/libs/solid/control/ifaces/networkmanager.moc:115
#36 0xae7faeba in NMNetworkManager::deviceAdded (this=0x8176130, objpath=...) at /usr/src/debug/kdebase-workspace-4.5.3/solid/networkmanager-0.7/manager.cpp:199
#37 0xae80558b in NMNetworkManager::qt_metacall (this=0x8176130, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd611d8)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/manager.moc:95
#38 0xb6ea996d in QMetaObject::metacall (object=0x8176130, cl=QMetaObject::InvokeMetaMethod, idx=15, argv=0xbfd611d8) at kernel/qmetaobject.cpp:237
#39 0xb6eb9b1c in QMetaObject::activate (sender=0x817dc30, m=0xae8106e4, local_signal_index=0, argv=0xbfd611d8) at kernel/qobject.cpp:3272
#40 0xae7f6ed5 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x817dc30, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#41 0xae7ff5cf in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x817dc30, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd6140c)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#42 0xb5e96e27 in QDBusConnectionPrivate::deliverCall (this=0x8166f78, object=0x817dc30, msg=..., metaTypes=..., slotIdx=0) at qdbusintegrator.cpp:919
#43 0xb5ea38d6 in QDBusCallDeliveryEvent::placeMetaCall (this=0x821a8e8, object=0x817dc30) at qdbusintegrator_p.h:103
#44 0xb6eb869f in QObject::event (this=0x817dc30, e=0x821a8e8) at kernel/qobject.cpp:1211
#45 0xb63a31a4 in QApplicationPrivate::notify_helper (this=0x80a36a0, receiver=0x817dc30, e=0x821a8e8) at kernel/qapplication.cpp:4396
#46 0xb63abdd7 in QApplication::notify (this=0xbfd61c70, receiver=0x817dc30, e=0x821a8e8) at kernel/qapplication.cpp:3798
#47 0xb74ea9d1 in KApplication::notify (this=0xbfd61c70, receiver=0x817dc30, event=0x821a8e8) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#48 0xb6ea312e in QCoreApplication::notifyInternal (this=0xbfd61c70, receiver=0x817dc30, event=0x821a8e8) at kernel/qcoreapplication.cpp:732
#49 0xb6ea6e6c in sendEvent (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.h:215
#50 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.cpp:1373
#51 0xb6ea6fbc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#52 0xb6ed16d4 in sendPostedEvents (s=0x80a51a8) at kernel/qcoreapplication.h:220
#53 postEventSourceDispatch (s=0x80a51a8) at kernel/qeventdispatcher_glib.cpp:277
#54 0xb5bdfb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0xb5be0350 in ?? () from /usr/lib/libglib-2.0.so.0
#56 0xb5be060e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0xb6ed185b in QEventDispatcherGlib::processEvents (this=0x805bce0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#58 0xb645819a in QGuiEventDispatcherGlib::processEvents (this=0x805bce0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#59 0xb6ea240d in QEventLoop::processEvents (this=0xbfd61bd4, flags=...) at kernel/qeventloop.cpp:149
#60 0xb6ea2639 in QEventLoop::exec (this=0xbfd61bd4, flags=...) at kernel/qeventloop.cpp:201
#61 0xb6ea7090 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#62 0xb63a0ed4 in QApplication::exec () at kernel/qapplication.cpp:3672
#63 0xb559f38d in kdemain (argc=1, argv=0x8094570) at /usr/src/debug/kdelibs-4.5.3/kded/kded.cpp:894
#64 0x0804e441 in launch (argc=1, _name=0x8052627 "kded4", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80524c3 "0") at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:723
#65 0x08050e48 in main (argc=) at /usr/src/debug/kdelibs-4.5.3/kinit/kinit.cpp:1835

Possible duplicates by query: bug 214793, bug 193800.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-04 15:55:21 UTC
[Comment from a bug triager]
This may be related to bug 210878. Regards
Comment 2 Lamarque V. Souza 2011-03-31 23:04:34 UTC

*** This bug has been marked as a duplicate of bug 210878 ***