Bug 243604 - Unknown crash
Summary: Unknown crash
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-04 21:21 UTC by wasserman.louis
Modified: 2010-07-04 23:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wasserman.louis 2010-07-04 21:21:41 UTC
Application: kate (3.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-23-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Idk, my BFF Jill?

No, seriously, I was just editing some Haskell source, and I think the crash might've come just as I was switching to looking at another file.

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d8710 (LWP 2654))]

Thread 3 (Thread 0xb1e35b70 (LWP 2889)):
#0  0x00fc4422 in __kernel_vsyscall ()
#1  0x0093d015 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x0083a9dd in __pthread_cond_wait (cond=0x9b91c58, mutex=0x9b91c40) at forward.c:139
#3  0x00a57287 in QWaitConditionPrivate::wait (this=0x9b91848, mutex=0x9b91844, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x9b91848, mutex=0x9b91844, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x01679d52 in QFileInfoGatherer::run (this=0x9b9183c) at dialogs/qfileinfogatherer.cpp:203
#6  0x00a5632e in QThreadPrivate::start (arg=0x9b9183c) at thread/qthread_unix.cpp:248
#7  0x0093896e in start_thread (arg=0xb1e35b70) at pthread_create.c:300
#8  0x0082da4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb01fbb70 (LWP 2890)):
#0  0x00fc4422 in __kernel_vsyscall ()
#1  0x0081fb86 in *__GI___poll (fds=0x8b5ff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x00eed4eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x00ee00ac in ?? () from /lib/libglib-2.0.so.0
#4  0x00ee04b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00b8460f in QEventDispatcherGlib::processEvents (this=0xb5800a20, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x00b57059 in QEventLoop::processEvents (this=0xb01fb290, flags=) at kernel/qeventloop.cpp:149
#7  0x00b574aa in QEventLoop::exec (this=0xb01fb290, flags=...) at kernel/qeventloop.cpp:201
#8  0x00a535a8 in QThread::exec (this=0x9b922c8) at thread/qthread.cpp:487
#9  0x00b36c1b in QInotifyFileSystemWatcherEngine::run (this=0x9b922c8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00a5632e in QThreadPrivate::start (arg=0x9b922c8) at thread/qthread_unix.cpp:248
#11 0x0093896e in start_thread (arg=0xb01fbb70) at pthread_create.c:300
#12 0x0082da4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77d8710 (LWP 2654)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#7  0x02e0694c in KateLayoutCache::viewLine (this=0xa2d6210, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#8  0x02e06f7f in KateLayoutCache::textLayout (this=0xa2d6210, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#9  0x02e77e91 in KateViewInternal::makeVisible (this=0xa191218, c=..., endCol=-1, force=false, center=false, calledExternally=false) at ../../kate/view/kateviewinternal.cpp:690
#10 0x02e785f0 in KateViewInternal::updateCursor (this=0xa191218, newCursor=..., force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#11 0x02e793eb in KateViewInternal::editEnd (this=0xa191218, editTagLineStart=113, editTagLineEnd=113, tagFrom=true) at ../../kate/view/kateviewinternal.cpp:3399
#12 0x02e57c69 in KateView::editEnd (this=0xa2e5b90, editTagLineStart=113, editTagLineEnd=113, tagFrom=<value optimized out>) at ../../kate/view/kateview.cpp:1602
#13 0x02dbfb04 in KateDocument::editEnd (this=0xa313970) at ../../kate/document/katedocument.cpp:977
#14 0x02dc6dac in KateDocument::removeText (this=0xa313970, _range=..., block=false) at ../../kate/document/katedocument.cpp:821
#15 0x02dc8b7d in KateDocument::backspace (this=0xa313970, view=0xa2e5b90, c=...) at ../../kate/document/katedocument.cpp:2906
#16 0x02e6d0e1 in KateViewInternal::doBackspace (this=0xa191218) at ../../kate/view/kateviewinternal.cpp:854
#17 0x02e5a66c in KateView::backspace (this=0xa2e5b90) at ../../kate/view/kateview.cpp:2295
#18 0x02e5fdd4 in KateView::qt_metacall (this=0xa2e5b90, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbfb24c98) at ./kateview.moc:373
#19 0x00b5dc9a in QMetaObject::metacall (object=0xa2e5b90, cl=QMetaObject::ReadProperty, idx=90, argv=0xbfb24c98) at kernel/qmetaobject.cpp:237
#20 0x00b6c3d5 in QMetaObject::activate (sender=0xa363b28, m=0x1a22d58, local_signal_index=1, argv=0xbfb24c98) at kernel/qobject.cpp:3293
#21 0x010f3bd9 in QAction::triggered (this=0xa363b28, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x010f5dcc in QAction::activate (this=0xa363b28, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x010f7698 in QAction::event (this=0x8773498, e=0x0) at kernel/qaction.cpp:1181
#24 0x0045fd63 in KAction::event (this=0xa363b28, event=0xbfb251b8) at ../../kdeui/actions/kaction.cpp:129
#25 0x010fa4dc in QApplicationPrivate::notify_helper (this=0x85ceb68, receiver=0xa363b28, e=0xbfb251b8) at kernel/qapplication.cpp:4300
#26 0x0110105e in QApplication::notify (this=0xbfb260e4, receiver=0xa363b28, e=0xbfb251b8) at kernel/qapplication.cpp:3704
#27 0x0054bf2a in KApplication::notify (this=0xbfb260e4, receiver=0xa363b28, event=0xbfb251b8) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x00b58a3b in QCoreApplication::notifyInternal (this=0xbfb260e4, receiver=0xa363b28, event=0xbfb251b8) at kernel/qcoreapplication.cpp:704
#29 0x0113c34d in QCoreApplication::sendEvent (this=0x85cec14, e=0xbfb25634) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x85cec14, e=0xbfb25634) at kernel/qshortcutmap.cpp:879
#31 0x0113e15e in QShortcutMap::tryShortcutEvent (this=0x85cec14, o=0xa191218, e=0xbfb25634) at kernel/qshortcutmap.cpp:364
#32 0x01102e43 in QApplication::notify (this=0xbfb260e4, receiver=0xa191218, e=0xbfb25634) at kernel/qapplication.cpp:3746
#33 0x0054bf2a in KApplication::notify (this=0xbfb260e4, receiver=0xa191218, event=0xbfb25634) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x00b58a3b in QCoreApplication::notifyInternal (this=0xbfb260e4, receiver=0xa191218, event=0xbfb25634) at kernel/qcoreapplication.cpp:704
#35 0x010fb2be in QCoreApplication::sendSpontaneousEvent (receiver=0xa191218, event=0x8773498) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0xa191218, event=0x8773498) at kernel/qapplication.cpp:5279
#37 0x011b4d90 in QKeyMapper::sendKeyEvent (keyWidget=0xa191218, grab=false, type=QEvent::KeyPress, code=16777219, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#38 0x011b72f5 in QKeyMapperPrivate::translateKeyEvent (this=0x85f5a90, keyWidget=0xa191218, event=0xbfb25cfc, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x0118a757 in QApplication::x11ProcessEvent (this=0xbfb260e4, event=0xbfb25cfc) at kernel/qapplication_x11.cpp:3394
#40 0x011ba60a in x11EventSourceDispatch (s=0x85d0b08, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x00edc5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x00ee02d8 in ?? () from /lib/libglib-2.0.so.0
#43 0x00ee04b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x00b845d5 in QEventDispatcherGlib::processEvents (this=0x85b04a0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#45 0x011ba135 in QGuiEventDispatcherGlib::processEvents (this=0x85b04a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00b57059 in QEventLoop::processEvents (this=0xbfb25ff4, flags=) at kernel/qeventloop.cpp:149
#47 0x00b574aa in QEventLoop::exec (this=0xbfb25ff4, flags=...) at kernel/qeventloop.cpp:201
#48 0x00b5b69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#49 0x010fa577 in QApplication::exec () at kernel/qapplication.cpp:3579
#50 0x00d2ca65 in kdemain (argc=1, argv=0xbfb26784) at ../../../kate/app/katemain.cpp:377
#51 0x080485fb in main (argc=1, argv=0xbfb26784) at kate_dummy.cpp:3

Possible duplicates by query: bug 242511, bug 242205, bug 241992, bug 241213, bug 238704.

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-07-04 23:16:07 UTC

*** This bug has been marked as a duplicate of bug 226409 ***