Bug 242205 - Kate crash, unknown cause
Summary: Kate crash, unknown cause
Status: RESOLVED DUPLICATE of bug 226409
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-19 22:44 UTC by P Dawkins
Modified: 2010-06-20 11:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description P Dawkins 2010-06-19 22:44:04 UTC
Application: kate (3.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I had quite a few PHP script files open over the 'fish' KIO slave. I use Kate heavily and have had no other problems.

 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#7  0x02ab894c in KateLayoutCache::viewLine (this=0x8cde510, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#8  0x02ab8f7f in KateLayoutCache::textLayout (this=0x8cde510, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#9  0x02b29e91 in KateViewInternal::makeVisible (this=0x8c278f0, c=..., endCol=-1, force=false, center=false, calledExternally=false) at ../../kate/view/kateviewinternal.cpp:690
#10 0x02b2a5f0 in KateViewInternal::updateCursor (this=0x8c278f0, newCursor=..., force=true, center=<value optimized out>, calledExternally=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:1914
#11 0x02b2b3eb in KateViewInternal::editEnd (this=0x8c278f0, editTagLineStart=26, editTagLineEnd=26, tagFrom=true) at ../../kate/view/kateviewinternal.cpp:3399
#12 0x02b09c69 in KateView::editEnd (this=0x8b26030, editTagLineStart=26, editTagLineEnd=26, tagFrom=<value optimized out>) at ../../kate/view/kateview.cpp:1602
#13 0x02a71b04 in KateDocument::editEnd (this=0x8b6b050) at ../../kate/document/katedocument.cpp:977
#14 0x02a78dac in KateDocument::removeText (this=0x8b6b050, _range=..., block=false) at ../../kate/document/katedocument.cpp:821
#15 0x02a7ab7d in KateDocument::backspace (this=0x8b6b050, view=0x8b26030, c=...) at ../../kate/document/katedocument.cpp:2906
#16 0x02b1f0e1 in KateViewInternal::doBackspace (this=0x8c278f0) at ../../kate/view/kateviewinternal.cpp:854
#17 0x02b0c66c in KateView::backspace (this=0x8b26030) at ../../kate/view/kateview.cpp:2295
#18 0x02b11dd4 in KateView::qt_metacall (this=0x8b26030, _c=QMetaObject::InvokeMetaMethod, _id=51, _a=0xbfbc2588) at ./kateview.moc:373
#19 0x0445bc9a in QMetaObject::metacall (object=0x8b26030, cl=QMetaObject::ReadProperty, idx=90, argv=0xbfbc2588) at kernel/qmetaobject.cpp:237
#20 0x0446a3d5 in QMetaObject::activate (sender=0x8d65810, m=0x1820d58, local_signal_index=1, argv=0xbfbc2588) at kernel/qobject.cpp:3293
#21 0x00ef1bd9 in QAction::triggered (this=0x8d65810, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x00ef3dcc in QAction::activate (this=0x8d65810, event=QAction::Trigger) at kernel/qaction.cpp:1255
#23 0x00ef5698 in QAction::event (this=0x82d6ee0, e=0x0) at kernel/qaction.cpp:1181
#24 0x00481d63 in KAction::event (this=0x8d65810, event=0xbfbc2aa8) at ../../kdeui/actions/kaction.cpp:129
#25 0x00ef84dc in QApplicationPrivate::notify_helper (this=0x815e0e0, receiver=0x8d65810, e=0xbfbc2aa8) at kernel/qapplication.cpp:4300
#26 0x00eff05e in QApplication::notify (this=0xbfbc39d4, receiver=0x8d65810, e=0xbfbc2aa8) at kernel/qapplication.cpp:3704
#27 0x0056df2a in KApplication::notify (this=0xbfbc39d4, receiver=0x8d65810, event=0xbfbc2aa8) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x04456a3b in QCoreApplication::notifyInternal (this=0xbfbc39d4, receiver=0x8d65810, event=0xbfbc2aa8) at kernel/qcoreapplication.cpp:704
#29 0x00f3a34d in QCoreApplication::sendEvent (this=0x815e18c, e=0xbfbc2f24) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QShortcutMap::dispatchEvent (this=0x815e18c, e=0xbfbc2f24) at kernel/qshortcutmap.cpp:879
#31 0x00f3c15e in QShortcutMap::tryShortcutEvent (this=0x815e18c, o=0x8c278f0, e=0xbfbc2f24) at kernel/qshortcutmap.cpp:364
#32 0x00f00e43 in QApplication::notify (this=0xbfbc39d4, receiver=0x8c278f0, e=0xbfbc2f24) at kernel/qapplication.cpp:3746
#33 0x0056df2a in KApplication::notify (this=0xbfbc39d4, receiver=0x8c278f0, event=0xbfbc2f24) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x04456a3b in QCoreApplication::notifyInternal (this=0xbfbc39d4, receiver=0x8c278f0, event=0xbfbc2f24) at kernel/qcoreapplication.cpp:704
#35 0x00ef92be in QCoreApplication::sendSpontaneousEvent (receiver=0x8c278f0, event=0x82d6ee0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#36 qt_sendSpontaneousEvent (receiver=0x8c278f0, event=0x82d6ee0) at kernel/qapplication.cpp:5279
#37 0x00fb2d90 in QKeyMapper::sendKeyEvent (keyWidget=0x8c278f0, grab=false, type=QEvent::KeyPress, code=16777219, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=22, nativeVirtualKey=65288, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#38 0x00fb52f5 in QKeyMapperPrivate::translateKeyEvent (this=0x8187b88, keyWidget=0x8c278f0, event=0xbfbc35ec, grab=false) at kernel/qkeymapper_x11.cpp:1831
#39 0x00f88757 in QApplication::x11ProcessEvent (this=0xbfbc39d4, event=0xbfbc35ec) at kernel/qapplication_x11.cpp:3394
#40 0x00fb860a in x11EventSourceDispatch (s=0x8163040, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x007805e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x007842d8 in ?? () from /lib/libglib-2.0.so.0
#43 0x007844b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x044825d5 in QEventDispatcherGlib::processEvents (this=0x81429c0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#45 0x00fb8135 in QGuiEventDispatcherGlib::processEvents (this=0x81429c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x04455059 in QEventLoop::processEvents (this=0xbfbc38e4, flags=) at kernel/qeventloop.cpp:149
#47 0x044554aa in QEventLoop::exec (this=0xbfbc38e4, flags=...) at kernel/qeventloop.cpp:201
#48 0x0445969f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#49 0x00ef8577 in QApplication::exec () at kernel/qapplication.cpp:3579
#50 0x00a73a65 in kdemain (argc=2, argv=0xbfbc4074) at ../../../kate/app/katemain.cpp:377
#51 0x080485fb in main (argc=2, argv=0xbfbc4074) at kate_dummy.cpp:3

This bug may be a duplicate of or related to bug 237256.

Possible duplicates by query: bug 241992, bug 241213, bug 238292, bug 237002, bug 236041.

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-06-20 11:48:37 UTC
fixed in kde 4.4.4.

*** This bug has been marked as a duplicate of bug 226409 ***