Bug 248408 - KNetworkManager crashes when NetworkManager is restarted
Summary: KNetworkManager crashes when NetworkManager is restarted
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-19 17:23 UTC by yingted
Modified: 2010-08-20 04:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yingted 2010-08-19 17:23:58 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.33.6-147.fc13.i686.PAE i686
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
steps:
1. stop networkmanager
2. mess around with the network (I joined a network manually using konsole, iwconfig, and iwlist)
3. start networkmanager

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x8a9d5a8) at /usr/include/QtCore/qatomic_i386.h:120
#7  QString (this=0x8a9d5a8) at /usr/include/QtCore/qstring.h:715
#8  Knm::Activatable::deviceUni (this=0x8a9d5a8) at /usr/src/debug/networkmanagement-0.9/libs/internals/activatable.cpp:51
#9  0x0045b3b1 in compareDevices (first=0x8a9d5a8, second=0x8a87e38) at /usr/src/debug/networkmanagement-0.9/libs/service/sortedactivatablelist.cpp:262
#10 0x0045b4fd in activatableLessThan (first=0x8a9d5a8, second=0x8a87e38) at /usr/src/debug/networkmanagement-0.9/libs/service/sortedactivatablelist.cpp:172
#11 0x0045b7c3 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., 
    end=<value optimized out>, t=@0x8a4e0d8, lessThan=0x229f0) at /usr/include/QtCore/qalgorithms.h:356
#12 0x0045ba83 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8a53568, activatable=0x8a87e38)
    at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x8a53568, activatable=0x8a87e38) at /usr/src/debug/networkmanagement-0.9/libs/service/sortedactivatablelist.cpp:96
#14 0x0044b3d3 in ActivatableList::notifyOnAddActivatable (this=0x8a55780, activatable=0x8a87e38) at /usr/src/debug/networkmanagement-0.9/libs/service/activatablelist.cpp:99
#15 0x0044b788 in ActivatableList::addActivatable (this=0x8a55780, activatable=0x8a87e38) at /usr/src/debug/networkmanagement-0.9/libs/service/activatablelist.cpp:83
#16 0x0044f6fa in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x8aa3508, addedConnection=0x8a9eed8)
    at /usr/src/debug/networkmanagement-0.9/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#17 0x0044ce60 in NetworkInterfaceActivatableProvider::init (this=0x8aa3508) at /usr/src/debug/networkmanagement-0.9/libs/service/networkinterfaceactivatableprovider.cpp:64
#18 0x0044bfe2 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x8a6b0f8, uni=...) at /usr/src/debug/networkmanagement-0.9/libs/service/networkinterfacemonitor.cpp:79
#19 0x00446edc in NetworkInterfaceMonitor::qt_metacall (this=0x8a6b0f8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa15c58)
    at /usr/src/debug/networkmanagement-0.9/i686-redhat-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:75
#20 0x07436bcb in QMetaObject::metacall (object=0x8a6b0f8, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbfa15c58) at kernel/qmetaobject.cpp:237
#21 0x07445a75 in QMetaObject::activate (sender=0x8a56170, m=0x4ed180, local_signal_index=1, argv=0xbfa15c58) at kernel/qobject.cpp:3295
#22 0x004cbe34 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x8a56170, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.5/i686-redhat-linux-gnu/libs/solid/control/networkmanager.moc:110
#23 0x004cc797 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x8a56170, uni=...) at /usr/src/debug/kdebase-workspace-4.4.5/libs/solid/control/networkmanager.cpp:199
#24 0x004cc817 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8a56170, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa15dc8)
    at /usr/src/debug/kdebase-workspace-4.4.5/i686-redhat-linux-gnu/libs/solid/control/networkmanager_p.moc:81
#25 0x07436bcb in QMetaObject::metacall (object=0x8a56170, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbfa15dc8) at kernel/qmetaobject.cpp:237
#26 0x07445a75 in QMetaObject::activate (sender=0x8a66e60, m=0x9814d0, local_signal_index=1, argv=0xbfa15dc8) at kernel/qobject.cpp:3295
#27 0x00967164 in NMNetworkManager::networkInterfaceAdded (this=0x8a66e60, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.5/i686-redhat-linux-gnu/solid/networkmanager-0.7/manager.moc:134
#28 0x0096796b in NMNetworkManager::deviceAdded (this=0x8a66e60, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.5/solid/networkmanager-0.7/manager.cpp:214
#29 0x0096af4d in NMNetworkManager::qt_metacall (this=0x8a66e60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa15f68)
    at /usr/src/debug/kdebase-workspace-4.4.5/i686-redhat-linux-gnu/solid/networkmanager-0.7/manager.moc:111
#30 0x07436bcb in QMetaObject::metacall (object=0x8a66e60, cl=QMetaObject::InvokeMetaMethod, idx=21, argv=0xbfa15f68) at kernel/qmetaobject.cpp:237
#31 0x07445a75 in QMetaObject::activate (sender=0x8a78a38, m=0x9824e0, local_signal_index=0, argv=0xbfa15f68) at kernel/qobject.cpp:3295
#32 0x00974af4 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x8a78a38, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.5/i686-redhat-linux-gnu/solid/networkmanager-0.7/nm-manager-clientinterface.moc:161
#33 0x00974fa5 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x8a78a38, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa161dc)
    at /usr/src/debug/kdebase-workspace-4.4.5/i686-redhat-linux-gnu/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#34 0x0721228c in QDBusConnectionPrivate::deliverCall (this=0x8a52578, object=0x8a78a38, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#35 0x0721cf28 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8a9fc20, object=0x8a78a38) at qdbusintegrator_p.h:101
#36 0x0744209e in QObject::event (this=0x8a78a38, e=0x8a9fc20) at kernel/qobject.cpp:1248
#37 0x0213c77c in QApplicationPrivate::notify_helper (this=0x89bf990, receiver=0x8a78a38, e=0x8a9fc20) at kernel/qapplication.cpp:4306
#38 0x021431d6 in QApplication::notify (this=0xbfa16aa0, receiver=0x8a78a38, e=0x8a9fc20) at kernel/qapplication.cpp:3710
#39 0x06c0200b in KApplication::notify (this=0xbfa16aa0, receiver=0x8a78a38, event=0x8a9fc20) at /usr/src/debug/kdelibs-4.4.5/kdeui/kernel/kapplication.cpp:302
#40 0x07432133 in QCoreApplication::notifyInternal (this=0xbfa16aa0, receiver=0x8a78a38, event=0x8a9fc20) at kernel/qcoreapplication.cpp:726
#41 0x074345bc in sendEvent (receiver=0x0, event_type=0, data=0x899f870) at kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x899f870) at kernel/qcoreapplication.cpp:1367
#43 0x0743473e in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#44 0x0745a950 in sendPostedEvents (s=0x89c1d10) at kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x89c1d10) at kernel/qeventdispatcher_glib.cpp:276
#46 0x00a78525 in g_main_dispatch (context=0x89c1c90) at gmain.c:1960
#47 IA__g_main_context_dispatch (context=0x89c1c90) at gmain.c:2513
#48 0x00a7c268 in g_main_context_iterate (context=0x88c490, block=1, dispatch=1, self=0x89bf948) at gmain.c:2591
#49 0x00a7c449 in IA__g_main_context_iteration (context=0x89c1c90, may_block=1) at gmain.c:2654
#50 0x0745a446 in QEventDispatcherGlib::processEvents (this=0x899f370, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#51 0x021eb336 in QGuiEventDispatcherGlib::processEvents (this=0x899f370, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0x0743080a in QEventLoop::processEvents (this=0xbfa16a04, flags=...) at kernel/qeventloop.cpp:149
#53 0x07430b4a in QEventLoop::exec (this=0xbfa16a04, flags=...) at kernel/qeventloop.cpp:201
#54 0x07434807 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#55 0x0213c828 in QApplication::exec () at kernel/qapplication.cpp:3585
#56 0x0805345f in main (argc=145260088, argv=0x8a9d5a8) at /usr/src/debug/networkmanagement-0.9/monolithic/main.cpp:45

This bug may be a duplicate of or related to bug 210878.

Possible duplicates by query: bug 245839, bug 244291, bug 241678, bug 235015, bug 231278.

Reported using DrKonqi
Comment 1 Jonathan Thomas 2010-08-20 04:25:31 UTC

*** This bug has been marked as a duplicate of bug 210878 ***