Bug 253726 - KNetworkManager Crashed after config change.
Summary: KNetworkManager Crashed after config change.
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-10 10:08 UTC by Lawrence Fitzgerald
Modified: 2010-10-23 16:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lawrence Fitzgerald 2010-10-10 10:08:23 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.3-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
I was switching network control from YAST to Network Manager when it crashed.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  ref (this=0x899b10) at /usr/include/QtCore/qatomic_x86_64.h:121
#6  QString (this=0x899b10) at /usr/include/QtCore/qstring.h:715
#7  Knm::Activatable::deviceUni (this=0x899b10) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#8  0x00007fd4562ec742 in compareDevices (first=<value optimized out>, second=0x899b10) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#9  0x00007fd4562eca43 in activatableLessThan (first=0x890640, second=0x899b10) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#10 0x00007fd4562ed51a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x7d84d0, lessThan=0x7fd4562eca20 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#11 0x00007fd4562ed307 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x7acd00, activatable=0x890640)
    at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleAdd (this=0x7acd00, activatable=0x890640) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#13 0x00007fd4562ddf53 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x890640) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#14 0x00007fd4562e185e in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=<value optimized out>, addedConnection=<value optimized out>)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007fd4562df45d in NetworkInterfaceActivatableProvider::init (this=0x82f300) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007fd4562de99d in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:79
#17 0x00007fd4562d9fbd in NetworkInterfaceMonitor::qt_metacall (this=0x7a6030, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffba891420)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#18 0x00007fd4558cda1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#19 0x00007fd455e60945 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#20 0x00007fd455e60f17 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x77ab00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffba891540)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#21 0x00007fd4558cda1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#22 0x00007fd44883b375 in NMNetworkManager::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#23 0x00007fd44883fbea in NMNetworkManager::deviceAdded (this=0x7602c0, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#24 0x00007fd4488497c9 in NMNetworkManager::qt_metacall (this=0x7602c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffba891700)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#25 0x00007fd4558cda1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#26 0x00007fd44883c382 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#27 0x00007fd448843b94 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x7a8ed0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffba891b40)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#28 0x00007fd455bf1188 in QDBusConnectionPrivate::deliverCall (this=0x798560, object=0x7a8ed0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#29 0x00007fd455bfdecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#30 0x00007fd4558cb509 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#31 0x00007fd454cab4d4 in QApplicationPrivate::notify_helper (this=0x668720, receiver=0x7a8ed0, e=0x8195f0) at kernel/qapplication.cpp:4302
#32 0x00007fd454cb3aca in QApplication::notify (this=<value optimized out>, receiver=0x7a8ed0, e=0x8195f0) at kernel/qapplication.cpp:4185
#33 0x00007fd456bcdc06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#34 0x00007fd4558b9e4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#35 0x00007fd4558bd5ba in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#36 0x00007fd4558e2173 in ?? () from /usr/lib64/libQtCore.so.4
#37 0x00007fd450d7ca93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#38 0x00007fd450d7d270 in ?? () from /usr/lib64/libglib-2.0.so.0
#39 0x00007fd450d7d510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#40 0x00007fd4558e267f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007fd454d4c14e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007fd4558b9292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x00007fd4558b9495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#44 0x00007fd4558bd88b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#45 0x000000000040e88f in _start ()

This bug may be a duplicate of or related to bug 249270, bug 210878.

Possible duplicates by query: bug 249270, bug 249226, bug 248662, bug 248408, bug 245839.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-23 16:03:14 UTC

*** This bug has been marked as a duplicate of bug 210878 ***