Bug 249270 - Networkmanager crashed during activation by Yast2 (opensuse 11.3)
Summary: Networkmanager crashed during activation by Yast2 (opensuse 11.3)
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-27 21:06 UTC by ijedi10
Modified: 2011-02-11 15:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ijedi10 2010-08-27 21:06:39 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I was turning on Knetworkmanger after using ifup in yast for the last month. I was using ifup because of bug that disable the all networks in knetworkmanager. This bug was fixed about a week ago, so I decided to move back over.

This report repressents one of four crashes, I actual had to delete this file to get things to work.
rm /var/lib/NetworkManager/NetworkManager.state 

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x81a0f78) at /usr/include/QtCore/qatomic_i386.h:120
#7  QString (this=0x81a0f78) at /usr/include/QtCore/qstring.h:715
#8  Knm::Activatable::deviceUni (this=0x81a0f78) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0xb70ec99b in compareDevices (first=0x8096288, second=0x81a0f78) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:263
#10 0xb70eccd2 in activatableLessThan (first=0x8096288, second=0x81a0f78) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#11 0xb70ed795 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=
    @0x817ce2c, lessThan=0xb70ecca0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#12 0xb70ed5f3 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8128760, activatable=0x8096288)
    at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x8128760, activatable=0x8096288) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#14 0xb70dc1d4 in ActivatableList::notifyOnAddActivatable (this=0x8134f78, activatable=0x8096288) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#15 0xb70dc253 in ActivatableList::addActivatable (this=0x8134f78, activatable=0x8096288) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:83
#16 0xb70e0126 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x81b02c0, addedConnection=0x81574e0)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#17 0xb70dd8e9 in NetworkInterfaceActivatableProvider::init (this=0x81b02c0) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#18 0xb70dcccd in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x814f720, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:79
#19 0xb70d7b65 in NetworkInterfaceMonitor::qt_metacall (this=0x814f720, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd07e58)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#20 0xb6ebaefd in QMetaObject::metacall (object=0x814f720, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbfd07e58) at kernel/qmetaobject.cpp:237
#21 0xb6ec9fe8 in QMetaObject::activate (sender=0x8140080, m=0xb7080560, local_signal_index=1, argv=0xbfd07e58) at kernel/qobject.cpp:3295
#22 0xb7061195 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x8140080, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#23 0xb70617cc in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x8140080, uni=...) at /usr/src/debug/kdebase-workspace-4.4.4/libs/solid/control/networkmanager.cpp:197
#24 0xb706184e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8140080, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd07fb8)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#25 0xb6ebaefd in QMetaObject::metacall (object=0x8140080, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbfd07fb8) at kernel/qmetaobject.cpp:237
#26 0xb6ec9fe8 in QMetaObject::activate (sender=0x8121c88, m=0xb3c88618, local_signal_index=1, argv=0xbfd07fb8) at kernel/qobject.cpp:3295
#27 0xb3c6e135 in NMNetworkManager::networkInterfaceAdded (this=0x8121c88, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#28 0xb3c7372a in NMNetworkManager::deviceAdded (this=0x8121c88, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#29 0xb3c7df73 in NMNetworkManager::qt_metacall (this=0x8121c88, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd08138)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#30 0xb6ebaefd in QMetaObject::metacall (object=0x8121c88, cl=QMetaObject::InvokeMetaMethod, idx=20, argv=0xbfd08138) at kernel/qmetaobject.cpp:237
#31 0xb6ec9fe8 in QMetaObject::activate (sender=0x814bb30, m=0xb3c88678, local_signal_index=0, argv=0xbfd08138) at kernel/qobject.cpp:3295
#32 0xb3c6f745 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x814bb30, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#33 0xb3c78b7f in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x814bb30, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd0836c)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#34 0xb6fefa37 in QDBusConnectionPrivate::deliverCall (this=0x81294f8, object=0x814bb30, msg=..., metaTypes=..., slotIdx=-1076856392) at qdbusintegrator.cpp:904
#35 0xb6ffd536 in QDBusCallDeliveryEvent::placeMetaCall (this=0x81916d0, object=0x814bb30) at qdbusintegrator_p.h:101
#36 0xb6ec793f in QObject::event (this=0x814bb30, e=0x81916d0) at kernel/qobject.cpp:1248
#37 0xb6409c64 in QApplicationPrivate::notify_helper (this=0x8098918, receiver=0x814bb30, e=0x81916d0) at kernel/qapplication.cpp:4302
#38 0xb6411bf7 in QApplication::notify (this=0xbfd08bd0, receiver=0x814bb30, e=0x81916d0) at kernel/qapplication.cpp:3706
#39 0xb737e9d1 in KApplication::notify (this=0xbfd08bd0, receiver=0x814bb30, event=0x81916d0) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#40 0xb6eb4e0e in QCoreApplication::notifyInternal (this=0xbfd08bd0, receiver=0x814bb30, event=0x81916d0) at kernel/qcoreapplication.cpp:726
#41 0xb6eb89b4 in sendEvent (receiver=0x0, event_type=0, data=0x8074e10) at kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8074e10) at kernel/qcoreapplication.cpp:1367
#43 0xb6eb8b9c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#44 0xb6ee083d in sendPostedEvents (s=0x809ad10) at kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x809ad10) at kernel/qeventdispatcher_glib.cpp:276
#46 0xb5ba8b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#47 0xb5ba9350 in ?? () from /usr/lib/libglib-2.0.so.0
#48 0xb5ba960e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#49 0xb6ee0d4b in QEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#50 0xb64ba19a in QGuiEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0xb6eb411d in QEventLoop::processEvents (this=0xbfd08b34, flags=...) at kernel/qeventloop.cpp:149
#52 0xb6eb4319 in QEventLoop::exec (this=0xbfd08b34, flags=...) at kernel/qeventloop.cpp:201
#53 0xb6eb8c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#54 0xb6407164 in QApplication::exec () at kernel/qapplication.cpp:3581
#55 0x08053e59 in _start ()

Possible duplicates by query: bug 249226, bug 248662, bug 248408, bug 245839, bug 244291.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2011-02-11 15:56:57 UTC
Thanks for the bug report. This looks like bug 210878. There have been commits
recently which might fix the problem.

*** This bug has been marked as a duplicate of bug 210878 ***