Bug 248662 - knetworkmanager crash on restart after config changes
Summary: knetworkmanager crash on restart after config changes
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-22 06:51 UTC by sixdof
Modified: 2010-08-22 10:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sixdof 2010-08-22 06:51:45 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2" (Compiled from sources)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Unchecked option "Change Hostname via DHCP" under the Hostname/DNS tab of Network Settings  >   clicked "ok" > crash began.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#4  ref (this=0xc06c90) at /usr/include/QtCore/qatomic_x86_64.h:121
#5  QString (this=0xc06c90) at /usr/include/QtCore/qstring.h:715
#6  Knm::Activatable::deviceUni (this=0xc06c90) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#7  0x00007f210aeee718 in compareDevices (first=0xc06c90, second=0xa86410) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:262
#8  0x00007f210aeeea43 in activatableLessThan (first=0xc06c90, second=0xa86410) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#9  0x00007f210aeef51a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0xa85938, lessThan=0x7f210aeeea20 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#10 0x00007f210aeef3d8 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#12 0x00007f210aee0363 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:124
#13 0x00007f210aedc030 in ActivatableList::qt_metacall (this=0x709910, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:72
#14 0x00007f210a4cfa1f in QMetaObject::activate (sender=0x8845b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#15 0x00007f210b126991 in Knm::InterfaceConnection::setActivationState (this=0x8845b0, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#16 0x00007f210acb73fd in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x8167d0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#17 0x00007f210acb7429 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x8167d0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#18 0x00007f210acb8ddf in NMDBusActiveConnectionMonitor::handleRemove (this=<value optimized out>, removed=0x8845b0)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:235
#19 0x00007f210aee02a8 in ActivatableList::removeActivatable (this=<value optimized out>, activatable=0x8845b0) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:112
#20 0x00007f210aee1850 in NetworkInterfaceActivatableProvider::handleRemove (this=0x76bd20, removedConnection=0x721910)
    at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:197
#21 0x00007f210aedccf6 in ConnectionList::removeConnection (this=<value optimized out>, connection=0x721910) at /usr/src/debug/networkmanagement/libs/service/connectionlist.cpp:136
#22 0x00007f210acb9f8f in NMDBusSettingsConnectionProvider::onRemoteConnectionRemoved (this=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbussettingsconnectionprovider.cpp:130
#23 0x00007f210ac8feec in NMDBusSettingsConnectionProvider::qt_metacall (this=0x75d850, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff37995120)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbussettingsconnectionprovider.cpp:82
#24 0x00007f210a4cfa1f in QMetaObject::activate (sender=0x71f8c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#25 0x00007f210ac906e0 in OrgFreedesktopNetworkManagerSettingsConnectionInterface::qt_metacall (this=0x71f8c0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff37995460)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nm-exported-connectioninterface.cpp:83
#26 0x00007f210a7f3188 in QDBusConnectionPrivate::deliverCall (this=0x7438b0, object=0x71f8c0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#27 0x00007f210a7ffecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#28 0x00007f210a4cd509 in QObject::event (this=0x71f8c0, e=0x7e95a0) at kernel/qobject.cpp:1248
#29 0x00007f21098ad4d4 in QApplicationPrivate::notify_helper (this=0x65cc40, receiver=0x71f8c0, e=0x7e95a0) at kernel/qapplication.cpp:4302
#30 0x00007f21098b5aca in QApplication::notify (this=<value optimized out>, receiver=0x71f8c0, e=0x7e95a0) at kernel/qapplication.cpp:4185
#31 0x00007f210b7cfc06 in KApplication::notify (this=0x7fff37995f40, receiver=0x71f8c0, event=0x7e95a0) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#32 0x00007f210a4bbe4c in QCoreApplication::notifyInternal (this=0x7fff37995f40, receiver=0x71f8c0, event=0x7e95a0) at kernel/qcoreapplication.cpp:726
#33 0x00007f210a4bf5ba in sendEvent (receiver=0x0, event_type=0, data=0x631220) at kernel/qcoreapplication.h:215
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x631220) at kernel/qcoreapplication.cpp:1367
#35 0x00007f210a4e4173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#36 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#37 0x00007f210597ea93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f210597f270 in ?? () from /usr/lib64/libglib-2.0.so.0
#39 0x00007f210597f510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f210a4e467f in QEventDispatcherGlib::processEvents (this=0x6368b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#41 0x00007f210994e14e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007f210a4bb292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x00007f210a4bb495 in QEventLoop::exec (this=0x7fff37995e90, flags=...) at kernel/qeventloop.cpp:201
#44 0x00007f210a4bf88b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#45 0x000000000040e88f in _start ()

This bug may be a duplicate of or related to bug 210878.

Possible duplicates by query: bug 248408, bug 245839, bug 244291, bug 241678, bug 235015.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-08-22 10:17:57 UTC

*** This bug has been marked as a duplicate of bug 210878 ***