Bug 253885 - KNetwork Manager Crashed after update
Summary: KNetwork Manager Crashed after update
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: 0.9
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-11 22:20 UTC by marko.gabriel.cz
Modified: 2010-10-23 16:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marko.gabriel.cz 2010-10-11 22:20:38 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-trunk-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

-- Information about the crash:
KNetwork manager crashed after updating via apt-get to version 0.8.1-3 debian testing.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0xb710e7ce in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0xb70d9d31 in ?? () from /usr/lib/libknmservice.so.4
#8  0xb70d9e6c in ?? () from /usr/lib/libknmservice.so.4
#9  0xb70da1d8 in ?? () from /usr/lib/libknmservice.so.4
#10 0xb70da3f2 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb70c8d03 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb70c9098 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0xb70cd540 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0xb70cabe0 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#15 0xb70c9aa3 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#16 0xb70c422b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#17 0xb63387da in QMetaObject::metacall (object=0x9994ed0, cl=QMetaObject::InvokeMetaMethod, idx=160939920, argv=0x99984cc) at kernel/qmetaobject.cpp:237
#18 0xb63471eb in QMetaObject::activate (sender=0x98cef80, m=0xb6ff4440, local_signal_index=1, argv=0xbfec6c88) at kernel/qobject.cpp:3295
#19 0xb6fd5463 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x98cef80, _t1=...) at ./networkmanager.moc:107
#20 0xb6fd5ed6 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x98cef80, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#21 0xb6fd5f57 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x98cef80, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfec6df8) at ./networkmanager_p.moc:81
#22 0xb63387da in QMetaObject::metacall (object=0x98cef80, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbfec6df8) at kernel/qmetaobject.cpp:237
#23 0xb63471eb in QMetaObject::activate (sender=0x991f3a8, m=0xb3bc44d0, local_signal_index=1, argv=0xbfec6df8) at kernel/qobject.cpp:3295
#24 0xb3bad613 in NMNetworkManager::networkInterfaceAdded (this=0x991f3a8, _t1=...) at ./manager.moc:134
#25 0xb3badefa in NMNetworkManager::deviceAdded (this=0x991f3a8, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#26 0xb3bb221d in NMNetworkManager::qt_metacall (this=0x991f3a8, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfec6f98) at ./manager.moc:111
#27 0xb63387da in QMetaObject::metacall (object=0x991f3a8, cl=QMetaObject::InvokeMetaMethod, idx=20, argv=0xbfec6f98) at kernel/qmetaobject.cpp:237
#28 0xb63471eb in QMetaObject::activate (sender=0x98fe690, m=0xb3bc54e0, local_signal_index=0, argv=0xbfec6f98) at kernel/qobject.cpp:3295
#29 0xb3bbc563 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x98fe690, _t1=...) at ./nm-manager-clientinterface.moc:155
#30 0xb3bbc925 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x98fe690, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfec7148) at ./nm-manager-clientinterface.moc:102
#31 0xb646d011 in QDBusConnectionPrivate::deliverCall (this=0x9925e18, object=0x98fe690, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#32 0xb6478107 in QDBusCallDeliveryEvent::placeMetaCall (this=0x992cd48, object=0x98fe690) at qdbusintegrator_p.h:101
#33 0xb6343e2e in QObject::event (this=0x98fe690, e=0x992cd48) at kernel/qobject.cpp:1248
#34 0xb661d5cc in QApplicationPrivate::notify_helper (this=0x9883360, receiver=0x98fe690, e=0x992cd48) at kernel/qapplication.cpp:4302
#35 0xb662415e in QApplication::notify (this=0xbfec7a90, receiver=0x98fe690, e=0x992cd48) at kernel/qapplication.cpp:3706
#36 0xb742fc5a in KApplication::notify (this=0xbfec7a90, receiver=0x98fe690, event=0x992cd48) at ../../kdeui/kernel/kapplication.cpp:302
#37 0xb63334fb in QCoreApplication::notifyInternal (this=0xbfec7a90, receiver=0x98fe690, event=0x992cd48) at kernel/qcoreapplication.cpp:726
#38 0xb6336f5c in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x985f860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x985f860) at kernel/qcoreapplication.cpp:1367
#40 0xb63370dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#41 0xb635f5af in QCoreApplication::sendPostedEvents (s=0x9885710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=0x9885710) at kernel/qeventdispatcher_glib.cpp:276
#43 0xb5be8305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0xb5bebfe8 in ?? () from /lib/libglib-2.0.so.0
#45 0xb5bec1c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0xb635f0a5 in QEventDispatcherGlib::processEvents (this=0x985f360, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#47 0xb66dbf25 in QGuiEventDispatcherGlib::processEvents (this=0x985f360, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0xb6331b19 in QEventLoop::processEvents (this=0xbfec79f4, flags=) at kernel/qeventloop.cpp:149
#49 0xb6331f6a in QEventLoop::exec (this=0xbfec79f4, flags=...) at kernel/qeventloop.cpp:201
#50 0xb633719f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#51 0xb661d667 in QApplication::exec () at kernel/qapplication.cpp:3581
#52 0x08053ec5 in _start ()

Possible duplicates by query: bug 250798, bug 249299, bug 249270, bug 248408, bug 246176.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-23 16:02:52 UTC

*** This bug has been marked as a duplicate of bug 210878 ***