Bug 249299 - Knetworkmanager crashed unexpectedly.
Summary: Knetworkmanager crashed unexpectedly.
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-28 08:51 UTC by Willy Gommel
Modified: 2011-05-13 03:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Willy Gommel 2010-08-28 08:51:33 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-5-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

-- Information about the crash:
I had just deleted Grub loader and installed Lilo as a replacement for it. Upon closing the Synaptic package manager, I was abruptly informed of the crash of Knetworkmanager.

Thank you very much! :)


 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0xb6218837 in QMetaObject::cast (this=0x806ea00, obj=0x859d500) at kernel/qmetaobject.cpp:266
#7  0xb6fb9eae in ?? () from /usr/lib/libknmservice.so.4
#8  0xb6fba142 in ?? () from /usr/lib/libknmservice.so.4
#9  0xb6fba3f2 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#10 0xb6fa8d03 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb6fa9098 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb6fac97b in WirelessNetworkInterfaceActivatableProvider::networkAppeared(QString const&) () from /usr/lib/libknmservice.so.4
#13 0xb6facf41 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider(ConnectionList*, ActivatableList*, Solid::Control::WirelessNetworkInterface*, QObject*) ()
   from /usr/lib/libknmservice.so.4
#14 0xb6fa9b0c in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#15 0xb6fa422b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#16 0xb621880a in QMetaObject::metacall (object=0x8588580, cl=3216217928, idx=140112904, argv=0x85db910) at kernel/qmetaobject.cpp:237
#17 0xb62271db in QMetaObject::activate (sender=0x8589688, m=0xb6ed4440, local_signal_index=1, argv=0xbfb39c38) at kernel/qobject.cpp:3295
#18 0xb6eb5463 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x8589688, _t1=...) at ./networkmanager.moc:107
#19 0xb6eb5ed6 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x8589688, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#20 0xb6eb5f57 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8589688, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfb39da8) at ./networkmanager_p.moc:81
#21 0xb621880a in QMetaObject::metacall (object=0x8589688, cl=3216217928, idx=10, argv=0xbfb39da8) at kernel/qmetaobject.cpp:237
#22 0xb62271db in QMetaObject::activate (sender=0x8585358, m=0xb3c934d0, local_signal_index=1, argv=0xbfb39da8) at kernel/qobject.cpp:3295
#23 0xb3c7c613 in NMNetworkManager::networkInterfaceAdded (this=0x8585358, _t1=...) at ./manager.moc:134
#24 0xb3c7cefa in NMNetworkManager::deviceAdded (this=0x8585358, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#25 0xb3c8121d in NMNetworkManager::qt_metacall (this=0x8585358, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfb39f48) at ./manager.moc:111
#26 0xb621880a in QMetaObject::metacall (object=0x8585358, cl=3216217928, idx=20, argv=0xbfb39f48) at kernel/qmetaobject.cpp:237
#27 0xb62271db in QMetaObject::activate (sender=0x85941b0, m=0xb3c944e0, local_signal_index=0, argv=0xbfb39f48) at kernel/qobject.cpp:3295
#28 0xb3c8b563 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x85941b0, _t1=...) at ./nm-manager-clientinterface.moc:155
#29 0xb3c8b925 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x85941b0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb3a0f8) at ./nm-manager-clientinterface.moc:102
#30 0xb634d021 in QDBusConnectionPrivate::deliverCall (this=0x856e858, object=0x85941b0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#31 0xb6358107 in QDBusCallDeliveryEvent::placeMetaCall (this=0x86f6aa8, object=0x85941b0) at qdbusintegrator_p.h:101
#32 0xb6223e2e in QObject::event (this=0x85941b0, e=0x86f6aa8) at kernel/qobject.cpp:1248
#33 0xb64fd5cc in QApplicationPrivate::notify_helper (this=0x84fc458, receiver=0x85941b0, e=0x86f6aa8) at kernel/qapplication.cpp:4302
#34 0xb650415e in QApplication::notify (this=0xbfb3aa40, receiver=0x85941b0, e=0x86f6aa8) at kernel/qapplication.cpp:3706
#35 0xb730fc5a in KApplication::notify (this=0xbfb3aa40, receiver=0x85941b0, event=0x86f6aa8) at ../../kdeui/kernel/kapplication.cpp:302
#36 0xb621352b in QCoreApplication::notifyInternal (this=0xbfb3aa40, receiver=0x85941b0, event=0x86f6aa8) at kernel/qcoreapplication.cpp:726
#37 0xb6216f8c in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x84de860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x84de860) at kernel/qcoreapplication.cpp:1367
#39 0xb621710d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#40 0xb623f59f in QCoreApplication::sendPostedEvents (s=0x84fe910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=0x84fe910) at kernel/qeventdispatcher_glib.cpp:276
#42 0xb5ac72f5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0xb5acafd8 in ?? () from /lib/libglib-2.0.so.0
#44 0xb5acb1b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0xb623f095 in QEventDispatcherGlib::processEvents (this=0x84de360, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#46 0xb65bbf45 in QGuiEventDispatcherGlib::processEvents (this=0x84de360, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0xb6211b49 in QEventLoop::processEvents (this=0xbfb3a9a4, flags=) at kernel/qeventloop.cpp:149
#48 0xb6211f9a in QEventLoop::exec (this=0xbfb3a9a4, flags=...) at kernel/qeventloop.cpp:201
#49 0xb62171cf in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#50 0xb64fd667 in QApplication::exec () at kernel/qapplication.cpp:3581
#51 0x08053ec5 in _start ()

Possible duplicates by query: bug 246876, bug 246485, bug 245614, bug 244011, bug 237771.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-05-13 03:30:10 UTC

*** This bug has been marked as a duplicate of bug 210878 ***