Bug 246176 - KNetworkManager crashed when restarting service on ubuntu
Summary: KNetworkManager crashed when restarting service on ubuntu
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-29 17:38 UTC by Miguel Tadeu
Modified: 2010-08-06 11:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Tadeu 2010-07-29 17:38:39 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.92 (KDE 4.4.92 (KDE 4.5 RC2))
Qt Version: 4.7.0
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I restarted the service in ubuntu and network-manager crashed leavin this report

-- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#7  0x497a42ce in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#8  0x497e1f71 in ?? () from /usr/lib/libknmservice.so.4
#9  0x497e20ac in ?? () from /usr/lib/libknmservice.so.4
#10 0x497e2418 in ?? () from /usr/lib/libknmservice.so.4
#11 0x497e2632 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x497d06e3 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0x497d0f38 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#14 0x497d51e6 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#15 0x497d2760 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#16 0x497d15d3 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#17 0x497cbadb in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#18 0x4c0399ca in QMetaObject::metacall (object=<value optimized out>, cl=<value optimized out>, idx=<value optimized out>, argv=<value optimized out>) at kernel/qmetaobject.cpp:237
#19 0x4c04c755 in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>) at kernel/qobject.cpp:3280
#20 0x4a02eb83 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=) at ./networkmanager.moc:107
#21 0x4a02f606 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=<value optimized out>, uni=<value optimized out>) at ../../../../libs/solid/control/networkmanager.cpp:197
#22 0x4a02f687 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>)
    at ./networkmanager_p.moc:81
#23 0x4c0399ca in QMetaObject::metacall (object=<value optimized out>, cl=<value optimized out>, idx=<value optimized out>, argv=<value optimized out>) at kernel/qmetaobject.cpp:237
#24 0x4c04c755 in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>) at kernel/qobject.cpp:3280
#25 0x4c8d0d63 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=) at ./networkmanager.moc:115
#26 0x00fb843a in NMNetworkManager::deviceAdded (this=0x91bc4e8, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#27 0x00fbc665 in NMNetworkManager::qt_metacall (this=0x91bc4e8, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbfeb99f8) at ./manager.moc:95
#28 0x4c0399ca in QMetaObject::metacall (object=<value optimized out>, cl=<value optimized out>, idx=<value optimized out>, argv=<value optimized out>) at kernel/qmetaobject.cpp:237
#29 0x4c04c755 in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>) at kernel/qobject.cpp:3280
#30 0x00fc7123 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x91bd7d8, _t1=...) at ./nm-manager-clientinterface.moc:155
#31 0x00fc76a5 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x91bd7d8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfeb9c3c) at ./nm-manager-clientinterface.moc:102
#32 0x4c1d1694 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=<value optimized out>, 
    slotIdx=<value optimized out>) at qdbusintegrator.cpp:909
#33 0x4c1dcdd7 in QDBusCallDeliveryEvent::placeMetaCall (this=) at qdbusintegrator_p.h:103
#34 0x4c046762 in QObject::event (this=<value optimized out>, e=<value optimized out>) at kernel/qobject.cpp:1219
#35 0x4e3fd56c in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4389
#36 0x4e4035be in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:3791
#37 0x4953762a in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:309
#38 0x4c033c6b in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:732
#39 0x4c036ecb in QCoreApplication::sendEvent (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>) at kernel/qcoreapplication.cpp:1373
#41 0x4c03708d in QCoreApplication::sendPostedEvents (receiver=) at kernel/qcoreapplication.cpp:1266
#42 0x4c06299f in QCoreApplication::sendPostedEvents (s=) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=) at kernel/qeventdispatcher_glib.cpp:276
#44 0x4afbf5e5 in g_main_dispatch (context=<value optimized out>) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:1960
#45 IA__g_main_context_dispatch (context=<value optimized out>) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2513
#46 0x4afc32d8 in g_main_context_iterate (context=<value optimized out>, block=<value optimized out>, dispatch=<value optimized out>, self=) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2591
#47 0x4afc34b8 in IA__g_main_context_iteration (context=<value optimized out>, may_block=<value optimized out>) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#48 0x4c062495 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#49 0x4e4be855 in QGuiEventDispatcherGlib::processEvents (this=) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x4c032719 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#51 0x4c032b9a in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#52 0x4c03714f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#53 0x4e3fc397 in QApplication::exec () at kernel/qapplication.cpp:3665
#54 0x08053f91 in _start ()

This bug may be a duplicate of or related to bug 243887.

Possible duplicates by query: bug 245614, bug 243887, bug 241678.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-08-06 11:50:53 UTC

*** This bug has been marked as a duplicate of bug 210878 ***