Bug 244191 - KNotify crashed without audio
Summary: KNotify crashed without audio
Status: RESOLVED DUPLICATE of bug 232068
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-11 09:26 UTC by sad2004
Modified: 2010-07-11 17:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sad2004 2010-07-11 09:26:57 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33.5-desktop-2mnb i686
Distribution: "Mandriva Linux 2010.1"

-- Information about the crash:
KNotify crashes one time when my OS lost an audio card.

The crash does not seem to be reproducible.

 -- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb54af6d0 (LWP 1204))]

Thread 2 (Thread 0xadd12b70 (LWP 1281)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb60d0b16 in poll () from /lib/i686/libc.so.6
#2  0xb5d881c6 in poll_func (ufds=0x9a3dd00, nfds=2, timeout=-1, userdata=0x9a3c970) at pulse/thread-mainloop.c:75
#3  0xb5d74eca in pa_mainloop_poll (m=0x9a3d2c0) at pulse/mainloop.c:879
#4  0xb5d7670d in pa_mainloop_iterate (m=0x9a3d2c0, block=1, retval=0x0) at pulse/mainloop.c:961
#5  0xb5d767e4 in pa_mainloop_run (m=0x9a3d2c0, retval=0x0) at pulse/mainloop.c:979
#6  0xb5d880ae in thread (userdata=0x9a3cad0) at pulse/thread-mainloop.c:94
#7  0xb595c996 in internal_thread_func (userdata=0x9a3dc38) at pulsecore/thread-posix.c:83
#8  0xb5de7ae5 in start_thread () from /lib/i686/libpthread.so.0
#9  0xb60dc03e in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb54af6d0 (LWP 1204)):
[KCrash Handler]
#6  0xb382bf0c in snd_pcm_ioplug_close (pcm=0x9a3a508) at pcm_ioplug.c:743
#7  0xb37e71ee in snd_pcm_close (pcm=0x9a3a508) at pcm.c:706
#8  0xb388e0af in gst_alsasink_close (asink=0x9a244f8) at gstalsasink.c:783
#9  0xb326bee0 in gst_audioringbuffer_close_device (buf=0x9a28148) at gstaudiosink.c:365
#10 0xb325b468 in gst_ring_buffer_close_device (buf=0x9a28148) at gstringbuffer.c:714
#11 0xb3266292 in gst_base_audio_sink_change_state (element=0x9a244f8, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1888
#12 0xb32fd55b in gst_element_change_state (element=0x9a244f8, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2531
#13 0xb3300d37 in gst_element_set_state_func (element=0x9a244f8, state=GST_STATE_NULL) at gstelement.c:2487
#14 0xb32fc8a1 in gst_element_set_state (element=0x9a244f8, state=GST_STATE_NULL) at gstelement.c:2388
#15 0xb32eb828 in gst_bin_element_set_state (element=0x9a260d8, transition=9) at gstbin.c:2121
#16 gst_bin_change_state_func (element=0x9a260d8, transition=9) at gstbin.c:2420
#17 0xb32fd55b in gst_element_change_state (element=0x9a260d8, transition=9) at gstelement.c:2531
#18 0xb3300d37 in gst_element_set_state_func (element=0x9a260d8, state=GST_STATE_NULL) at gstelement.c:2487
#19 0xb32fc8a1 in gst_element_set_state (element=0x9a260d8, state=GST_STATE_NULL) at gstelement.c:2388
#20 0xb354fd85 in Phonon::Gstreamer::MediaNode::addOutput (this=0x9a5cfb0, output=0x98e3f7c, tee=0x9a50018) at /usr/src/debug/phonon-4.4.1/gstreamer/medianode.cpp:317
#21 0xb354ff16 in Phonon::Gstreamer::MediaNode::linkMediaNodeList (this=0x9a5cfb0, list=..., bin=0x9a48d80, tee=0x9a50018, fakesink=0x9a66130, src=0x9a461f8)
    at /usr/src/debug/phonon-4.4.1/gstreamer/medianode.cpp:392
#22 0xb354ffd3 in Phonon::Gstreamer::MediaNode::link (this=0x9a5cfb0) at /usr/src/debug/phonon-4.4.1/gstreamer/medianode.cpp:404
#23 0xb354f7b4 in Phonon::Gstreamer::MediaNode::buildGraph (this=0x9a5cfb0) at /usr/src/debug/phonon-4.4.1/gstreamer/medianode.cpp:102
#24 0xb3550897 in Phonon::Gstreamer::MediaNode::connectNode (this=0x9a5cfb0, obj=0x98e3f70) at /usr/src/debug/phonon-4.4.1/gstreamer/medianode.cpp:188
#25 0xb353e6e5 in Phonon::Gstreamer::Backend::connectNodes (this=0x98e4e98, source=0x9a5cfa0, sink=0x98e3f70) at /usr/src/debug/phonon-4.4.1/gstreamer/backend.cpp:364
#26 0xb72810ed in Phonon::PathPrivate::executeTransaction (this=0x98c7c98, disconnections=<value optimized out>, connections=...) at /usr/src/debug/phonon-4.4.1/phonon/path.cpp:332
#27 0xb7281d70 in Phonon::Path::reconnect (this=0xbf8657cc, source=0x989cc80, sink=0x9824b58) at /usr/src/debug/phonon-4.4.1/phonon/path.cpp:197
#28 0xb7281f8f in Phonon::createPath (source=0x989cc80, sink=0x9824b58) at /usr/src/debug/phonon-4.4.1/phonon/path.cpp:436
#29 0x0805313d in _start ()

This bug may be a duplicate of or related to bug 237744.

Possible duplicates by query: bug 237744.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-07-11 17:25:50 UTC

*** This bug has been marked as a duplicate of bug 232068 ***