Bug 232784 - kopete crash causes plasma crash
Summary: kopete crash causes plasma crash
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-31 01:49 UTC by Scott
Modified: 2010-03-31 14:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott 2010-03-31 01:49:26 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
kopete crashed after facebook account add, and forever after crashes on load-up, causing plasma to then crash

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x0000003a0ddee035 in QString (this=<value optimized out>, group=<value optimized out>, state=<value optimized out>) at /usr/include/qt4/QtCore/qstring.h:714
#6  KIconEffect::fingerprint (this=<value optimized out>, group=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconeffect.cpp:158
#7  0x0000003a0ddfaac8 in KIconLoader::loadIcon (this=<value optimized out>, _name=<value optimized out>, group=<value optimized out>, size=<value optimized out>, state=<value optimized out>, 
    overlays=) at ../../kdeui/icons/kiconloader.cpp:1085
#8  0x0000003a0ddf254c in KIconEngine::actualSize (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>)
    at ../../kdeui/icons/kiconengine.cpp:80
#9  0x0000003a0d06fcfc in QIcon::actualSize (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:700
#10 0x0000003a187ad427 in Plasma::IconWidgetPrivate::decoration (this=<value optimized out>, option=<value optimized out>, useHoverEffect=<value optimized out>, 
    usePressedEffect=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:701
#11 0x0000003a187aea8c in Plasma::IconWidget::paint (this=<value optimized out>, painter=<value optimized out>, option=<value optimized out>, widget=<value optimized out>)
    at ../../plasma/widgets/iconwidget.cpp:1013
#12 0x0000003a0d5c9a7a in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=<value optimized out>, widget=<value optimized out>, useWindowOpacity=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4243
#13 0x0000003a0d5c9d0c in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=<value optimized out>, itemToPixmap=<value optimized out>, 
    renderHints=<value optimized out>, option=<value optimized out>, painterStateProtection=) at graphicsview/qgraphicsscene.cpp:4281
#14 0x0000003a0d5ddf73 in QGraphicsScenePrivate::drawItemHelper (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, option=<value optimized out>, 
    widget=<value optimized out>, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4574
#15 0x0000003a0d5de865 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=) at graphicsview/qgraphicsscene.cpp:4827
#16 0x0000003a0d5df4c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=<value optimized out>, parentOpacity=<value optimized out>, effectTransform=) at graphicsview/qgraphicsscene.cpp:4749
#17 0x0000003a0d5de900 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=) at graphicsview/qgraphicsscene.cpp:4841
#18 0x0000003a0d5df4c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=<value optimized out>, parentOpacity=<value optimized out>, effectTransform=) at graphicsview/qgraphicsscene.cpp:4749
#19 0x0000003a0d5de900 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=) at graphicsview/qgraphicsscene.cpp:4841
#20 0x0000003a0d5df4c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=<value optimized out>, parentOpacity=<value optimized out>, effectTransform=) at graphicsview/qgraphicsscene.cpp:4749
#21 0x0000003a0d5de900 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=) at graphicsview/qgraphicsscene.cpp:4841
#22 0x0000003a0d5df4c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=<value optimized out>, parentOpacity=<value optimized out>, effectTransform=) at graphicsview/qgraphicsscene.cpp:4749
#23 0x0000003a0d5dfe64 in QGraphicsScenePrivate::drawItems (this=<value optimized out>, painter=<value optimized out>, viewTransform=<value optimized out>, exposedRegion=<value optimized out>, 
    widget=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4619
#24 0x0000003a0d5ff265 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3393
#25 0x0000003a12e42bf9 in PanelView::paintEvent (this=<value optimized out>, event=<value optimized out>) at ../../../../plasma/desktop/shell/panelview.cpp:1310
#26 0x0000003a0d0140e2 in QWidget::event (this=<value optimized out>, event=<value optimized out>) at kernel/qwidget.cpp:8144
#27 0x0000003a0d3ba956 in QFrame::event (this=<value optimized out>, e=<value optimized out>) at widgets/qframe.cpp:557
#28 0x0000003a0d5fa5db in QGraphicsView::viewportEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:2787
#29 0x0000003a0a76d227 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>)
    at kernel/qcoreapplication.cpp:819
#30 0x0000003a0cfbe0fc in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4296
#31 0x0000003a0cfc471b in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4183
#32 0x0000003a0de32d76 in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x0000003a0a76de0c in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:704
#34 0x0000003a0d01c75d in QCoreApplication::sendSpontaneousEvent (this=<value optimized out>, pdev=<value optimized out>, rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>, backingStore=) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 QWidgetPrivate::drawWidget (this=<value optimized out>, pdev=<value optimized out>, rgn=<value optimized out>, offset=<value optimized out>, flags=<value optimized out>, 
    sharedPainter=<value optimized out>, backingStore=) at kernel/qwidget.cpp:5339
#36 0x0000003a0d01d3f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=) at kernel/qwidget.cpp:5452
#37 0x0000003a0d01c4ba in QWidgetPrivate::drawWidget (this=<value optimized out>, pdev=<value optimized out>, rgn=<value optimized out>, offset=<value optimized out>, flags=<value optimized out>, 
    sharedPainter=<value optimized out>, backingStore=) at kernel/qwidget.cpp:5388
#38 0x0000003a0d1d5c95 in QWidgetBackingStore::sync (this=<value optimized out>) at painting/qbackingstore.cpp:1291
#39 0x0000003a0d00e050 in QWidgetPrivate::syncBackingStore (this=<value optimized out>) at kernel/qwidget.cpp:1672
#40 0x0000003a0d0147e5 in QWidget::event (this=<value optimized out>, event=<value optimized out>) at kernel/qwidget.cpp:8291
#41 0x0000003a0d3ba956 in QFrame::event (this=<value optimized out>, e=<value optimized out>) at widgets/qframe.cpp:557
#42 0x0000003a0d445dab in QAbstractScrollArea::event (this=<value optimized out>, e=<value optimized out>) at widgets/qabstractscrollarea.cpp:989
#43 0x0000003a12e44f50 in PanelView::event (this=<value optimized out>, event=<value optimized out>) at ../../../../plasma/desktop/shell/panelview.cpp:1324
#44 0x0000003a0cfbe12c in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4300
#45 0x0000003a0cfc471b in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4183
#46 0x0000003a0de32d76 in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:302
#47 0x0000003a0a76de0c in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:704
#48 0x0000003a0a770587 in QCoreApplication::sendEvent (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>) at kernel/qcoreapplication.cpp:1345
#50 0x0000003a0d5e6a7a in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=<value optimized out>) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#51 QGraphicsScenePrivate::_q_processDirtyItems (this=<value optimized out>) at graphicsview/qgraphicsscene.cpp:509
#52 0x0000003a0d5e7002 in QGraphicsScene::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>)
    at .moc/release-shared/moc_qgraphicsscene.cpp:130
#53 0x0000003a186fd995 in Plasma::Corona::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>) at ./corona.moc:107
#54 0x0000003a12e34de3 in DesktopCorona::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>) at ./desktopcorona.moc:86
#55 0x0000003a0a77db49 in QObject::event (this=<value optimized out>, e=<value optimized out>) at kernel/qobject.cpp:1248
#56 0x0000003a0d5e2fb0 in QGraphicsScene::event (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3500
#57 0x0000003a0cfbe12c in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4300
#58 0x0000003a0cfc471b in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4183
#59 0x0000003a0de32d76 in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:302
#60 0x0000003a0a76de0c in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:704
#61 0x0000003a0a770587 in QCoreApplication::sendEvent (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>) at kernel/qcoreapplication.cpp:1345
#63 0x0000003a0a7977f3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#65 0x0000003a0663bbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#66 0x0000003a0663f598 in ?? () from /lib/libglib-2.0.so.0
#67 0x0000003a0663f6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#68 0x0000003a0a797333 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#69 0x0000003a0d06df0e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#70 0x0000003a0a76c732 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#71 0x0000003a0a76cb0c in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#72 0x0000003a0a77084b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#73 0x0000003a12e3c0a2 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:112
#74 0x0000000000406fb8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a499 "0") at ../../kinit/kinit.cpp:717
#75 0x0000000000407c70 in handle_launcher_request (sock=9, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#76 0x0000000000408121 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#77 0x0000000000408df2 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1841

This bug may be a duplicate of or related to bug 226596.

Possible duplicates by query: bug 232279, bug 231810, bug 231041, bug 230313, bug 230222.

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-31 14:37:51 UTC
Tracked at bug 226596. Regards

*** This bug has been marked as a duplicate of bug 226596 ***