Bug 232279 - error to close kopete
Summary: error to close kopete
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-26 22:53 UTC by Raúl A V
Modified: 2010-03-27 14:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl A V 2010-03-26 22:53:21 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
I close kopete, when plasma is crash.... sorry my english is very bad

 -- Backtrace:
Application: Área de trabajo de Plasma (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f220ee237f0 (LWP 2809))]

Thread 3 (Thread 0x7f21dbddb910 (LWP 2822)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f2204072816 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f2204072859 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f220d066a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f220be2a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f21da176910 (LWP 2823)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f220d2f50e5 in thread_sleep (ti=0x7f21da175ee0) at thread/qthread_unix.cpp:398
#2  0x00007f220d2f5296 in QThread::sleep (secs=<value optimized out>) at thread/qthread_unix.cpp:412
#3  0x00007f21e549149a in ?? () from /usr/lib/kde4/plasma_applet_mail_plasmoid.so
#4  0x00007f220d2f5775 in QThreadPrivate::start (arg=0x405ae40) at thread/qthread_unix.cpp:248
#5  0x00007f220d066a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f220be2a80d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 1 (Thread 0x7f220ee237f0 (LWP 2809)):
[KCrash Handler]
#5  0x00007f220d8ed027 in QString (this=0x48, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#6  KIconEffect::fingerprint (this=0x48, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#7  0x00007f220d8f9ac8 in KIconLoader::loadIcon (this=0x69e27f0, _name=..., group=<value optimized out>, size=20, state=<value optimized out>, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#8  0x00007f220d8f154c in KIconEngine::actualSize (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>)
    at ../../kdeui/icons/kiconengine.cpp:80
#9  0x00007f220c639cfc in QIcon::actualSize (this=<value optimized out>, size=..., mode=QIcon::Normal, state=QIcon::On) at image/qicon.cpp:700
#10 0x00007f220544a427 in Plasma::IconWidgetPrivate::decoration (this=0x5a70dc0, option=<value optimized out>, useHoverEffect=true, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#11 0x00007f220544ba8c in Plasma::IconWidget::paint (this=0x73f7a90, painter=0x7fff03f33870, option=0x25ca828, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1013
#12 0x00007f220cb93a7a in _q_paintItem (item=<value optimized out>, painter=0x7fff03f33870, option=0x25ca828, widget=0x0, useWindowOpacity=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4243
#13 0x00007f220cb93d0c in _q_paintIntoCache (pix=0x7fff03f33f00, item=<value optimized out>, pixmapExposed=..., itemToPixmap=<value optimized out>, renderHints=)
    at graphicsview/qgraphicsscene.cpp:4281
#14 0x00007f220cba7f73 in QGraphicsScenePrivate::drawItemHelper (this=<value optimized out>, item=0x73f7aa0, painter=0x7fff03f35e70, option=0x25ca828, widget=<value optimized out>, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4574
#15 0x00007f220cba8865 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x73f7aa0, painter=0x7fff03f35e70, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x40c4430, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4827
#16 0x00007f220cba94c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x73f7aa0, painter=0x7fff03f35e70, viewTransform=0x7fff03f35c20, exposedRegion=0x4077930, 
    widget=0x40c4430, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#17 0x00007f220cba8900 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x2ab74f0, painter=0x7fff03f35e70, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x40c4430, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#18 0x00007f220cba94c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x2ab74f0, painter=0x7fff03f35e70, viewTransform=0x7fff03f35c20, exposedRegion=0x4077930, 
    widget=0x40c4430, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#19 0x00007f220cba8900 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x2a13f30, painter=0x7fff03f35e70, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x40c4430, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#20 0x00007f220cba94c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x2a13f30, painter=0x7fff03f35e70, viewTransform=0x7fff03f35c20, exposedRegion=0x4077930, 
    widget=0x40c4430, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#21 0x00007f220cba8900 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x29f8b40, painter=0x7fff03f35e70, viewTransform=<value optimized out>, transformPtr=<value optimized out>, 
    exposedRegion=<value optimized out>, widget=0x40c4430, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true)
    at graphicsview/qgraphicsscene.cpp:4841
#22 0x00007f220cba94c2 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x29f8b40, painter=0x7fff03f35e70, viewTransform=0x7fff03f35c20, exposedRegion=0x4077930, 
    widget=0x40c4430, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#23 0x00007f220cba9e64 in QGraphicsScenePrivate::drawItems (this=0x25ca5d0, painter=0x7fff03f35e70, viewTransform=0x7fff03f35c20, exposedRegion=0x4077930, widget=0x40c4430)
    at graphicsview/qgraphicsscene.cpp:4619
#24 0x00007f220cbc9265 in QGraphicsView::paintEvent (this=0x3d96e50, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3393
#25 0x00007f22001fabf9 in PanelView::paintEvent (this=0x7fff03f32ee0, event=0x48) at ../../../../plasma/desktop/shell/panelview.cpp:1310
#26 0x00007f220c5de0e2 in QWidget::event (this=0x3d96e50, event=0x7fff03f367b0) at kernel/qwidget.cpp:8144
#27 0x00007f220c984956 in QFrame::event (this=0x3d96e50, e=0x7fff03f367b0) at widgets/qframe.cpp:557
#28 0x00007f220cbc45db in QGraphicsView::viewportEvent (this=0x3d96e50, event=0x7fff03f367b0) at graphicsview/qgraphicsview.cpp:2787
#29 0x00007f220d3e9227 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x40c4430, event=0x7fff03f367b0) at kernel/qcoreapplication.cpp:819
#30 0x00007f220c5880fc in QApplicationPrivate::notify_helper (this=0x251e6f0, receiver=0x40c4430, e=0x7fff03f367b0) at kernel/qapplication.cpp:4296
#31 0x00007f220c58e71b in QApplication::notify (this=0x2507fa0, receiver=0x40c4430, e=0x7fff03f367b0) at kernel/qapplication.cpp:4183
#32 0x00007f220d931d76 in KApplication::notify (this=0x2507fa0, receiver=0x40c4430, event=0x7fff03f367b0) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007f220d3e9e0c in QCoreApplication::notifyInternal (this=0x2507fa0, receiver=0x40c4430, event=0x7fff03f367b0) at kernel/qcoreapplication.cpp:704
#34 0x00007f220c5e675d in QCoreApplication::sendSpontaneousEvent (this=0x334d8c0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x40879a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 QWidgetPrivate::drawWidget (this=0x334d8c0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x40879a0)
    at kernel/qwidget.cpp:5339
#36 0x00007f220c5e73f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x40879a0) at kernel/qwidget.cpp:5452
#37 0x00007f220c5e64ba in QWidgetPrivate::drawWidget (this=0x4077470, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x40879a0) at kernel/qwidget.cpp:5388
#38 0x00007f220c79fc95 in QWidgetBackingStore::sync (this=0x40879a0) at painting/qbackingstore.cpp:1291
#39 0x00007f220c5d8050 in QWidgetPrivate::syncBackingStore (this=0x4077470) at kernel/qwidget.cpp:1672
#40 0x00007f220c5de7e5 in QWidget::event (this=0x3d96e50, event=0x346ab30) at kernel/qwidget.cpp:8291
#41 0x00007f220c984956 in QFrame::event (this=0x3d96e50, e=0x346ab30) at widgets/qframe.cpp:557
#42 0x00007f220ca0fdab in QAbstractScrollArea::event (this=0x3d96e50, e=0x346ab30) at widgets/qabstractscrollarea.cpp:989
#43 0x00007f22001fcf50 in PanelView::event (this=0x3d96e50, event=0x346ab30) at ../../../../plasma/desktop/shell/panelview.cpp:1324
#44 0x00007f220c58812c in QApplicationPrivate::notify_helper (this=0x251e6f0, receiver=0x3d96e50, e=0x346ab30) at kernel/qapplication.cpp:4300
#45 0x00007f220c58e71b in QApplication::notify (this=0x2507fa0, receiver=0x3d96e50, e=0x346ab30) at kernel/qapplication.cpp:4183
#46 0x00007f220d931d76 in KApplication::notify (this=0x2507fa0, receiver=0x3d96e50, event=0x346ab30) at ../../kdeui/kernel/kapplication.cpp:302
#47 0x00007f220d3e9e0c in QCoreApplication::notifyInternal (this=0x2507fa0, receiver=0x3d96e50, event=0x346ab30) at kernel/qcoreapplication.cpp:704
#48 0x00007f220d3ec587 in QCoreApplication::sendEvent (receiver=0x3d96e50, event_type=<value optimized out>, data=0x2494cb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x3d96e50, event_type=<value optimized out>, data=0x2494cb0) at kernel/qcoreapplication.cpp:1345
#50 0x00007f220cbb0a7a in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x25ca5d0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#51 QGraphicsScenePrivate::_q_processDirtyItems (this=0x25ca5d0) at graphicsview/qgraphicsscene.cpp:509
#52 0x00007f220cbb1002 in QGraphicsScene::qt_metacall (this=0x25fd870, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x72fdde0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#53 0x00007f220539a995 in Plasma::Corona::qt_metacall (this=0x7fff03f32ee0, _c=72, _id=0, _a=0x0) at ./corona.moc:107
#54 0x00007f22001ecde3 in DesktopCorona::qt_metacall (this=0x7fff03f32ee0, _c=72, _id=0, _a=0x0) at ./desktopcorona.moc:86
#55 0x00007f220d3f9b49 in QObject::event (this=0x25fd870, e=0x5455c40) at kernel/qobject.cpp:1248
#56 0x00007f220cbacfb0 in QGraphicsScene::event (this=0x25fd870, event=0x5455c40) at graphicsview/qgraphicsscene.cpp:3500
#57 0x00007f220c58812c in QApplicationPrivate::notify_helper (this=0x251e6f0, receiver=0x25fd870, e=0x5455c40) at kernel/qapplication.cpp:4300
#58 0x00007f220c58e71b in QApplication::notify (this=0x2507fa0, receiver=0x25fd870, e=0x5455c40) at kernel/qapplication.cpp:4183
#59 0x00007f220d931d76 in KApplication::notify (this=0x2507fa0, receiver=0x25fd870, event=0x5455c40) at ../../kdeui/kernel/kapplication.cpp:302
#60 0x00007f220d3e9e0c in QCoreApplication::notifyInternal (this=0x2507fa0, receiver=0x25fd870, event=0x5455c40) at kernel/qcoreapplication.cpp:704
#61 0x00007f220d3ec587 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x2494cb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#62 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x2494cb0) at kernel/qcoreapplication.cpp:1345
#63 0x00007f220d4137f3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#65 0x00007f22085ecbce in g_main_dispatch (context=0x2520d20) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#66 IA__g_main_context_dispatch (context=0x2520d20) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#67 0x00007f22085f0598 in g_main_context_iterate (context=0x2520d20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#68 0x00007f22085f06c0 in IA__g_main_context_iteration (context=0x2520d20, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#69 0x00007f220d413333 in QEventDispatcherGlib::processEvents (this=0x24961c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#70 0x00007f220c637f0e in QGuiEventDispatcherGlib::processEvents (this=0x7fff03f32ee0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#71 0x00007f220d3e8732 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#72 0x00007f220d3e8b0c in QEventLoop::exec (this=0x7fff03f388a0, flags=) at kernel/qeventloop.cpp:201
#73 0x00007f220d3ec84b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#74 0x00007f22001f40a2 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:112
#75 0x0000000000406fb8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a499 "0") at ../../kinit/kinit.cpp:717
#76 0x0000000000407c70 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#77 0x0000000000408121 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#78 0x0000000000408df2 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1841
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-27 14:22:54 UTC
Reported at bug 226596..
Regards

*** This bug has been marked as a duplicate of bug 226596 ***