Bug 228923 - Plasma desktop crashed after a Kopete crash
Summary: Plasma desktop crashed after a Kopete crash
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-28 18:05 UTC by Alexis Kauffmann
Modified: 2010-03-05 18:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Kauffmann 2010-02-28 18:05:04 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.1
Operating System: Linux 2.6.31-19-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
Kopete crashed simultaneously. Opera browser, Flock browser and Firefox stopped responding too.

 -- Backtrace:
Application: Espaço de trabalho do Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c3980 (LWP 2271))]

Thread 2 (Thread 0xab385b70 (LWP 2272)):
#0  0x03297e06 in *__GI_clock_gettime (clock_id=53067764, tp=0xab384f68) at ../sysdeps/unix/clock_gettime.c:100
#1  0x01060a0b in qt_gettime () at kernel/qcore_unix.cpp:109
#2  0x01065af5 in QTimerInfoList::updateCurrentTime (this=0xa5c4c34) at kernel/qeventdispatcher_unix.cpp:340
#3  0x01065b3a in QTimerInfoList::timerWait (this=0xa5c4c34, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x01063b28 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xab38507c) at kernel/qeventdispatcher_glib.cpp:136
#5  0x01063bb5 in timerSourcePrepare (source=0x0, timeout=0x329bff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x060d3f90 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x060d4351 in ?? () from /lib/libglib-2.0.so.0
#8  0x060d4863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x0106391f in QEventDispatcherGlib::processEvents (this=0xa5c3500, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x01036319 in QEventLoop::processEvents (this=0xab385240, flags=) at kernel/qeventloop.cpp:149
#11 0x0103676a in QEventLoop::exec (this=0xab385240, flags=...) at kernel/qeventloop.cpp:201
#12 0x00f325a8 in QThread::exec (this=0xa5c3628) at thread/qthread.cpp:487
#13 0x01015fbb in QInotifyFileSystemWatcherEngine::run (this=0xa5c3628) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x00f3532e in QThreadPrivate::start (arg=0xa5c3628) at thread/qthread_unix.cpp:248
#15 0x0015480e in start_thread (arg=0xab385b70) at pthread_create.c:300
#16 0x04fdc8de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77c3980 (LWP 2271)):
[KCrash Handler]
#6  0x00cad386 in QString (this=0x13, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:723
#7  KIconEffect::fingerprint (this=0x13, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x00cba844 in KIconLoader::loadIcon (this=0xa4361f8, _name=..., group=KIconLoader::Desktop, size=21, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0x00cb1cd8 in KIconEngine::actualSize (this=0xb411750, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0x0384e7f6 in QIcon::actualSize (this=0xb21426c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0x014069a3 in Plasma::IconWidgetPrivate::decoration (this=0xb2141f0, option=0xa0c6b98, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0x014085d7 in Plasma::IconWidget::paint (this=0xad91b30, painter=0xbf84f77c, option=0xa0c6b98, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0x03e2139c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0xa0c6b98, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4218
#14 0x03e2424a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0xa0c6b98, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4256
#15 0x03e3d8b0 in QGraphicsScenePrivate::drawItemHelper (this=0xa0c6a38, item=0xad91b38, painter=0xbf8512e4, option=0xa0c6b98, widget=0xaa3c538, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4549
#16 0x03e3e471 in QGraphicsScenePrivate::draw (this=0xa0c6a38, item=0xad91b38, painter=0xbf8512e4, viewTransform=0xbf85111c, transformPtr=0xbf850138, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4767
#17 0x03e3ee43 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xa0c6a38, item=0xad91b38, painter=0xbf8512e4, viewTransform=0xbf85111c, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4700
#18 0x03e3e4fc in QGraphicsScenePrivate::draw (this=0xa0c6a38, item=0xa3738c8, painter=0xbf8512e4, viewTransform=0xbf85111c, transformPtr=0xbf850588, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4781
#19 0x03e3ee43 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xa0c6a38, item=0xa3738c8, painter=0xbf8512e4, viewTransform=0xbf85111c, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4700
#20 0x03e3e4fc in QGraphicsScenePrivate::draw (this=0xa0c6a38, item=0xa337328, painter=0xbf8512e4, viewTransform=0xbf85111c, transformPtr=0xbf8509d8, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4781
#21 0x03e3ee43 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xa0c6a38, item=0xa337328, painter=0xbf8512e4, viewTransform=0xbf85111c, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4700
#22 0x03e3e4fc in QGraphicsScenePrivate::draw (this=0xa0c6a38, item=0xa2dbec8, painter=0xbf8512e4, viewTransform=0xbf85111c, transformPtr=0xbf850e28, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4781
#23 0x03e3ee43 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xa0c6a38, item=0xa2dbec8, painter=0xbf8512e4, viewTransform=0xbf85111c, exposedRegion=0xaa29abc, widget=0xaa3c538, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4700
#24 0x03e3f556 in QGraphicsScenePrivate::drawItems (this=0xa0c6a38, painter=0xbf8512e4, viewTransform=0xbf85111c, exposedRegion=0xaa29abc, widget=0xaa3c538) at graphicsview/qgraphicsscene.cpp:4593
#25 0x03e5997b in QGraphicsView::paintEvent (this=0xaa28238, event=0xbf851a04) at graphicsview/qgraphicsview.cpp:3394
#26 0x01a04d99 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#27 0x037eb466 in QWidget::event (this=0xaa28238, event=0xbf851a04) at kernel/qwidget.cpp:8124
#28 0x03be6b23 in QFrame::event (this=0xaa28238, e=0xbf851a04) at widgets/qframe.cpp:557
#29 0x03c80da2 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x13) at widgets/qabstractscrollarea.cpp:1036
#30 0x03e55dfb in QGraphicsView::viewportEvent (this=0xaa28238, event=0xbf851a04) at graphicsview/qgraphicsview.cpp:2788
#31 0x03c83695 in QAbstractScrollAreaPrivate::viewportEvent (this=0xa8c0fd8, o=0xaa3c538, e=0xbf851a04) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0xa8c0fd8, o=0xaa3c538, e=0xbf851a04) at widgets/qabstractscrollarea_p.h:116
#33 0x01036f9a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9fdf9e0, receiver=0xaa3c538, event=0xbf851a04) at kernel/qcoreapplication.cpp:819
#34 0x0378d259 in QApplicationPrivate::notify_helper (this=0x9fdf9e0, receiver=0xaa3c538, e=0xbf851a04) at kernel/qapplication.cpp:4294
#35 0x03793f79 in QApplication::notify (this=0x9feea88, receiver=0xaa3c538, e=0xbf851a04) at kernel/qapplication.cpp:4263
#36 0x00cf71fa in KApplication::notify (this=0x9feea88, receiver=0xaa3c538, event=0xbf851a04) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x01037cfb in QCoreApplication::notifyInternal (this=0x9feea88, receiver=0xaa3c538, event=0xbf851a04) at kernel/qcoreapplication.cpp:704
#38 0x037f4666 in QCoreApplication::sendSpontaneousEvent (this=0xaa3c550, pdev=0xaa3cd6c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xaa3cc68)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0xaa3c550, pdev=0xaa3cd6c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xaa3cc68) at kernel/qwidget.cpp:5321
#40 0x037f54a5 in QWidgetPrivate::paintSiblingsRecursive (this=0xaa29758, pdev=0xaa3cd6c, siblings=..., index=11, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xaa3cc68)
    at kernel/qwidget.cpp:5434
#41 0x037f52de in QWidgetPrivate::paintSiblingsRecursive (this=0xaa29758, pdev=0xaa3cd6c, siblings=..., index=12, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xaa3cc68)
    at kernel/qwidget.cpp:5421
#42 0x037f43b5 in QWidgetPrivate::drawWidget (this=0xaa29758, pdev=0xaa3cd6c, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xaa3cc68) at kernel/qwidget.cpp:5370
#43 0x039ca490 in QWidgetBackingStore::sync (this=0xaa3cc68) at painting/qbackingstore.cpp:1291
#44 0x037e4973 in QWidgetPrivate::syncBackingStore (this=0xaa29758) at kernel/qwidget.cpp:1663
#45 0x037ebc26 in QWidget::event (this=0xaa28238, event=0xb0dc0e0) at kernel/qwidget.cpp:8271
#46 0x03be6b23 in QFrame::event (this=0xaa28238, e=0xb0dc0e0) at widgets/qframe.cpp:557
#47 0x03c817b7 in QAbstractScrollArea::event (this=0xaa28238, e=0xb0dc0e0) at widgets/qabstractscrollarea.cpp:989
#48 0x03e57fa6 in QGraphicsView::event (this=0xaa28238, event=0xb0dc0e0) at graphicsview/qgraphicsview.cpp:2666
#49 0x01a05583 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#50 0x0378d27c in QApplicationPrivate::notify_helper (this=0x9fdf9e0, receiver=0xb0dc0e0, e=0xaa28238) at kernel/qapplication.cpp:4298
#51 0x03793f79 in QApplication::notify (this=0x9feea88, receiver=0xaa28238, e=0xb0dc0e0) at kernel/qapplication.cpp:4263
#52 0x00cf71fa in KApplication::notify (this=0x9feea88, receiver=0xaa28238, event=0xb0dc0e0) at ../../kdeui/kernel/kapplication.cpp:302
#53 0x01037cfb in QCoreApplication::notifyInternal (this=0x9feea88, receiver=0xaa28238, event=0xb0dc0e0) at kernel/qcoreapplication.cpp:704
#54 0x0103a733 in QCoreApplication::sendEvent (receiver=0xaa28238, event_type=77, data=0x9fa9658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0xaa28238, event_type=77, data=0x9fa9658) at kernel/qcoreapplication.cpp:1345
#56 0x0103a89d in QCoreApplication::sendPostedEvents (receiver=0xaa28238, event_type=77) at kernel/qcoreapplication.cpp:1238
#57 0x03e3b5b6 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0xa0c6a38) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#58 QGraphicsScenePrivate::_q_processDirtyItems (this=0xa0c6a38) at graphicsview/qgraphicsscene.cpp:490
#59 0x03e3bb06 in QGraphicsScene::qt_metacall (this=0xa0b04a8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xada90e0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#60 0x0134590a in Plasma::Corona::qt_metacall (this=0xa0b04a8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xada90e0) at ./corona.moc:107
#61 0x019f51ad in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#62 0x0103cf6a in QMetaObject::metacall (object=0xa0b04a8, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x0) at kernel/qmetaobject.cpp:237
#63 0x01047626 in QMetaCallEvent::placeMetaCall (this=0xb8ef8a8, object=0xa0b04a8) at kernel/qobject.cpp:561
#64 0x0104874e in QObject::event (this=0xa0b04a8, e=0xb8ef8a8) at kernel/qobject.cpp:1248
#65 0x03e377e4 in QGraphicsScene::event (this=0xa0b04a8, event=0xb8ef8a8) at graphicsview/qgraphicsscene.cpp:3475
#66 0x0378d27c in QApplicationPrivate::notify_helper (this=0x9fdf9e0, receiver=0xa0b04a8, e=0xb8ef8a8) at kernel/qapplication.cpp:4298
#67 0x03793ede in QApplication::notify (this=0x9feea88, receiver=0xa0b04a8, e=0xb8ef8a8) at kernel/qapplication.cpp:3702
#68 0x00cf71fa in KApplication::notify (this=0x9feea88, receiver=0xa0b04a8, event=0xb8ef8a8) at ../../kdeui/kernel/kapplication.cpp:302
#69 0x01037cfb in QCoreApplication::notifyInternal (this=0x9feea88, receiver=0xa0b04a8, event=0xb8ef8a8) at kernel/qcoreapplication.cpp:704
#70 0x0103a733 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9fa9658) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#71 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9fa9658) at kernel/qcoreapplication.cpp:1345
#72 0x0103a89d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#73 0x01063def in QCoreApplication::sendPostedEvents (s=0x9fe1210) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#74 postEventSourceDispatch (s=0x9fe1210) at kernel/qeventdispatcher_glib.cpp:276
#75 0x060d0e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#76 0x060d4730 in ?? () from /lib/libglib-2.0.so.0
#77 0x060d4863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#78 0x010638e5 in QEventDispatcherGlib::processEvents (this=0x9fdf6b0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#79 0x0384c485 in QGuiEventDispatcherGlib::processEvents (this=0x9fdf6b0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#80 0x01036319 in QEventLoop::processEvents (this=0xbf853424, flags=) at kernel/qeventloop.cpp:149
#81 0x0103676a in QEventLoop::exec (this=0xbf853424, flags=...) at kernel/qeventloop.cpp:201
#82 0x0103a95f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#83 0x0378d317 in QApplication::exec () at kernel/qapplication.cpp:3577
#84 0x019fd17e in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#85 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9faa330 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051405 "0") at ../../kinit/kinit.cpp:717
#86 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#87 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#88 0x0804fe2f in main (argc=4, argv=0xbf853ed4, envp=0xbf853ee8) at ../../kinit/kinit.cpp:1841
The current source language is "auto; currently c".

Possible duplicates by query: bug 226596.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-03-05 18:18:08 UTC

*** This bug has been marked as a duplicate of bug 226596 ***