Bug 225230 - kate crashes while closing a file out of half dozen open files
Summary: kate crashes while closing a file out of half dozen open files
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-02 08:02 UTC by Pol
Modified: 2010-05-23 00:26 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pol 2010-02-02 08:02:07 UTC
Application: kate (3.3.95)
KDE Platform Version: 4.3.95 (KDE 4.3.95 (KDE 4.4 RC2))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
kate crashes while closing aan open  file out of half dozen open files

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c3760 (LWP 2367))]

Thread 2 (Thread 0xb4fbcb70 (LWP 2384)):
#0  0x00d0b422 in __kernel_vsyscall ()
#1  0x00617e15 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x02064bb7 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x213e1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#3  0x02064c01 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x213e1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#4  0x0061380e in start_thread (arg=0xb4fbcb70) at pthread_create.c:300
#5  0x06ee28de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77c3760 (LWP 2367)):
[KCrash Handler]
#6  0x054f9f6a in KateSmartCursor::setPositionInternal (this=0xa280d60, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0x054fa342 in KateSmartCursor::translate (this=0xa280d60, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x055005df in KateSmartGroup::translateChanged (this=0xa1b4400, edit=...) at ../../kate/smart/katesmartmanager.cpp:467
#9  0x055038bf in KateSmartManager::slotTextChanged (this=0xa00f768, edit=0xa2d47c0) at ../../kate/smart/katesmartmanager.cpp:371
#10 0x05503c4f in KateSmartManager::qt_metacall (this=0xa00f768, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbffc64f8) at ./katesmartmanager.moc:80
#11 0x004fd11a in QMetaObject::metacall (object=0xa00f768, cl=QMetaObject::ResetProperty, idx=5, argv=0xbffc64f8) at kernel/qmetaobject.cpp:237
#12 0x0050b89b in QMetaObject::activate (sender=0xa1ffaf0, m=0x56148a4, local_signal_index=0, argv=0xbffc64f8) at kernel/qobject.cpp:3294
#13 0x054bb413 in KateEditHistory::editDone (this=0xa1ffaf0, _t1=0xa2d47c0) at ./kateedit.moc:84
#14 0x05494a5a in KateDocument::closeUrl (this=0xa1b23b0) at ../../kate/document/katedocument.cpp:2521
#15 0x05296f13 in ?? () from /usr/lib/libkateinterfaces.so.4
#16 0x052aa9f8 in ?? () from /usr/lib/libkateinterfaces.so.4
#17 0x052af22c in ?? () from /usr/lib/libkateinterfaces.so.4
#18 0x004fd11a in QMetaObject::metacall (object=0x9c412b0, cl=QMetaObject::ResetProperty, idx=157202504, argv=0x0) at kernel/qmetaobject.cpp:237
#19 0x0050b89b in QMetaObject::activate (sender=0x9c91910, m=0x52e5814, local_signal_index=0, argv=0xbffc6938) at kernel/qobject.cpp:3294
#20 0x052993e3 in ?? () from /usr/lib/libkateinterfaces.so.4
#21 0x05299b18 in ?? () from /usr/lib/libkateinterfaces.so.4
#22 0x05299c8b in ?? () from /usr/lib/libkateinterfaces.so.4
#23 0x004fd11a in QMetaObject::metacall (object=0x9c91910, cl=QMetaObject::ResetProperty, idx=-1073976960, argv=0x9c91910) at kernel/qmetaobject.cpp:237
#24 0x0050b89b in QMetaObject::activate (sender=0x9ca3790, m=0x43f8d98, local_signal_index=1, argv=0xbffc6ad8) at kernel/qobject.cpp:3294
#25 0x03ad2a39 in QAction::triggered (this=0x9ca3790, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#26 0x03ad4bac in QAction::activate (this=0x9ca3790, event=QAction::Trigger) at kernel/qaction.cpp:1245
#27 0x03f7308c in QMenuPrivate::activateCausedStack (this=0x9d93910, causedStack=..., action=0x9ca3790, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:994
#28 0x03f7937b in QMenuPrivate::activateAction (this=0x9d93910, action=0x9ca3790, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1086
#29 0x03f7a3b7 in QMenu::mouseReleaseEvent (this=0x9d938f0, e=0xbffc7300) at widgets/qmenu.cpp:2307
#30 0x00fdf965 in KMenu::mouseReleaseEvent (this=0x9d938f0, e=0xbffc7300) at ../../kdeui/widgets/kmenu.cpp:471
#31 0x03b35f9e in QWidget::event (this=0x9d938f0, event=0xbffc7300) at kernel/qwidget.cpp:7974
#32 0x03f7ba44 in QMenu::event (this=0x9d938f0, e=0xbffc7300) at widgets/qmenu.cpp:2406
#33 0x03ad919c in QApplicationPrivate::notify_helper (this=0x952ba10, receiver=0x9d938f0, e=0xbffc7300) at kernel/qapplication.cpp:4242
#34 0x03ae076b in QApplication::notify (this=0xbffc8e04, receiver=0x9d938f0, e=0xbffc7300) at kernel/qapplication.cpp:3822
#35 0x00ee9a1a in KApplication::notify (this=0xbffc8e04, receiver=0x9d938f0, event=0xbffc7300) at ../../kdeui/kernel/kapplication.cpp:302
#36 0x004f7eab in QCoreApplication::notifyInternal (this=0xbffc8e04, receiver=0x9d938f0, event=0xbffc7300) at kernel/qcoreapplication.cpp:704
#37 0x03adf71f in QCoreApplication::sendEvent (receiver=0x9d938f0, event=0xbffc7300, alienWidget=0x0, nativeWidget=0x9d938f0, buttonDown=0x4414060, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QApplicationPrivate::sendMouseEvent (receiver=0x9d938f0, event=0xbffc7300, alienWidget=0x0, nativeWidget=0x9d938f0, buttonDown=0x4414060, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2956
#39 0x03b691f7 in QETWidget::translateMouseEvent (this=0x9d938f0, event=0xbffc781c) at kernel/qapplication_x11.cpp:4302
#40 0x03b681f1 in QApplication::x11ProcessEvent (this=0xbffc8e04, event=0xbffc781c) at kernel/qapplication_x11.cpp:3379
#41 0x03b9704a in x11EventSourceDispatch (s=0x952d240, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#42 0x019b5e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0x019b9730 in ?? () from /lib/libglib-2.0.so.0
#44 0x019b9863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0x00523bd5 in QEventDispatcherGlib::processEvents (this=0x9529df0, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#46 0x03b96b75 in QGuiEventDispatcherGlib::processEvents (this=0x9529df0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#47 0x004f64c9 in QEventLoop::processEvents (this=0xbffc7b10, flags=) at kernel/qeventloop.cpp:149
#48 0x004f691a in QEventLoop::exec (this=0xbffc7b10, flags=...) at kernel/qeventloop.cpp:201
#49 0x03f7676e in QMenu::exec (this=0x9d938f0, p=..., action=0x0) at widgets/qmenu.cpp:2045
#50 0x052a0d1f in ?? () from /usr/lib/libkateinterfaces.so.4
#51 0x052a7545 in ?? () from /usr/lib/libkateinterfaces.so.4
#52 0x004fd11a in QMetaObject::metacall (object=0x97549c0, cl=QMetaObject::ResetProperty, idx=-1073972368, argv=0x9d938f0) at kernel/qmetaobject.cpp:237
#53 0x0050b89b in QMetaObject::activate (sender=0x9c91910, m=0x43f9d48, local_signal_index=0, argv=0xbffc7cb8) at kernel/qobject.cpp:3294
#54 0x03b28eb3 in QWidget::customContextMenuRequested (this=0x9c91910, _t1=...) at .moc/release-shared/moc_qwidget.cpp:360
#55 0x052990ac in ?? () from /usr/lib/libkateinterfaces.so.4
#56 0x03b366ca in QWidget::event (this=0x9c91910, event=0xbffc8528) at kernel/qwidget.cpp:8141
#57 0x03f2f433 in QFrame::event (this=0x9c91910, e=0xbffc8528) at widgets/qframe.cpp:557
#58 0x03fc8cf2 in QAbstractScrollArea::viewportEvent (this=0x3, e=0x0) at widgets/qabstractscrollarea.cpp:1032
#59 0x0407d0d4 in QAbstractItemView::viewportEvent (this=0x9c91910, event=0xbffc8528) at itemviews/qabstractitemview.cpp:1589
#60 0x03fcb5e5 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9ca7628, o=0x9c49c00, e=0xbffc8528) at widgets/qabstractscrollarea_p.h:100
#61 QAbstractScrollAreaFilter::eventFilter (this=0x9ca7628, o=0x9c49c00, e=0xbffc8528) at widgets/qabstractscrollarea_p.h:116
#62 0x004f714a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x952ba10, receiver=0x9c49c00, event=0xbffc8528) at kernel/qcoreapplication.cpp:819
#63 0x03ad9179 in QApplicationPrivate::notify_helper (this=0x952ba10, receiver=0x9c49c00, e=0xbffc8528) at kernel/qapplication.cpp:4238
#64 0x03ae01e6 in QApplication::notify (this=0xbffc8e04, receiver=0x9c49c00, e=0xbffc8528) at kernel/qapplication.cpp:3901
#65 0x00ee9a1a in KApplication::notify (this=0xbffc8e04, receiver=0x9c49c00, event=0xbffc8528) at ../../kdeui/kernel/kapplication.cpp:302
#66 0x004f7eab in QCoreApplication::notifyInternal (this=0xbffc8e04, receiver=0x9c49c00, event=0xbffc8528) at kernel/qcoreapplication.cpp:704
#67 0x03b6ea9e in QCoreApplication::sendSpontaneousEvent (receiver=0x9c49c00, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#68 0x03b693dc in QETWidget::translateMouseEvent (this=0x9756d18, event=0xbffc8a1c) at kernel/qapplication_x11.cpp:4373
#69 0x03b681f1 in QApplication::x11ProcessEvent (this=0xbffc8e04, event=0xbffc8a1c) at kernel/qapplication_x11.cpp:3379
#70 0x03b9704a in x11EventSourceDispatch (s=0x952d240, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#71 0x019b5e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#72 0x019b9730 in ?? () from /lib/libglib-2.0.so.0
#73 0x019b9863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#74 0x00523bd5 in QEventDispatcherGlib::processEvents (this=0x9529df0, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#75 0x03b96b75 in QGuiEventDispatcherGlib::processEvents (this=0x9529df0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#76 0x004f64c9 in QEventLoop::processEvents (this=0xbffc8d14, flags=) at kernel/qeventloop.cpp:149
#77 0x004f691a in QEventLoop::exec (this=0xbffc8d14, flags=...) at kernel/qeventloop.cpp:201
#78 0x004fab0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#79 0x03ad9237 in QApplication::exec () at kernel/qapplication.cpp:3570
#80 0x03124a25 in kdemain () from /usr/lib/libkdeinit4_kate.so
#81 0x0804dff7 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x951a2b6 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051429 "0") at ../../kinit/kinit.cpp:706
#82 0x0804ec15 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1198
#83 0x0804f08c in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1391
#84 0x0804fe27 in main (argc=4, argv=0xbffc9d54, envp=0xbffc9d68) at ../../kinit/kinit.cpp:1830

Possible duplicates by query: bug 223836, bug 221835, bug 220289, bug 217035, bug 213512.

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-02 19:46:55 UTC
Mh, this looks related to bug 200450...
- Have you tried to repeat the situation to check if Kate crash again ?
Regards
Comment 2 Christoph Cullmann 2010-02-16 13:02:26 UTC
Can't reproduce either.
Comment 3 Dominik Haumann 2010-05-23 00:26:56 UTC

*** This bug has been marked as a duplicate of bug 200450 ***