Bug 221835 - Kate crashes when cut&pasting block of python code [KateSmartCursor::setPositionInternal, KateSmartCursor::translate, KateSmartGroup::translateChanged]
Summary: Kate crashes when cut&pasting block of python code [KateSmartCursor::setPosit...
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-08 19:13 UTC by Unknown
Modified: 2010-01-08 19:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2010-01-08 19:13:05 UTC
Application: kate (3.3.85)
KDE Platform Version: 4.3.85 (KDE 4.3.85 (KDE 4.4 Beta2))
Qt Version: 4.6.0
Operating System: Linux 2.6.32-9-generic x86_64
Distribution: Ubuntu lucid (development branch)

-- Information about the crash:
100% reproducible on this file (cant attach files from the reporting assistant, using dpaste): http://dpaste.com/hold/142610/

Cut the from_string method (lines 14-34) and paste it at the end of the file.


The crash can be reproduced everytime.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently asm".
[Current thread is 1 (Thread 0x7f9dcdc16760 (LWP 27301))]

Thread 2 (Thread 0x7f9dbc64f710 (LWP 27302)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9dbc98df36 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9dbcc6d200) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x00007f9dbc98df79 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f9dbcc7b2cc) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00007f9dcbe6bb14 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f9dcac2bf7d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9dcdc16760 (LWP 27301)):
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x2104f70, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007f9dbcfe399f in KateSmartCursor::translate (this=0x2104f70, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007f9dbcfe99cc in KateSmartGroup::translateChanged (this=0x22a3650, edit=...) at ../../kate/smart/katesmartmanager.cpp:467
#8  0x00007f9dbcfecbab in KateSmartManager::slotTextChanged (this=0x1e5a4e0, edit=0x1da2f20) at ../../kate/smart/katesmartmanager.cpp:371
#9  0x00007f9dbcfecf2c in KateSmartManager::qt_metacall (this=0x1e5a4e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4a93e100) at ./katesmartmanager.moc:80
#10 0x00007f9dcc201833 in QMetaObject::activate (sender=0x2099f40, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x20f9148) at kernel/qobject.cpp:3294
#11 0x00007f9dbcfa9f0f in KateEditHistory::editDone (this=0x7fff4a93de60, _t1=0x1da2f20) at ./kateedit.moc:84
#12 0x00007f9dbcf8c86b in KateDocument::editWrapLine (this=0x20a51b0, line=48, col=30, newLine=<value optimized out>, newLineAdded=<value optimized out>) at ../../kate/document/katedocument.cpp:1273
#13 0x00007f9dbcf95421 in KateDocument::insertText (this=0x20a51b0, position=<value optimized out>, text=..., block=<value optimized out>) at ../../kate/document/katedocument.cpp:623
#14 0x00007f9dbcf942aa in KateDocument::paste (this=0x20a51b0, view=0x20eedb0, mode=<value optimized out>) at ../../kate/document/katedocument.cpp:2917
#15 0x00007f9dbd016645 in KateView::paste (this=0x20eedb0) at ../../kate/view/kateview.cpp:2176
#16 0x00007f9dbd01e855 in KateView::qt_metacall (this=0x20eedb0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4a93e710) at ./kateview.moc:327
#17 0x00007f9dcc201833 in QMetaObject::activate (sender=0x2161c50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x20f9148) at kernel/qobject.cpp:3294
#18 0x00007f9dcb38df02 in QAction::triggered (this=0x7fff4a93de60, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#19 0x00007f9dcb38feeb in QAction::activate (this=0x2161c50, event=<value optimized out>) at kernel/qaction.cpp:1245
#20 0x00007f9dcb391857 in QAction::event (this=0x7fff4a93de60, e=<value optimized out>) at kernel/qaction.cpp:1162
#21 0x00007f9dcc65f24d in KAction::event (this=0x7fff4a93de60, event=0x7fff4a93ecf0) at ../../kdeui/actions/kaction.cpp:129
#22 0x00007f9dcb393f2c in QApplicationPrivate::notify_helper (this=0x172bb50, receiver=0x2161c50, e=0x7fff4a93ecf0) at kernel/qapplication.cpp:4242
#23 0x00007f9dcb39a53d in QApplication::notify (this=0x7fff4a9402a0, receiver=0x2161c50, e=0x7fff4a93ecf0) at kernel/qapplication.cpp:4125
#24 0x00007f9dcc7319d6 in KApplication::notify (this=0x7fff4a9402a0, receiver=0x2161c50, event=0x7fff4a93ecf0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f9dcc1eeabc in QCoreApplication::notifyInternal (this=0x7fff4a9402a0, receiver=0x2161c50, event=0x7fff4a93ecf0) at kernel/qcoreapplication.cpp:704
#26 0x00007f9dcb3cef56 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fff4a93f260) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fff4a93f260) at kernel/qshortcutmap.cpp:879
#28 0x00007f9dcb3d0d47 in QShortcutMap::tryShortcutEvent (this=0x172bc78, o=<value optimized out>, e=0x7fff4a93f260) at kernel/qshortcutmap.cpp:364
#29 0x00007f9dcb39be95 in QApplication::notify (this=0x7fff4a9402a0, receiver=0x2104ef0, e=0x7fff4a93f260) at kernel/qapplication.cpp:3703
#30 0x00007f9dcc7319d6 in KApplication::notify (this=0x7fff4a9402a0, receiver=0x2104ef0, event=0x7fff4a93f260) at ../../kdeui/kernel/kapplication.cpp:302
#31 0x00007f9dcc1eeabc in QCoreApplication::notifyInternal (this=0x7fff4a9402a0, receiver=0x2104ef0, event=0x7fff4a93f260) at kernel/qcoreapplication.cpp:704
#32 0x00007f9dcb43d0ea in QKeyMapper::sendKeyEvent (keyWidget=0x2104ef0, grab=<value optimized out>, type=QEvent::KeyPress, code=86, modifiers=<value optimized out>, text=..., autorepeat=false, 
    count=1, nativeScanCode=55, nativeVirtualKey=118, nativeModifiers=20) at kernel/qkeymapper_x11.cpp:1861
#33 0x00007f9dcb43f660 in QKeyMapperPrivate::translateKeyEvent (this=0x17636f0, keyWidget=0x2104ef0, event=<value optimized out>, grab=50) at kernel/qkeymapper_x11.cpp:1831
#34 0x00007f9dcb416b24 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff4a93fe30) at kernel/qapplication_x11.cpp:3394
#35 0x00007f9dcb4427f2 in x11EventSourceDispatch (s=0x172ea60, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007f9dc7826d4e in g_main_dispatch (context=0x172d500) at /build/buildd/glib2.0-2.23.1/glib/gmain.c:1960
#37 IA__g_main_context_dispatch (context=0x172d500) at /build/buildd/glib2.0-2.23.1/glib/gmain.c:2513
#38 0x00007f9dc782a718 in g_main_context_iterate (context=0x172d500, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.23.1/glib/gmain.c:2591
#39 0x00007f9dc782a840 in IA__g_main_context_iteration (context=0x172d500, may_block=1) at /build/buildd/glib2.0-2.23.1/glib/gmain.c:2654
#40 0x00007f9dcc218053 in QEventDispatcherGlib::processEvents (this=0x16a0460, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#41 0x00007f9dcb4423de in QGuiEventDispatcherGlib::processEvents (this=0x7fff4a93de60, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#42 0x00007f9dcc1ed3e2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#43 0x00007f9dcc1ed7bc in QEventLoop::exec (this=0x7fff4a940160, flags=) at kernel/qeventloop.cpp:201
#44 0x00007f9dcc1f14fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#45 0x00007f9dbff2dead in kdemain () from /usr/lib/libkdeinit4_kate.so
#46 0x0000000000406fb8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=1, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4a1 "0") at ../../kinit/kinit.cpp:705
#47 0x0000000000407c70 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1197
#48 0x0000000000408121 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1390
#49 0x0000000000408dea in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1825

This bug may be a duplicate of or related to bug 200450.

Possible duplicates by query: bug 220289, bug 217035, bug 213512, bug 212269, bug 211667.

Reported using DrKonqi
Comment 1 Milian Wolff 2010-01-08 19:37:38 UTC
merging with 200450

*** This bug has been marked as a duplicate of bug 200450 ***