Bug 223836 - KWrite crashed when I made some undo after a "Search and replace"
Summary: KWrite crashed when I made some undo after a "Search and replace"
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: kwrite (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-22 19:43 UTC by Unknown
Modified: 2010-01-22 19:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2010-01-22 19:43:29 UTC
Application: kwrite (4.3.90 (KDE 4.3.90 (KDE 4.4 RC1)) "release 212")
KDE Platform Version: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1)) "release 212"
Qt Version: 4.6.1
Operating System: Linux 2.6.31.8-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
I used KWrite to search and replace "\n\n" (regexp) to "\n" then I made a full undo. After I did it with escape sequences and I tried to undo this but after the first "Ctrl+Z" KWrite crashed.

Here is the document: http://pastebin.org/80450
(First I deleted all the unnecessary lines with the following regexp: "^[^T].*")

DrKonqi says it a duplicate of 200450, but now I don't have any Samba shares nor I wanted to quit from the program.

 -- Backtrace:
Application: KWrite (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6b4210e7f0 (LWP 11475))]

Thread 2 (Thread 0x7f6b2e6b3910 (LWP 11476)):
#0  0x00007f6b403ba049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6b2eab1656 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f6b2ed8f220) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x00007f6b2eab1699 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f6b2ed9d2ec) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00007f6b403b565d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6b3f1ac14d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6b4210e7f0 (LWP 11475)):
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0xba83b0, pos=..., internal=true) at /usr/src/debug/kdelibs-4.3.90/kate/smart/katesmartcursor.cpp:186
#6  0x00007f6b2f12accf in KateSmartCursor::translate (this=0xba83b0, edit=...) at /usr/src/debug/kdelibs-4.3.90/kate/smart/katesmartcursor.cpp:305
#7  0x00007f6b2f130cfc in KateSmartGroup::translateChanged (this=0x1365a20, edit=...) at /usr/src/debug/kdelibs-4.3.90/kate/smart/katesmartmanager.cpp:467
#8  0x00007f6b2f133edb in KateSmartManager::slotTextChanged (this=0x9e3c00, edit=0x1315830) at /usr/src/debug/kdelibs-4.3.90/kate/smart/katesmartmanager.cpp:371
#9  0x00007f6b2f13425c in KateSmartManager::qt_metacall (this=0x9e3c00, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa7a25390)
    at /usr/src/debug/kdelibs-4.3.90/build/kate/katesmartmanager.moc:80
#10 0x00007f6b4074a03f in QMetaObject::activate (sender=0x9ec720, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1357c48) at kernel/qobject.cpp:3267
#11 0x00007f6b2f0f161f in KateEditHistory::editDone (this=0x7fffa7a250f0, _t1=0x1315830) at /usr/src/debug/kdelibs-4.3.90/build/kate/kateedit.moc:84
#12 0x00007f6b2f0d9182 in KateDocument::editInsertLine (this=0x7fb4c0, line=<value optimized out>, s=<value optimized out>, editSource=<value optimized out>)
    at /usr/src/debug/kdelibs-4.3.90/kate/document/katedocument.cpp:1440
#13 0x00007f6b2f0f358f in KateUndoGroup::undo (this=0x1280370) at /usr/src/debug/kdelibs-4.3.90/kate/undo/kateundo.cpp:215
#14 0x00007f6b2f0f4779 in KateUndoManager::undo (this=0x9e1250) at /usr/src/debug/kdelibs-4.3.90/kate/undo/kateundomanager.cpp:232
#15 0x00007f6b2f0e5e33 in undo (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.90/kate/document/katedocument.cpp:1538
#16 KateDocument::qt_metacall (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.90/build/kate/katedocument.moc:346
#17 0x00007f6b4074a03f in QMetaObject::activate (sender=0xa7fa50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1357c48) at kernel/qobject.cpp:3267
#18 0x00007f6b3f8f8782 in QAction::triggered (this=0x7fffa7a250f0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#19 0x00007f6b3f8fa7fb in QAction::activate (this=0xa7fa50, event=<value optimized out>) at kernel/qaction.cpp:1251
#20 0x00007f6b3f8fc107 in QAction::event (this=0x7fffa7a250f0, e=<value optimized out>) at kernel/qaction.cpp:1177
#21 0x00007f6b40d7530d in KAction::event (this=0x7fffa7a250f0, event=0x7fffa7a25d00) at /usr/src/debug/kdelibs-4.3.90/kdeui/actions/kaction.cpp:129
#22 0x00007f6b3f8fe7ec in QApplicationPrivate::notify_helper (this=0x680550, receiver=0xa7fa50, e=0x7fffa7a25d00) at kernel/qapplication.cpp:4297
#23 0x00007f6b3f904dcb in QApplication::notify (this=0x7fffa7a27360, receiver=0xa7fa50, e=0x7fffa7a25d00) at kernel/qapplication.cpp:4180
#24 0x00007f6b40c08806 in KApplication::notify (this=0x7fffa7a27360, receiver=0xa7fa50, event=0x7fffa7a25d00) at /usr/src/debug/kdelibs-4.3.90/kdeui/kernel/kapplication.cpp:302
#25 0x00007f6b4073725c in QCoreApplication::notifyInternal (this=0x7fffa7a27360, receiver=0xa7fa50, event=0x7fffa7a25d00) at kernel/qcoreapplication.cpp:704
#26 0x00007f6b3f93a536 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#27 QShortcutMap::dispatchEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qshortcutmap.cpp:879
#28 0x00007f6b3f93c337 in QShortcutMap::tryShortcutEvent (this=0x680678, o=<value optimized out>, e=0x7fffa7a26300) at kernel/qshortcutmap.cpp:364
#29 0x00007f6b3f906913 in QApplication::notify (this=0x7fffa7a27360, receiver=0x9f6830, e=0x7fffa7a26300) at kernel/qapplication.cpp:3743
#30 0x00007f6b40c08806 in KApplication::notify (this=0x7fffa7a27360, receiver=0x9f6830, event=0x7fffa7a26300) at /usr/src/debug/kdelibs-4.3.90/kdeui/kernel/kapplication.cpp:302
#31 0x00007f6b4073725c in QCoreApplication::notifyInternal (this=0x7fffa7a27360, receiver=0x9f6830, event=0x7fffa7a26300) at kernel/qcoreapplication.cpp:704
#32 0x00007f6b3f9a74fa in QKeyMapper::sendKeyEvent (keyWidget=0x9f6830, grab=<value optimized out>, type=KeyPress, code=90, modifiers=<value optimized out>, text=..., autorepeat=false, count=1, 
    nativeScanCode=29, nativeVirtualKey=122, nativeModifiers=4) at kernel/qkeymapper_x11.cpp:1861
#33 0x00007f6b3f9a9a70 in QKeyMapperPrivate::translateKeyEvent (this=0x6c0340, keyWidget=0x9f6830, event=<value optimized out>, grab=202) at kernel/qkeymapper_x11.cpp:1831
#34 0x00007f6b3f9827c4 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffa7a26ed0) at kernel/qapplication_x11.cpp:3394
#35 0x00007f6b3f9acc02 in x11EventSourceDispatch (s=0x684350, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007f6b3b9bbdde in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#37 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#38 0x00007f6b3b9bf7a8 in g_main_context_iterate (context=0x683120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#39 0x00007f6b3b9bf8d0 in IA__g_main_context_iteration (context=0x683120, may_block=1) at gmain.c:2654
#40 0x00007f6b407607e3 in QEventDispatcherGlib::processEvents (this=0x61b770, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#41 0x00007f6b3f9ac7ee in QGuiEventDispatcherGlib::processEvents (this=0x7fffa7a250f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007f6b40735b72 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#43 0x00007f6b40735f4c in QEventLoop::exec (this=0x7fffa7a27200, flags=) at kernel/qeventloop.cpp:201
#44 0x00007f6b40739c9b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#45 0x00007f6b34b4609d in kdemain () from /usr/lib64/libkdeinit4_kwrite.so
#46 0x00000000004073b8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=1, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x665b45 "linux-suse;1264185119;872463;2256_TIME17643123") at /usr/src/debug/kdelibs-4.3.90/kinit/kinit.cpp:706
#47 0x0000000000408070 in handle_launcher_request (sock=7, who=<value optimized out>) at /usr/src/debug/kdelibs-4.3.90/kinit/kinit.cpp:1198
#48 0x0000000000408521 in handle_requests (waitForPid=0) at /usr/src/debug/kdelibs-4.3.90/kinit/kinit.cpp:1391
#49 0x00000000004091ea in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/kdelibs-4.3.90/kinit/kinit.cpp:1830

Possible duplicates by query: bug 221835, bug 220289, bug 217035, bug 213512, bug 212269.

Reported using DrKonqi
Comment 1 Milian Wolff 2010-01-22 19:53:00 UTC

*** This bug has been marked as a duplicate of bug 200450 ***