Bug 220289 - Kate crash when pressing enter
Summary: Kate crash when pressing enter
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-27 17:21 UTC by jerome.frgacic
Modified: 2009-12-27 19:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerome.frgacic 2009-12-27 17:21:04 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was editing an HTML file and when i pressed enter to create a new line kate crashed.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x119cea0, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007f8e5f75e0cf in KateSmartCursor::translate (this=0x119cea0, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007f8e5f76335c in KateSmartGroup::translateChanged (this=0x1d51130, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#8  0x00007f8e5f766a9b in KateSmartManager::slotTextChanged (this=0xd90f60, edit=0x13341f0) at ../../kate/smart/katesmartmanager.cpp:368
#9  0x00007f8e5f766e1c in KateSmartManager::qt_metacall (this=0xd90f60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb3ca2ba0) at ./katesmartmanager.moc:74
#10 0x00007f8e6e410ddc in QMetaObject::activate (sender=0xd75be0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x119cea0) at kernel/qobject.cpp:3113
#11 0x00007f8e5f738b5f in KateEditHistory::editDone (this=0x7fffb3ca2900, _t1=0x13341f0) at ./kateedit.moc:78
#12 0x00007f8e5f724d26 in KateDocument::editWrapLine (this=0xd1df00, line=321, col=0, newLine=<value optimized out>, newLineAdded=<value optimized out>) at ../../kate/document/katedocument.cpp:1281
#13 0x00007f8e5f726829 in KateDocument::newLine (this=0xd1df00, v=0xdb9e80) at ../../kate/document/katedocument.cpp:3877
#14 0x00007f8e5f7aada1 in KateViewInternal::doReturn (this=0x10f2320) at ../../kate/view/kateviewinternal.cpp:808
#15 0x00007f8e5f7ab48d in KateViewInternal::keyPressEvent (this=0x10f2320, e=0x7fffb3ca34d0) at ../../kate/view/kateviewinternal.cpp:2381
#16 0x00007f8e5f7aa7cc in KateViewInternal::eventFilter (this=0x10f2320, obj=0x10f2320, e=0x7fffb3ca34d0) at ../../kate/view/kateviewinternal.cpp:2250
#17 0x00007f8e6e3faf47 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x10f2320, event=0x7fffb3ca34d0) at kernel/qcoreapplication.cpp:726
#18 0x00007f8e6c3abecc in QApplicationPrivate::notify_helper (this=0xb5a100, receiver=0x10f2320, e=0x7fffb3ca34d0) at kernel/qapplication.cpp:4052
#19 0x00007f8e6c3b3ce3 in QApplication::notify (this=<value optimized out>, receiver=0x10f2320, e=0x7fffb3ca34d0) at kernel/qapplication.cpp:3662
#20 0x00007f8e6cfe2ab6 in KApplication::notify (this=0x7fffb3ca56e0, receiver=0x10f2320, event=0x7fffb3ca34d0) at ../../kdeui/kernel/kapplication.cpp:302
#21 0x00007f8e6e3fbc2c in QCoreApplication::notifyInternal (this=0x7fffb3ca56e0, receiver=0x10f2320, event=0x7fffb3ca34d0) at kernel/qcoreapplication.cpp:610
#22 0x00007f8e6c43cdfa in QKeyMapper::sendKeyEvent (keyWidget=0x10f2320, grab=<value optimized out>, type=QEvent::KeyPress, code=16777220, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#23 0x00007f8e6c43f370 in QKeyMapperPrivate::translateKeyEvent (this=0xb8dfe0, keyWidget=0x10f2320, event=<value optimized out>, grab=70) at kernel/qkeymapper_x11.cpp:1831
#24 0x00007f8e6c417493 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffb3ca52b0) at kernel/qapplication_x11.cpp:3443
#25 0x00007f8e6c440d0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x00007f8e6b2dcbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x00007f8e6b2e0598 in ?? () from /lib/libglib-2.0.so.0
#28 0x00007f8e6b2e06c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x00007f8e6e4241a6 in QEventDispatcherGlib::processEvents (this=0xabe040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#30 0x00007f8e6c4404be in QGuiEventDispatcherGlib::processEvents (this=0x7fffb3ca2900, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#31 0x00007f8e6e3fa532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#32 0x00007f8e6e3fa904 in QEventLoop::exec (this=0x7fffb3ca55e0, flags=) at kernel/qeventloop.cpp:201
#33 0x00007f8e6e3fcab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#34 0x00007f8e627c2d2d in kdemain () from /usr/lib/libkdeinit4_kate.so
#35 0x0000000000406da8 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0xb03f8d "Adalbert;1261929464;958737;1833_TIME233069") at ../../kinit/kinit.cpp:677
#36 0x0000000000407aa0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#37 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#38 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dominik Haumann 2009-12-27 19:30:28 UTC
Known issue, but unfortunately no solution yet, it seems.

*** This bug has been marked as a duplicate of bug 200450 ***