Bug 217035 - kate segfault stack trace
Summary: kate segfault stack trace
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-02 10:17 UTC by Will Murnane
Modified: 2009-12-02 16:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Will Murnane 2009-12-02 10:17:37 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x180e760, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007f8b2fb2e780 in KateSmartCursor::translate (this=0x180e760, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007f8b2fb33f04 in KateSmartGroup::translateChanged (this=0x1511e60, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#8  0x00007f8b2fb3766b in KateSmartManager::slotTextChanged (this=0xde5cf0, edit=0x13288b0) at ../../kate/smart/katesmartmanager.cpp:368
#9  0x00007f8b2fb37a0f in KateSmartManager::qt_metacall (this=0xde5cf0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff35b3deb0) at ./katesmartmanager.moc:74
#10 0x00007f8b41eb0df2 in QMetaObject::activate (sender=0xe18910, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x11) at kernel/qobject.cpp:3112
#11 0x00007f8b2fb096ef in KateEditHistory::editDone (this=0x7fff35b3dc30, _t1=0x13288b0) at ./kateedit.moc:78
#12 0x00007f8b2faf45ed in KateDocument::editWrapLine (this=0xf575b0, line=186, col=0, newLine=<value optimized out>, newLineAdded=0x0) at ../../kate/document/katedocument.cpp:1281
#13 0x00007f8b2faf61aa in KateDocument::newLine (this=0xf575b0, v=0x1414480) at ../../kate/document/katedocument.cpp:3877
#14 0x00007f8b2fb7b501 in KateViewInternal::doReturn (this=0x14187b0) at ../../kate/view/kateviewinternal.cpp:808
#15 0x00007f8b2fb7bbf9 in KateViewInternal::keyPressEvent (this=0x14187b0, e=0x7fff35b3e870) at ../../kate/view/kateviewinternal.cpp:2381
#16 0x00007f8b2fb7af13 in KateViewInternal::eventFilter (this=0x14187b0, obj=0x14187b0, e=0x7fff35b3e870) at ../../kate/view/kateviewinternal.cpp:2250
#17 0x00007f8b41e9afb8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x14187b0, event=0x7fff35b3e870) at kernel/qcoreapplication.cpp:726
#18 0x00007f8b3fe24fec in QApplicationPrivate::notify_helper (this=0x9a4130, receiver=0x14187b0, e=0x7fff35b3e870) at kernel/qapplication.cpp:4061
#19 0x00007f8b3fe2df7f in QApplication::notify (this=<value optimized out>, receiver=0x14187b0, e=0x7fff35b3e870) at kernel/qapplication.cpp:3664
#20 0x00007f8b40a7e0db in KApplication::notify (this=0x7fff35b40ac0, receiver=0x14187b0, event=0x7fff35b3e870) at ../../kdeui/kernel/kapplication.cpp:302
#21 0x00007f8b41e9bc9c in QCoreApplication::notifyInternal (this=0x7fff35b40ac0, receiver=0x14187b0, event=0x7fff35b3e870) at kernel/qcoreapplication.cpp:610
#22 0x00007f8b3feb8ab4 in QKeyMapper::sendKeyEvent (keyWidget=0x14187b0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777220, modifiers=..., text=..., autorepeat=false, count=1, 
    nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#23 0x00007f8b3febad89 in QKeyMapperPrivate::translateKeyEvent (this=0x9d8640, keyWidget=0x14187b0, event=0x7fff35b40670, grab=190) at kernel/qkeymapper_x11.cpp:1831
#24 0x00007f8b3fe93d06 in QApplication::x11ProcessEvent (this=0x7fff35b40ac0, event=0x7fff35b40670) at kernel/qapplication_x11.cpp:3445
#25 0x00007f8b3febc76c in x11EventSourceDispatch (s=0x9a7d10, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x00007f8b3ed3d12a in g_main_dispatch (context=0x9a6920) at /tmp/buildd/glib2.0-2.22.2/glib/gmain.c:1960
#27 IA__g_main_context_dispatch (context=0x9a6920) at /tmp/buildd/glib2.0-2.22.2/glib/gmain.c:2513
#28 0x00007f8b3ed40988 in g_main_context_iterate (context=0x9a6920, block=1, dispatch=1, self=<value optimized out>) at /tmp/buildd/glib2.0-2.22.2/glib/gmain.c:2591
#29 0x00007f8b3ed40b3c in IA__g_main_context_iteration (context=0x9a6920, may_block=1) at /tmp/buildd/glib2.0-2.22.2/glib/gmain.c:2654
#30 0x00007f8b41ec439c in QEventDispatcherGlib::processEvents (this=0x8fe850, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#31 0x00007f8b3febbf1f in QGuiEventDispatcherGlib::processEvents (this=0x7fff35b3dc30, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007f8b41e9a562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f8b41e9a934 in QEventLoop::exec (this=0x7fff35b409a0, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007f8b41e9cba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x00007f8b3618fd9d in kdemain () from /usr/lib/libkdeinit4_kate.so
#36 0x0000000000407264 in launch (argc=1, _name=0x94f468 "/usr/bin/kate", args=<value optimized out>, cwd=0x0, envc=1, envs=0x94f48a "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x94f493 "sun;1259741020;292163;3867_TIME1743461677") at ../../kinit/kinit.cpp:677
#37 0x0000000000407a28 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#38 0x0000000000407fae in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#39 0x000000000040863b in main (argc=1, argv=0x7fff35b42858, envp=0x7fff35b42868) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 212269

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-02 16:58:00 UTC

*** This bug has been marked as a duplicate of bug 200450 ***