Bug 212269 - Kate crashed when editing a python file
Summary: Kate crashed when editing a python file
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-29 10:41 UTC by Børre Gaup
Modified: 2009-10-29 14:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Børre Gaup 2009-10-29 10:41:33 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was editing a remote file opened via the sftp protocol in Dolphin.
I edited the file, saved it, and changed cursor position when Kate crashed.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x01cb3e6a in KateSmartCursor::setPositionInternal (this=0x99fb578, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0x01cb4242 in KateSmartCursor::translate (this=0x99fb578, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x01cb96af in KateSmartGroup::translateChanged (this=0x9a5d390, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#9  0x01cbcfcf in KateSmartManager::slotTextChanged (this=0x96ed218, edit=0x9c58e60) at ../../kate/smart/katesmartmanager.cpp:368
#10 0x01cbd38f in KateSmartManager::qt_metacall (this=0x96ed218, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfc0cb58) at ./katesmartmanager.moc:74
#11 0x00265263 in QMetaObject::activate (sender=0x973f498, from_signal_index=4, to_signal_index=4, argv=0xbfc0cb58) at kernel/qobject.cpp:3113
#12 0x00265ec2 in QMetaObject::activate (sender=0x973f498, m=0x1dc8b64, local_signal_index=0, argv=0xbfc0cb58) at kernel/qobject.cpp:3187
#13 0x01c8b523 in KateEditHistory::editDone (this=0x973f498, _t1=0x9c58e60) at ./kateedit.moc:78
#14 0x01c75f22 in KateDocument::editWrapLine (this=0x96ed808, line=207, col=31, newLine=true, newLineAdded=0x0) at ../../kate/document/katedocument.cpp:1281
#15 0x01c77b1c in KateDocument::newLine (this=0x96ed808, v=0x98eb308) at ../../kate/document/katedocument.cpp:3877
#16 0x01d09bcc in KateViewInternal::doReturn (this=0x996c258) at ../../kate/view/kateviewinternal.cpp:808
#17 0x01d0a2f0 in KateViewInternal::keyPressEvent (this=0x996c258, e=0xbfc0d1e4) at ../../kate/view/kateviewinternal.cpp:2381
#18 0x01d094e9 in KateViewInternal::eventFilter (this=0x996c258, obj=0x996c258, e=0xbfc0d1e4) at ../../kate/view/kateviewinternal.cpp:2250
#19 0x0024e83a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9588230, receiver=0x996c258, event=0xbfc0d1e4) at kernel/qcoreapplication.cpp:726
#20 0x029fef2c in QApplicationPrivate::notify_helper (this=0x9588230, receiver=0x996c258, e=0xbfc0d1e4) at kernel/qapplication.cpp:4052
#21 0x02a07778 in QApplication::notify (this=0xbfc0ed8c, receiver=0x996c258, e=0xbfc0d1e4) at kernel/qapplication.cpp:3662
#22 0x01099bfa in KApplication::notify (this=0xbfc0ed8c, receiver=0x996c258, event=0xbfc0d1e4) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x0024f6cb in QCoreApplication::notifyInternal (this=0xbfc0ed8c, receiver=0x996c258, event=0xbfc0d1e4) at kernel/qcoreapplication.cpp:610
#24 0x029ffe2e in QCoreApplication::sendSpontaneousEvent (receiver=0x996c258, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#25 qt_sendSpontaneousEvent (receiver=0x996c258, event=0x0) at kernel/qapplication.cpp:4958
#26 0x02a9c440 in QKeyMapper::sendKeyEvent (keyWidget=0x996c258, grab=false, type=QEvent::KeyPress, code=16777220, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=16384) at kernel/qkeymapper_x11.cpp:1861
#27 0x02a9e989 in QKeyMapperPrivate::translateKeyEvent (this=0x95ae748, keyWidget=0x996c258, event=0xbfc0e9cc, grab=217) at kernel/qkeymapper_x11.cpp:1831
#28 0x02a72ed7 in QApplication::x11ProcessEvent (this=0xbfc0ed8c, event=0xbfc0e9cc) at kernel/qapplication_x11.cpp:3443
#29 0x02aa0502 in x11EventSourceDispatch (s=0x9589970, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00a29e78 in g_main_dispatch (context=0x9584b38) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:1960
#31 IA__g_main_context_dispatch (context=0x9584b38) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2513
#32 0x00a2d720 in g_main_context_iterate (context=0x9584b38, block=<value optimized out>, dispatch=1, self=0x95850c8) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2591
#33 0x00a2d853 in IA__g_main_context_iteration (context=0x9584b38, may_block=1) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2654
#34 0x0027a02c in QEventDispatcherGlib::processEvents (this=0x9586e18, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#35 0x02a9fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x9586e18, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#36 0x0024dc79 in QEventLoop::processEvents (this=0xbfc0ecc4, flags=) at kernel/qeventloop.cpp:149
#37 0x0024e0ca in QEventLoop::exec (this=0xbfc0ecc4, flags=...) at kernel/qeventloop.cpp:201
#38 0x0025053f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0x029fedd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#40 0x0219bb0d in kdemain () from /usr/lib/libkdeinit4_kate.so
#41 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x9557342 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x9557353 "kross-laptop;1256808153;529849;7076_TIME829922") at ../../kinit/kinit.cpp:677
#42 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#43 0x0804eeac in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1362
#44 0x0804fbaf in main (argc=2, argv=0xbfc0f9a4, envp=0xbfc0f9b0) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 210762

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-29 14:22:48 UTC
Merging with bug 200450. Thanks

*** This bug has been marked as a duplicate of bug 200450 ***