Bug 211667 - kate crashed after saving
Summary: kate crashed after saving
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-24 17:46 UTC by Thomas Rehn
Modified: 2009-10-24 18:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Rehn 2009-10-24 17:46:58 UTC
Application that crashed: kate
Version of the application: 3.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I pressed Ctrl-V to paste a string into a document and Ctrl-S shortly after that to save the document. Immediately after Ctrl-S kate crashed.

 -- Backtrace:
Application: Kate (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x02537e6a in KateSmartCursor::setPositionInternal (this=0xb13f4d4, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0x02538242 in KateSmartCursor::translate (this=0xb13f4d4, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x0253d6af in KateSmartGroup::translateChanged (this=0xb1a7d60, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#9  0x02540fcf in KateSmartManager::slotTextChanged (this=0x906fcc0, edit=0xb123748) at ../../kate/smart/katesmartmanager.cpp:368
#10 0x0254138f in KateSmartManager::qt_metacall (this=0x906fcc0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfdfc978) at ./katesmartmanager.moc:74
#11 0x00c54263 in QMetaObject::activate (sender=0x9917bd0, from_signal_index=4, to_signal_index=4, argv=0xbfdfc978) at kernel/qobject.cpp:3113
#12 0x00c54ec2 in QMetaObject::activate (sender=0x9917bd0, m=0x264cb64, local_signal_index=0, argv=0xbfdfc978) at kernel/qobject.cpp:3187
#13 0x0250f523 in KateEditHistory::editDone (this=0x9917bd0, _t1=0xb123748) at ./kateedit.moc:78
#14 0x024f9f22 in KateDocument::editWrapLine (this=0x9c9fd80, line=42, col=6, newLine=true, newLineAdded=0x0) at ../../kate/document/katedocument.cpp:1281
#15 0x024fbb1c in KateDocument::newLine (this=0x9c9fd80, v=0xb1404c0) at ../../kate/document/katedocument.cpp:3877
#16 0x0258dbcc in KateViewInternal::doReturn (this=0xb13f480) at ../../kate/view/kateviewinternal.cpp:808
#17 0x0258e2f0 in KateViewInternal::keyPressEvent (this=0xb13f480, e=0xbfdfd004) at ../../kate/view/kateviewinternal.cpp:2381
#18 0x0258d4e9 in KateViewInternal::eventFilter (this=0xb13f480, obj=0xb13f480, e=0xbfdfd004) at ../../kate/view/kateviewinternal.cpp:2250
#19 0x00c3d83a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x870c420, receiver=0xb13f480, event=0xbfdfd004) at kernel/qcoreapplication.cpp:726
#20 0x0438ef2c in QApplicationPrivate::notify_helper (this=0x870c420, receiver=0xb13f480, e=0xbfdfd004) at kernel/qapplication.cpp:4052
#21 0x04397778 in QApplication::notify (this=0xbfdfebac, receiver=0xb13f480, e=0xbfdfd004) at kernel/qapplication.cpp:3662
#22 0x011a1bfa in KApplication::notify (this=0xbfdfebac, receiver=0xb13f480, event=0xbfdfd004) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00c3e6cb in QCoreApplication::notifyInternal (this=0xbfdfebac, receiver=0xb13f480, event=0xbfdfd004) at kernel/qcoreapplication.cpp:610
#24 0x0438fe2e in QCoreApplication::sendSpontaneousEvent (receiver=0xb13f480, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#25 qt_sendSpontaneousEvent (receiver=0xb13f480, event=0x0) at kernel/qapplication.cpp:4958
#26 0x0442c440 in QKeyMapper::sendKeyEvent (keyWidget=0xb13f480, grab=false, type=QEvent::KeyPress, code=16777220, modifiers=..., text=..., autorepeat=<value optimized out>, 
    count=<value optimized out>, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1861
#27 0x0442e989 in QKeyMapperPrivate::translateKeyEvent (this=0x87341b0, keyWidget=0xb13f480, event=0xbfdfe7ec, grab=44) at kernel/qkeymapper_x11.cpp:1831
#28 0x04402ed7 in QApplication::x11ProcessEvent (this=0xbfdfebac, event=0xbfdfe7ec) at kernel/qapplication_x11.cpp:3443
#29 0x04430502 in x11EventSourceDispatch (s=0x870f400, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x009cae78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x009ce720 in ?? () from /lib/libglib-2.0.so.0
#32 0x009ce853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00c6902c in QEventDispatcherGlib::processEvents (this=0x869aa58, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#34 0x0442fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x869aa58, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00c3cc79 in QEventLoop::processEvents (this=0xbfdfeae4, flags=) at kernel/qeventloop.cpp:149
#36 0x00c3d0ca in QEventLoop::exec (this=0xbfdfeae4, flags=...) at kernel/qeventloop.cpp:201
#37 0x00c3f53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x0438edd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#39 0x00af8b0d in kdemain () from /usr/lib/libkdeinit4_kate.so
#40 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x86d3ba2 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x80511a5 "0") at ../../kinit/kinit.cpp:677
#41 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#42 0x0804eeac in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1362
#43 0x0804fbaf in main (argc=2, argv=0xbfdff7c4, envp=0xbfdff7d0) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 200450

Reported using DrKonqi
Comment 1 Dario Andres 2009-10-24 18:45:43 UTC
Merging with bug 200450. Thanks

*** This bug has been marked as a duplicate of bug 200450 ***