Bug 217817 - kwin crashed closing konqueror [KWin::Scene::Window::buildQuads, KWin::Scene::paintSimpleScreen, KWin::Scene::finalPaintScreen]
Summary: kwin crashed closing konqueror [KWin::Scene::Window::buildQuads, KWin::Scene:...
Status: RESOLVED DUPLICATE of bug 216908
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-08 05:08 UTC by Andrey Borzenkov
Modified: 2009-12-08 09:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Borzenkov 2009-12-08 05:08:14 UTC
Application: kwin (4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)))
KDE Platform Version: 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31.6-desktop-2mnb x86_64
Distribution: "Mandriva Linux 2010.0"

-- Information about the crash:
I just pressed close button on konqueror window and kwin crashed. Konqueror window was properly closed. Using nVidia binary drivers with effects enabled.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#5  KWin::Scene::Window::buildQuads (this=0x1b26ed0, force=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:485
#6  0x00007fcf93e2e3ac in KWin::Scene::paintSimpleScreen (this=0x141e390, orig_mask=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:237
#7  0x00007fcf93e2be05 in KWin::Scene::finalPaintScreen (this=0x141e390, mask=8, region=<value optimized out>, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:176
#8  0x00007fcf93e42cb6 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:126
#9  0x00007fcf7db4042f in KWin::LogoutEffect::paintScreen (this=0x1519570, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/logout/logout.cpp:196
#10 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#11 0x00007fcf7db5f610 in KWin::ShadowEffect::paintScreen (this=0x14eafe0, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/shadow/shadow.cpp:182
#12 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#13 0x00007fcf7db46b02 in KWin::PresentWindowsEffect::paintScreen (this=0x15088b0, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/presentwindows/presentwindows.cpp:191
#14 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#15 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#16 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#17 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#18 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#19 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#20 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#21 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#22 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#23 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#24 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#25 0x00007fcf7db2c772 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/desktopgrid/desktopgrid.cpp:151
#26 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#27 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#28 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#29 0x00007fcf7db790c2 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/cube/cube.cpp:697
#30 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#31 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#32 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#33 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#34 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#35 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#36 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#37 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#38 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#39 0x00007fcf9266141f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/lib/kwineffects.cpp:227
#40 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#41 0x00007fcf7db8e9ea in KWin::MouseMarkEffect::paintScreen (this=0x14a5e50, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/mousemark/mousemark.cpp:78
#42 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#43 0x00007fcf7db6b353 in KWin::ThumbnailAsideEffect::paintScreen (this=0x14da4e0, mask=8, region=<value optimized out>, data=@0x7fff5bc10710)
    at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/thumbnailaside/thumbnailaside.cpp:56
#44 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#45 0x00007fcf7db96025 in KWin::TrackMouseEffect::paintScreen (this=0x15479a0, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects/trackmouse/trackmouse.cpp:71
#46 0x00007fcf93e42d4e in KWin::EffectsHandlerImpl::paintScreen (this=0x1491d60, mask=8, region=) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/effects.cpp:122
#47 0x00007fcf93e2df15 in KWin::Scene::paintScreen (this=0x141e390, mask=0x7fff5bc1088c, region=0x7fff5bc109b0) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene.cpp:134
#48 0x00007fcf93e3c5e0 in KWin::SceneOpenGL::paint (this=0x141e390, damage=<value optimized out>, toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/scene_opengl.cpp:747
#49 0x00007fcf93e288b7 in KWin::Workspace::performCompositing (this=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/composite.cpp:424
#50 0x00007fcf93db3fae in KWin::Workspace::qt_metacall (this=0x1441e80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5bc10b60)
    at /usr/src/debug/kdebase-workspace-4.3.80/build/kwin/workspace.moc:535
#51 0x00007fcf8fa20ec3 in QMetaObject::activate (sender=0x14422f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x258) at kernel/qobject.cpp:3286
#52 0x00007fcf8fa1db33 in QObject::event (this=0x14422f0, e=0x7fff5bc11220) at kernel/qobject.cpp:1216
#53 0x00007fcf9014540c in QApplicationPrivate::notify_helper (this=0x1201a30, receiver=0x14422f0, e=0x7fff5bc11220) at kernel/qapplication.cpp:4242
#54 0x00007fcf9014ba2d in QApplication::notify (this=0x7fff5bc11580, receiver=0x14422f0, e=0x7fff5bc11220) at kernel/qapplication.cpp:4125
#55 0x00007fcf935ff956 in KApplication::notify (this=0x7fff5bc11580, receiver=0x14422f0, event=0x7fff5bc11220) at /usr/src/debug/kdelibs-4.3.80/kdeui/kernel/kapplication.cpp:302
#56 0x00007fcf8fa0e16c in QCoreApplication::notifyInternal (this=0x7fff5bc11580, receiver=0x14422f0, event=0x7fff5bc11220) at kernel/qcoreapplication.cpp:704
#57 0x00007fcf8fa3ae52 in QTimerInfoList::activateTimers (this=0x12057f0) at kernel/qcoreapplication.h:215
#58 0x00007fcf8fa37a58 in idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#59 0x00007fcf891354be in IA__g_main_context_dispatch (context=0x12044c0) at gmain.c:1960
#60 0x00007fcf89138e88 in g_main_context_iterate (context=0x12044c0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#61 0x00007fcf89138fb0 in IA__g_main_context_iteration (context=0x12044c0, may_block=1) at gmain.c:2654
#62 0x00007fcf8fa37723 in QEventDispatcherGlib::processEvents (this=0x11f8230, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#63 0x00007fcf901f266e in QGuiEventDispatcherGlib::processEvents (this=0x7fff5bc0ec00, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#64 0x00007fcf8fa0ca92 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#65 0x00007fcf8fa0ce6c in QEventLoop::exec (this=0x7fff5bc114c0, flags=) at kernel/qeventloop.cpp:201
#66 0x00007fcf8fa10bab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#67 0x00007fcf93dcd59e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.3.80/kwin/main.cpp:526
#68 0x00007fcf93a33afd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff5bc11a88) at libc-start.c:226
#69 0x0000000000400649 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 195104.

Possible duplicates by query: bug 217761, bug 217552, bug 217461, bug 216813, bug 216609.

Reported using DrKonqi
Comment 1 lucas 2009-12-08 05:18:01 UTC

*** This bug has been marked as a duplicate of bug 195104 ***
Comment 2 Martin Flöser 2009-12-08 09:46:56 UTC

*** This bug has been marked as a duplicate of bug 216908 ***